1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

A8-5600k stuck at 1400mhz and .924v

By WilhelmPrice
Jun 3, 2014
Post New Reply
  1. Hi so for starters this is my rig
    AMD A8-5600K Quadcore
    Gigabyte F2A75M D3H rev 1.1(motherboard)
    2X2 GB Corsair Gaming Memory DDR3 RAM
    PowerColor HD7770 1GB
    1.75 TB HDDs

    So anyway I've noticed that my performance was pretty strangely bad with games these days, I just haven't had much time to play but now it became terribly clear, some games like Outlast and Dark Souls had low fps at times, my friend's PC which has an AMD 3.0ghz dual core processor and a 9800GT with 6GB RAM does far better, he can run Outlast all very high with stable FPS, I've rocking it at medium and it still dips to 20 fps.

    Both of us were puzzled by this because HD7770 is far superior to 9800GT, and the A8-5600K can clearly be seen in benchmarks everywhere to outperform that processor of his significantly as well.

    After doing a stress test of my A8-5600k with prime95 or even AMD Overdrive torture tests, either Overdrive or CPU-Z would display that the clock speed is only 1400mhz and the voltage is 0.924 or a bit more like 0.94x, and it would just be stuck like that during the tests. So it points to my processor not running like it should.

    So maybe it's my board, I've disabled C6, APM, cool n quiet, set turbo to 4ghz in BIOS, it's still does the same thing. I've even tried disabling turbo and overclocking with the BIOS to 4.1ghz or even 3.8 ghz as well, still stuck at 1400mhz. Game performance still weirdly bad

    What should I do?
  2. Spykezxp

    Spykezxp TS Addict Posts: 296   +73

    Do you have the ability to disable the onboard graphics for the A8-5600K from within your Bios (or) change the graphics over to PCI-E only? Also, check the Windows Power Management and make sure that it is not limiting the maximum cpu percentage (or set to balanced or power saver modes - you want Performance mode). Not the only solutions, but try these first and see what happens.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...