Able to create folders but not files on USB drives

By wardy3 ยท 8 replies
Mar 16, 2009
  1. Hi all

    Weird problem that's driving me insane =:-}

    If I put an external USB drive (I've tried a 200gb 2.5"; 16gb brand new USB key, 1gb friend's USB key) into my Dell D610 XP laptop, I am unable to do any update activity on files.

    So, the following doesn't work:

    • right click, select New -> Text Document
    • renaming a file
    • touch a file using Cygwin
    • copying a file from the internal drive to the USB drive

    If I try, I get Unable to create file blahblah. Access is denied. Copying a file to the USB key gives me "Cannot copy blah blah: Access is Denied. Make sure the disk is not full or write protected" and that the file is not currently in use.

    I've tried all sorts of files and I get the same error.

    But these will work, leading me to believe it's not a write-protect problem:

    • Right click, select New -> Folder
    • rename folders, even if they contain files
    • mkdir a folder from Cygwin
    • All the things in the list about (the doesn't-work list) on another Windows laptop

    Can anyone think of where I can start looking to see where the problem is coming from?

    Thanks in advance
    ~ Michael
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    What are your computers specs and Operating System?
  3. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

  4. wardy3

    wardy3 TS Rookie Topic Starter

    Thanks for the reply

    I'm using a dell latitude d610 and running XP SP2
    It's a corporate SOE build but we do have admin priviledge to go and install things that would wreck it! (like I probably have)

    The IT guys could probably fix it but it'll take ages and I'll be without it for too long.

    My next option is to get it re-imaged but first I need to write to my USB drive to back up my stuff!!

    ~ Michael
  5. xehqter

    xehqter TS Rookie

    Also try disabling any anti-virus programs
  6. wardy3

    wardy3 TS Rookie Topic Starter

    Thanks xehqter

    I can't do that easily because it's protected in my SOE build. But other people I work with have the same build and everything's fine.

    I did try booting into Safe Mode. And the USB file writes are fine!
    So I'm guessing it's something to do with some program interfering.

    Then I booted back to "normal" mode and tried stopping services and killing processes but that didn't help. I pretty well stopped every service I could (including McAfee Antivirus stuff) but it was no use.

    Any thoughts come to mind?
  7. wardy3

    wardy3 TS Rookie Topic Starter

    Thanks LookinAround

    I don't have any control over the SP or the patches. The SP is SP2 and the patches are periodically loaded. It did a patch reload this morning but still no difference.
    Other guys I work with that use the same hardware and OS can write files ok, so I suppose it's something I've installed but I don't know how to identify exactly what...

    The USB key is FAT32 and doesn't seem to have all the complicated permissions. In fact, if I get the properties of the key, then it doesn't even have a security tab. And would it be a permissions thing if I am able to create folders?
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I think Xehqter's suggestion disabing A/V is along the lines of "something / some program" may have some form of real-time protection/monitoring in affect. Other tools (like Spybot) may also perform real-time protection. And the fact that starting in Safe Mode (where things work fine) also reinforces this thought.

    You can either download a tool like Mike Lin's Startup Control Panel to view and control your program startups. Find which program is starting that's causing the issue.

    Other option is using msconfig in Windows (see this link)
  9. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Or give up and let your IT department fix the laptop... SOE=Standard Operating Environment. I had to look it up :eek:
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...