Access Denied - Error: 5 (while using services.msc)

By technophobic · 16 replies
Oct 9, 2009
  1. Greetings techspot,
    Ive been reading techspot for a while now and just joined cause now I have a problem maybe all you tech heads out there can solve.

    The first problem is that i do NOT have a windows disk on me, im on vacation and internet is my only resource.

    Second, After a long bout with 100's of virus's i believe my pc is now clean, but my RPC is not able to start. If i bring up Services.msc it will come up as normal but if i try to activate anything it says "Error 5: access denied". Ive done some research and came up with a few unsuccessful solutions. First was editing it through regedit and trying to turn it on in the registry, also tried associating it with my hardware profile in the registry as well, following microsofts instructions (sorry cant post link)
    and instructions left by others with my problem online. All are unsuccessful.

    Ive read something about altering my policies through gpedit.msc or secpol.msc though i have very limited experience with policies and modifying them. I have attempted to reload the default policies but to no avail.

    Since my RPC is not on, everything on my pc is limited to performing less than safemode.

    Ive searched everything everywhere using every search engine, and no help... Please someone help me. Sorry for the massive wall of text.

    [Problem 1]
    RPC not running
    [Problem 2]
    Cannot modify Services in services.msc
    [Problem 3]
    Cannot boot into safemode normally

  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    "Second, After a long bout with 100's of virus's i believe my pc is now clean"...

    No Windows install CD, and 100's of viruses... The infection damaged Windows system files... Have you tried doing a system restore? Otherwise, you need a Windows install CD and you need to reload Windows fresh
  3. technophobic

    technophobic TS Rookie Topic Starter

    System restore

    I have not, i am currently trying it now. keeps giving me the error
    "System restore is not able to protect your pc, restart and try again."
    Attempting in safe mode which btw is problem 3: trying to load safemode gives me a quick blue screen of death then restarts itself. The only way into safemode is to select "load windows domain controllers only" which i think is under Directory restore or something on the selection menu. anyhow it starts it into safemode when its done.

    Just tried it and same error: "System restore is not able to protect your pc, restart and try again." apparently it cant launch, maybe because the rpc isn't on?
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Does your userid have Admin privileges???
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    I'm afraid you are out of luck... A fresh windows install is needed. It may point to a hardware issue too
  6. technophobic

    technophobic TS Rookie Topic Starter


    Yeah i have admin privileges. I was thinking upgrade but i want windows 7 final release and am a little hesitant in downloading the candidate version... still gunna work on this for the day and see how far i can get.
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    jWhat version of windows and SP level are you running?

    Take a look at these links (if they might help)
    here and here

    To get an easier view of your services and provide a report (so i can see) download Serviwin (very handy tool for viewing /managing Windows Services and Drivers)

    > Run it and click View->Services
    > Then click Ctrl-A to select all the services, then Ctrl-C to copy the services, then Ctrl-V to paste into a .txt file
    > (to create a blank txt file: Start->Programs->Accessories->Notepad )
    > Then attach the text file to your next post (use the paper clip icon)
  8. technophobic

    technophobic TS Rookie Topic Starter

    Thanks for the help, still reading through the links you posted. good stuff but im not sure if it will help. Im trying to get the program listed as well, but my computer cannot access the internet with RPC turned off and i have no thumb drive >.< as soon as i get it ill post it. Thanks for all your help so far lookin ;)
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    OK... part of what i'm guessing...

    1) The virus issues may have messed the file owenership and security permissions on some services
    2) Your System Restore service is probably not running either (my guess is its Status= Stopped or blank)

    you should also take a look in the Windows Event Log as there may be clues in there as well about what's not working and hints as to why
  10. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    "The RPC server is unavailable because the service couldn't function properly because it's dependancy (server service) couldn't start... I checked the dependencies through the server's properties and I looked through services and started those required dependancies to start the server service"...
    Does this make any sense here
  11. technophobic

    technophobic TS Rookie Topic Starter

    Forgot to post OS: Windows XP SP2

    and your right the recovery is disabled and i cant turn it on because its dependencies are disabled. im guessing RPC is one of them. Unfortunately part of this whole disaster is that i cannot check properties tabs on most anything... not sure if its due to dependency or what.

    Still cant get that program transferred over, i know i have an external somewhere...

    The only things running in services.msc show up:

    Plug and Play Service
    AVG8 Firewall
    Event Log
    Nvidia Video driver Service

    Everything else is disabled and cannot be turned on or i get "dependency Missing" (Error 1068) or "Access denied" (Error 5)

    And TMagic your post makes sense to me, but i cant check what dependencies RPC needs, as far as i know it is THE dependency from what i remember anyways. What else needs to be on for the RPC to be on?
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Yikes. Sounds like the viruses left your computer in quite a mess...

    You can continue to try and tweak things but i suspect a reinstall may be the only way to recover Windows at this point. It sounds like you should be able to get to your files/folders as is? Or see [post=766270]How to recover your folders/files when Windows won’t boot[/post]
  13. technophobic

    technophobic TS Rookie Topic Starter

    Yeah i suspect i will be able to save/recover my files i just dont know if i want to go buy windows with 7 just around the corner... May have to wait till after vacation to fix it. Thank you guys for your help. if i stumble on an answer ill post it here for anyone else who comes across this catastrophe as i have ;)
  14. JessicaD

    JessicaD TS Rookie Posts: 17


    Windows 7 is officially released in just a few weeks (on October 22nd). To learn more about Windows 7 and how it can meet your needs, please go here:

    Also, if you are currently a student you may qualify for the $30 upgrade to Windows 7. For more information, please go here:

    Microsoft Windows Client Team
  15. technophobic

    technophobic TS Rookie Topic Starter

    Giving up

    Alright guys Ive given up, there is no way to solve this problem. There are a lot of problems with my pc that are unspecified here. If anyone finds a way to solve the problem plz post it here as i love solving problems and if anyone ever comes up with this problem i don't want to tell them to just reinstall windows.

    anyhow without the use of a cd-rom im now actively trying to install windows xp from a thumb drive with no luck. i believe this warrants a new thread ;)

    P.S. I plan on buying windows 7, no need for advertisements in my plea for help, but thanks for the info jessica d.
  16. 14Terry

    14Terry TS Rookie

    Associated permissions

    Started as a jr. tech about 8 months ago. In the past few weeks I have seen this issue, including on my own PC which at the time was running Win 7 RC; build 7100.

    LookinAbout states: that this may be a permissions issue. I agree. On my PC I was unable to take ownership of a number of files while attempting to regain control of starting services. I was not able to resolve this, I reformatted the C: partition on this PC (Quick) and reinstalled. After coping data to a removable HD. I then installed windows 7 RTC. I still have a few issues. I still have permission errors, but I can start services.

    During this I discovered that I was also unable to install anything. I found the windows installer services was stopped and could not be restarted, returning the same error: Error 5 Access Denied. This meant I could install Microsoft updates, and I open a ticket regarding that, but have only received one reply and of course, since reinstalling windows, I cannot provide any files.

    I ran into this in the field too on a PC running XP Home. To reduce costs, I went straight to repair from the CD, which failed twice, then a quick format and reinstall. This PC only had one partition, and ran well after the re-install.

    I am writing because I am certain this is going to come up again, as I am finding this in the field.

  17. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Thanks for the update as to your experience.... never seen the problem just as you describe.. but my thoughts

    1) Odd you couldn't take ownership
    2) So my next thought was running chkdsk /r or just doing a reformat
    3) But then i see you DID a reformat
    4) BUT then i see you only did a Quick reformat (not FULL)

    If your problem persists try the chkdsk /r test. If still problems try a full reformat or try replacing the disk (if it's an easy and viable test to try)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...