Drivers Always prompted with "found new hardware" to install driver software for any USB device

Hi LookinAround and others. Hope its not too late to get in on this conversation as I'm having what seems to be the same problem kimjaezie had a while back and its been going on for quite a while. At least three separate USB devices have this problem across all USB ports on my Windows Vista 32 bit OS. I don't think System Restore is the way for me to go. I do think the options listed from post 15 down could save my day as my missing files seem to match kimjaezie's.

I believe this is where it is supposed to be: C:\WINDOWS\system32\drivers\usbstor.sys
However I don't see either of these guys: C:\WINDOWS\inf\usbstor.inf // C:\WINDOWS\inf\usbstor.pnf in the INF folder (I had previously gone in there and deleted the Infcache.1 file as some other forums suggested it could be corrupt. It rebuilt itself but the problem remains.

Do your recommend the hashtag utility for generating checksums or should I just copy these files onto a flashdrive from a friends Vista 32 bit SP2 computer and paste into mine? Thanks!


Posts: 6,429   +186
Hi @sseeaann and welcome to TechSpot! :)

First, a question
> Are all your USB problems with storage devices (like flash and disk)?
> Do other USB devices - like mouse and keyboard - work?
Hello and thanks for listening. I didn't notice any USB problems until a few months ago when I tried to use a brand new flash drive. A new drive mean I am prompted to install drivers and then it goes into a long cycle of installing drivers / searching for drivers, ultimately failing with "the system cannot find the file specified" error and "windows found driver software for your device but encountered an error while attempting to install it". have had the same problem with a work flash drive, a new 1TB external drive and a Behringer USB Audio Interface to digitize music.

Basically any device that already installed drivers years ago seems to be recognized and continues working as always. This does include the mouse and several flash drives, a web cam and an external hard drive. Devices that have never been used by my PC (the four mentioned above) are not recognized (except in device manager and the "found new hardware" bubble) and drivers to not install properly. Thanks.


Posts: 6,429   +186
Right click C:\WINDOWS\system32\drivers\usbstor.sys->Properties. Click the Details tab. Write down the file version number displayed.

Now navigate to C:\Windows\System32\DriverStore\FileRepository. Scroll down and look for folder names that begin usbstor.inf. Open the folder with the most recent date. Right click on the usbstor.sys file in that folder and check its file version number.

Does it match the other version number? (I hope so!) If yes, then copy the usbstor.inf and usbstor.pnf files in there to C:\WINDOWS\inf\. Try inserting your new flash drive
OK, so far so good. Both locations have the same value:

Regarding the last part of the process:

"If yes, then copy the usbstor.inf and usbstor.pnf files in there to C:\WINDOWS\inf\."

My question is this: Do I select copy and replace when I paste them into the C:\WINDOWS]inf\ folder? Or paste into the C:\WINDOWS]inf\ and keep the original file?


Posts: 6,429   +186
You should leave all the original files intact in the FileRepository. Only place copies of the usbstor.inf and .pnf files in C:\WINDOWS\inf

/* EDIT */
Or are you asking about the files in Windows\inf?
> Based on the problem and your description, I assume there is currently no usbstor.inf in that folder
> You can overwrite any current usbstor.pnf when you copy from the Repository
Last edited:


Posts: 6,429   +186
Excuse the double post.. but wanted to make sure you saw this addition.... After copying the files, you may also need to delete the INFcache.1 file again. Reboot computer. then insert your usb drive. Does it work now?
I was asking about the existing files in C:\WINDOWS\inf
When I pasted into the destination folder usbstor.pnf went in, no problem. There didn't seem to be one there and there is only one there now, dated today
It was the .inf file titled usbstor that prompted me to replace or allow them both. I did the second, which looking back may be wrong but you were talking about overwriting the .pnf file so I'm a bit confused.

In any case I can't get either USB to work after doing that and deleting the INFcache1 file beforehand. :(

I do appreciate the help, sorry to be a problem child


Posts: 6,429   +186
Hmmmm.. That is odd if usbstor.pnf wasn't there but usbstor.inf was... but if you copied from the repository folder with the same .sys version number (which you did) I wouldn't worry about it. And in your case, by allowing both it just means it renamed the original and replaced it from the repository folder. Which is good.

But not sure of the order;
> Do the copy from repository folder
> THEN delete the INFcache.1 folder
> Reboot and then insert your usb flash


Try looking here:

usb.inf_xxx_yyy_zzz files contain the USB inf. pnf and sys files
Lookin Around: Yeah, I think the one I pasted in became "ubstore (2)" and the pre-existing .inf file stayed the same "ubstore". I did do all three steps right afterwards in that order with no results.

But now looking back into the C:\Windows\System32\DriverStore\FileRepository I see that there was a second usbstor folder that I missed You mentioned to consult the one with the most recent date, which I thought that I did ... and then today I see another file with the same prefix usbstor.inf________ . The one I missed is actually the most recent (dated after I reinstalled my OS in 2009 while the first is from 2006. In the 2006 version the files do match but in the newer one the versions DO NOT MATCH. One has the valued 6.0.6000.16386 (2006) while the newer one has the value 6.0.6000.20496 (2009).

Could this file have been hidden the first time I looked or did I just miss it (probably the latter but weird). I'm assuming this is bad news since you said that you hoped both were the same. Anyway, thanks.
I also have the same using an asus k53e laptop windows 7 laptop cant install drivers for usb flash drive..even the new mouse I bought and any device I connect to my laptop through usb..I tried to troubleshoot it but it always says "cant install driver,access is denied." I already tried system restore but it didn't work..hope someone helps.


Posts: 6,429   +186
I've seen usb driver "access denied" errors when malware was present (may or may not be true for your case). Search for and run free versions of Malwarebytes and Super-Antispyware. Those have helped the cases I saw. Hope it might help you too.

If not, you can also try posting in our Malware Forum to get a thorough checkup
I only wonder how you knew this was a problem.

"you do learn something new everyday"

Repeating the quote:
Those two missing files are definitely a problem. The usbstor.sys file is good.

Do you have a friend with a Vista SP2 machine? Take a copy of usbstor.pnf and usbstor.inf and save them both in your C:\WINDOWS\inf directory. Reboot. Then try plugging in your USB flash drive again.

Let us know how it works. <fingers crossed>


Posts: 6,429   +186
@Hoang N.

I'm glad to hear you you were able to fix your problem :) (y)

Here's some updated information/tips (for you or anyone reading the thread in the future)

1) If those INF/PNF files are missing, most times you can find copies of what you need on your computer in the Windows "driverstore" (unless Windows is really corrupt). See How to Repair Corrupt USB Mass Storage or CD/DVD Drivers

2) I haven't had time to update that "How to" post yet. Some more info: Some USB drives (such as U3 flash drives and some (not all) Western Digital USB disks, use the USB Composite Device driver. You can use the same instructions above to check and replace these files (the USB composite device driver) if missing