1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Always prompted with "found new hardware" to install driver software for any USB device

By kimjaezie ยท 40 replies
Aug 25, 2012
Post New Reply
  1. hye
    I'm having this problem since few months ago. before I had installed a software named VMWare for my college's assignment in order for me to use Linux Ubuntu. but apparently it gave me a lot of problems until I decided to uninstall the software. after I uninstalled, all NEW USB devices such as external HD, flash drives and etc cannot be detected and windows always prompt "Found New Hardware" pop up message and require my windows to install driver software for my USB devices. I tried clicked the "Locate and install driver software (recommended)" but it still prompt out again the message. it happened for all new USB devices. I don't know why. maybe it happened after I installed the VMWare, I guess?

    can someone help me with this? I cannot use my new flash drives and external HD for me to transfer my works. it's so tiring :(
  2. ron111

    ron111 TS Rookie Posts: 44

    Have you tried reinstalling the chipset drivers, which would generally be responsible for USB support?
  3. kimjaezie

    kimjaezie TS Rookie Topic Starter

    yes, I've tried that before. several times. but it still pop out the same "Found New Hardware" pop out message. what should I do next? do u have any suggestion?
  4. ron111

    ron111 TS Rookie Posts: 44

    One thing that can sometimes help with USB problems is to shutdown and remove the power. If you are using a laptop, also remove the battery. Wait a few minutes and then plug everything back before rebooting.
    If that does not help, try using a restore point to bring back the configuration from before you installed VMWare, that could solve issues with the configuration (a lot of USB issues are actually caused by misconfiguration in the Windows registry).

    Hope it helps.
  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Plug your USB flash drive or external drive into the USB port. Is it the Found New Hardware Wizard that pops up?

    Look in Device Manager. Do you see any entries with yellow icons? Which entries?

    I suspect your USB Mass Storage driver is corrupt. But try the above and tell me what you see

    /* Edit */
    And what version of Windows are you running? What Service Pack level is installed?
  6. kimjaezie

    kimjaezie TS Rookie Topic Starter

    I plugged my external hard disk and yes, the Found New Hardware Wizard pops up. also look in Device Manager and there is one entry in Other Devices with yellow icon. so, if my USB Mass Storage is corrupt what should I do next? please help! :confused:

    currently I'm still using Windows Vista Home Premium, Service Pack 2, 32-bit OS

    how to bring back the configuration and where is the restore point? I don't know how to do that. can you give me the step by step procedures. thanks a lot!
  7. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +244

    Go to your start menu, Click on all programs. When the menu pop up . Click on Accessories The scroll down to System tools, Click on this, There you will see System restore, Click on this. When the window open hit next. Once this window opens , Go down to the left corner. Put a check in the box next to (show more restore Points) Then pick a restore point from a couple of weeks back or before your problem. Then click next. When the next window comes up Highlight the restore point in the square box. Then hit finish, The computer at this time will start the restore process, Do not turn it off let it do its thing. Good luck hope this helps you.
    LookinAround likes this.
  8. kimjaezie

    kimjaezie TS Rookie Topic Starter

    I already did the system restore and the problem still exist. but I did noticed one thing. I couldn't pick a restore point from the moment the problem existed as in few months ago. the restore point somehow has been set. I wish to undo what I did but there's no Undo System Restore option. or maybe I need to wait for a few days to undo, is it? I'm so confused now. I hope my problems can be solve as soon as possible. anyway, thank you for helping. appreciate what you have done :)
  9. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +244

    Did you click on the box , That said show more restore points? If you wish to undo this restore point you will need to go back into system restore. It will have back up and made a restore point for you of the time and date. You did this restore Just click on that date and time. It will take you back to windows , Before you did the restore. What you need to do was go back before you had the problem. If know about the time frame it happen. This would most likely solve your problem.
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    If you can't get a System restore point to work, do you still have your Vista installation disk? A repair might fix the problem
    Cobalt006 likes this.
  11. kimjaezie

    kimjaezie TS Rookie Topic Starter

    now when I open the System Restore, there is a sign indicate "No restore points have been created on your computer's system disk" thus I cannot find any Undo System Restore option. Next and Back button also disabled. When I clicked at the System Properties > System Protection and click the System Restore, then it will pop out "The System Restore wizard is already running. The Program will now exit". I logon into my laptop by using admin ID and always as admin as I don't create any other accounts. I'm sorry if I keep bother you.
  12. kimjaezie

    kimjaezie TS Rookie Topic Starter

    Nope, I don't. Sorry :(
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    I have one more idea on fixing the driver (altho it's still a guess the USB Mass Storage driver might be the problem) but will have to post later today or tomorrow
    kimjaezie likes this.
  14. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +244

    Your not bothering anyone, You need help with a problem which is ok. See what LookinAround has to help you.
    kimjaezie likes this.
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    No bother kimjaezie. We're all hoping to be able to help. That's why we're here :)

    Let's see if your USB Mass Storage driver might be the problem. There are 3 files involved. See if each one of these files exist on your machine (note the last file is in a different directory)
    If they all exist, then we'll calcualte each file's checksum to verify content against another set of those files I have on a Vista SP2 machine

    Download and install HashTab. This simple tool calculates file checksums. For each of the 3 usbstor files:
    > Right click the file, select->Properties. Click the File Hashes tab
    > Click on the MD5 value, right click select Copy
    > Now tell me the filename and paste in its MD5 checksum value so I can compare it to the checksums on the other Vista SP2 machine
  16. kimjaezie

    kimjaezie TS Rookie Topic Starter

    those files above aren't exist in my C but C:\WINDOWS\system32\drivers\usbstor.sys did exist. I did the File Hashes for this filename C:\WINDOWS\system32\drivers\usbstor.sys and the hash comparison / MD5 value is BE3DA31C191BC222D9AD503C5224F2AD. so, what's next?
  17. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    /* edit */
    To anyone reading this in the future: Note the fix below, is a specific fix to a specific problem for a specific version of Windows. I don't advise you try copying driver files yourself unless you know what you're doing or AT LEAST know how to recover if it screws things up!
    /* end edit */
    Those two missing files are definitely a problem. The usbstor.sys file is good.

    Do you have a friend with a Vista SP2 machine? Take a copy of usbstor.pnf and usbstor.inf and save them both in your C:\WINDOWS\inf directory. Reboot. Then try plugging in your USB flash drive again.

    Let us know how it works. <fingers crossed>
    kimjaezie likes this.
  18. jobeard

    jobeard TS Ambassador Posts: 12,443   +1,415

    @LookinAround; how about \windows\system32\DriverStore\en-US\usb* ?
  19. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    That's a good question. The Windows' driver store (which started with Vista) is, admittedly, a construct I still don't fully understand.

    As a sidebar for windows geeks: as I understand it.... For the case of good ol' XP, on plug and play hardware detection Windows searches for drivers based on registry entry DevPath. DevPath instructs Windows the sequence of folders to search for drivers. (fyi.. DevPath has the same syntax as the environment PATH variable which tells windows where to search for cmd executables)

    MS Technet documentation tells me for Vista and Win 7, upon Plug and Play hardware detection, Windows first searches the driver store looking for a matching driver. If not found, Windows then searches other locations including DevPath in the registry.

    Unless the registry is also screwed up, DevicePath always includes folder C:\Windows\inf. So, I'm guessing (and hoping) simply restoring the usbstor.pnf and usbstor.inf files to C:\Windows\inf may be sufficient to fix this driver problem so the USB Mass Storage driver can be located and installed. (Also, given that file usbstor.sys already exists in the folder it belongs)

    In any case, that's my reasoning behind my best guess for my suggested fix. If that doesn't work, any fixes to the driver store is beyond me...

    /* edit */
    I'll add to this side bar for windows geeks: I am aware of a command called pnputil that's used to add)or remove driver packages from the driver store but never tried it nor sure just how it works.
  20. kimjaezie

    kimjaezie TS Rookie Topic Starter

    THANK YOU THANK YOU THANK YOU! now it works! (y) like finally! all my new external HD and flash drives can be detect. thank you so much for helping! appreciate what you've done for me. I'm happy now :D

    and A BIG THANK YOU to the team! (y)
  21. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +244

    Your Welcome , But Lookin Around gets the credit.
    kimjaezie likes this.
  22. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    WooHoo! Great news kimjaezie. We're all glad to help :)

    Occured to me this morning I may have given you a long, roundabout answer :eek: to what may have been a simpler question.
    If you were asking about trying to extract the USB Mass Storage (UMS) driver files from driver store, I don't think OP's driver store contained a valid driver package for the needed UMS driver. If it did, Windows should have found and installed it as Windows searches driver store first looking for the UMS driver.
    kimjaezie likes this.
  23. sidni_11

    sidni_11 TS Rookie

    I have the same problem as this one. LookinAround what would I need to do? :'(
  24. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    sidni_11 Need more info. Provide answers to all of these questions:
    1) what make/model computer and what version of windows are you running on the computer having the problem?

    2) Have you tried the same flashdrives on other computers? Does the problem only occur on one but not others?

    3) Plug in the flash drive and wait for the Found New Hardware popup to occur. Then list any Problem devices
    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
    • On the other hand, if no devices are listed, tell me so
  25. starlitephi

    starlitephi TS Rookie

    Drivers that are installed during the "Installing Devices" portion of GUI-mode Setup have to be found in certain locations. At this point, Setup installs the devices (by using Plug and Play IDs) that have been enumerated by Windows Plug and Play. Setup searches a predefined path on the drive, looking in .inf files to find the best match for the Plug and Play ID of the device. This path is defined in the following registry location and is set to %SystemRoot%\Inf by default:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\DevicePath: REG_EXPAND_SZ:%SystemRoot%\Inf

    Setup uses this path to locate .inf files for device installation. After Setup, this path is also used for any new hardware found and installed. If you modify this key during Setup by using the Sysprep.inf or Unattended answer file, the value is saved and is also used after Setup.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...