Asus motherboard not recognizing modem

By needhelpinnz ยท 4 replies
Jun 5, 2008
  1. I am running XP Home SP2 and even though the motherboard I have came with an onboard RJ-45 slot, I can't find it under my Devices in the Hardware Profile. My laptop running Vista has a category called "Modem" which has the laptop's modem, so I figured the desktop running XP would have something similar. Also checked all the other categories and there was still nothing that seemed like it would be the modem.

    There is one unknown item called "other pci bridge device" but someone in another forum who had the same motherboard said it was some little extra for the onboard graphics. Can't find the disk at the moment to try and update, but I'm assuming that's not it.

    Also looking under my Network Connection and there is no LAN connection even present, just something with MSN.

    Any suggestions you have would be great, thanks!

    OS: XP Home SP2
    MB: M2N-MX SE Plus
    LAN:pHY 100/10 LAN
  2. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Go to the ASUS driver support for your motherboard model and for XP and download all the drivers you need and install them. Also get the main board chipset drivers too. Which should be the very first driver you install.

    Vista and XP are different when it comes to drivers. If you can't find a driver for your Vista, you might be able to use XP drivers but you'll have to install them manually. Good Luck on that. It might work or might not?
  3. needhelpinnz

    needhelpinnz TS Rookie Topic Starter Posts: 50

    woops, sorry, i didn't mean the modem, i meant the network adapter so i can connect my desktop to the laptop. does that change anything?
  4. skitzo_zac

    skitzo_zac TechSpot Chancellor Posts: 418

    No it shouldn't change anything. as topstir says, go to the asus site and download all the drivers for your motherboard and install them.
  5. needhelpinnz

    needhelpinnz TS Rookie Topic Starter Posts: 50

    worked like a charm. took a little while, but i guess i must have accidentally deleted them somehow when i was trying to disable my onboard graphics. thanks for the help!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...