Ati infinite loop fixed but with issues

By 0n1n3 ยท 4 replies
Jan 22, 2010
  1. Ati infinite loop fixed but with issues (problem solved)

    My motherboard is a via something or other piece of junk, my PSU is an 2yo antec trio with more than enough power, I have 2gb (2x1gb) of ram, and the card in question is an HD3850 AGP by powercolor and I am on winXP.

    I had troubles installing the 9.12 hotfix drivers from ati through the installer. I tried to install them manually with windows device manager and they installed but the VPU recovery thing would keep resetting.

    So I used driversweeper in safe mode and uninstalled the drivers, then went and got the 8.6 drivers from powercolor's website in the downloads section. I kept getting an infinite loop blue screen and tried reinstalling the drivers again through device manager, but it didn't work. I searched google and found ]this fix (below) which has solved the infinite loop problem from triggering during boot/startup sequence.
    So I boot up normally and tried to run a few games.
    First I started CounterStrike Source and the screen went black so I reboot, and I caught a glimpse of another blue screen but did not get a chance to read it. So I reboot and start CSS again, it loads and I am able to run a Stress Test inside the game successfully with a FPS average of 97. I went to guild wars and entered a high traffic area, the game loaded fine but there was a bit of sluggishness that I noticed, which I also noticed during the load process during the CSS test but it was not sluggish while graphics were being rendered during the test, just when loading things. In guild wars, when I first loaded the area, there were these blue - marks in 2 lines parallel to each other 5 or 6 marks high and similar red lines scattered across the screen, but it all went away when the area finished loading (which as I said was sluggish and slow). I loaded my guild hall and it loaded okay, so I logged out.
    I tried reboot and loading Guild Wars again but it got stuck on a black screen before I could login to my account and I had to manually reboot. I tried control-alt-delete to endtask guild wars and it brought up the task manager but I could not click it with my mouse because guild wars was stuck on top.

    I am guessing it is either a driver problem or something about what I did to fix the infinite loop bug.

    I thought this card was dead but it is only a year old... but I can't take it back and the backup card I have only has 2.0 shaders so I would really really like to try to get this to work.

    If anybody has any help to offer, please feel free to reply below.

    Thanks very much.
  2. 0n1n3

    0n1n3 TS Rookie Topic Starter Posts: 17

    I'm all over the place with this. Im trying to install the 9.12 hotfox drivers but they fail to install with the manager as usual. So when I go into Device Manager and install it manually, it keeps telling me that it cannot find ati2mtag.sys.

    I really hate ATI. Unfortunately I'm forced to put up with this and buying a new card is out of the question because this card is only 1 year old and I'm not made of money. :(!!!

    Edit: The card boots fine without drivers, so I am guessing that means that the card works... it's just the drivers which are utter crap?
  3. 0n1n3

    0n1n3 TS Rookie Topic Starter Posts: 17

    Sorry for double posting, but I wanted to update the thread when I have new information in case anyone is following this and did not reply because they had no ideas.

    I just installed the 9.12 successfully! I have no idea how..!
    All I did was copy out the ATI drivers to my desktop and also extracted files from installer to main location, Deleted the entire ATI folder in program files (stupid installer manager thing), used driversweeper and did a reboot... started installing with Device Manager pointing at the desktop. It couldn't find the sys file I mentioned before, so I pointed it at the C:/ATI drivers and it found the file (maybe I extracted in safe mode and wasn't thinking?) and so it found the sys file and installed. I ran a test in 800x600, played Guild wars and ran a CSS stress test with no problems or sluggishness. It seems to be working fine! But I don't want to jinx it... I'm afraid to reboot! I'm worried that when I reboot it won't work anymore. AHH!!!!! Now I am in 1024x768 and it went on with no errors... Afraid to do much though! I feel like it might break at any moment! But it seems to be okay? AAHH!!

    I hope this is the end of it. *fake sobs*

    Edit! OH YA! I forgot 1 other thing I did. I went into My Computer>Properties>Hardware>DriverSigning and changed it from "Warn" to "Ignore"! Maybe that's what it was!

    Also! I did not install CCC!
  4. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    Hopefully you have your problem all sorted out.

    I note that you used Driver Sweeper to get rid of your old graphics driver. Did you have problems using Add and Remove Programs?

    Also, I'm curious as to why you are using that procedure to install the graphics driver. It would be simpler to just double click on the driver file or if you prefer, go to Start > Run > and browse for the file location to enter it in the Run box and then run it.
  5. 0n1n3

    0n1n3 TS Rookie Topic Starter Posts: 17

    It doesn't use an typical installer. It has an ATI install manager thing. When I tried to use it, it would give me this error saying it was unable to install them. It seems to be common and I am lucky to have installed the 9.12 hotfix drivers at all because a lot of people stopped updating after similar issues with the 9.11 hotfix drivers.

    I use driversweeper because the ATI uninstaller, and Add and Remove Programs have never uninstalled the files completely. I've always been advised to use DriverCleaner, but DriverCleaner is not freeware anymore so guru3d and this other group programmed DriverSweeper, which turned out to be a better program ultimately. You might want to check it out, it scans for drivers based on chipset type, removed the folders & leftover drivers, and cleans up the registry also.

    Anyway, all that is in working order now. I'm still really surprised I got it to work. Come to think of it, since I changed the DriverSigning from Warn to Ignore, maybe I could've used the ATI Install Manager thing after all. I don't think it really matters since I just point to the files anyway by selecting the bottom option when it asks in the wizard.

    Also, if you go through the ATI install manager then you have to *install* the install manager, it creates a directory in program files that I felt was not necessary. Plus I wanted to make sure I did not install Catalyst Control Center.

    I'm a powerpincher and a minimalist. I try to get the most out of my system, but I suppose it's a matter of individuality and preference.

    1 thing of note is that the Install Manager has an uninstall option that I have not tried that might be worth testing.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...