ATI Sapphire 9700 Pro Kills XP apon driver install

By TWill ยท 8 replies
May 4, 2003
  1. ATi 9700 pro
    ASUS A7N8X-2.0
    the latest mobo(v2.03) and vid(v3.2) drivers, the latest mobo bios (rev 1004), and a fresh install of Windows XP SP1 and DX 9.0a

    My problem is that once my computer reboots after installing any version of 9700 drivers (off of the CD or web site) Windows XP dies! As soon as the system boots into XP, i start getting errors about failed delayed writes to the HD, and bad /$mbr errors an on and on... then files and shortcuts start going bad and the system runs very slow... At this point, i am not even able to reboot into safe mode...

    I have gone so far as to only have one CD drive, one Hard drive (tried two diff drives), one stick of ram (swapped brands), and the 9700 in the system. Then a fresh XP install with SP1 slipped in, then dx9, the mobo drivers (asus A7N8X nForce2)... All is good till i install the ati drivers and my system dies...

    The ATi 9700 runs fine on my KT333 system.
    My geForce 4 4600 runs fine on this asus a7n8x, which is where i am having the problem with the 9700...
    From what i can tell, the card is fine and the drivers are okay on the kt333, but when on the nForce2 board (A7N8X) sh1t hits the fan..

    I have found that if i use the latest nforce drivers from the nvidia web site over the latest from asus and let it install some enhanced IDE drivers (ones not in the asus rls) vs the normal nforce ide driver it works just fine.. no corruption... HAHA, but then my cd burner will not burn any thing!!!

    I have tried every thing... plz help!
  2. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    This is not a hardware error - I know from experience. This is a software issue which is probably brought up by a special set of circumstances between ATI's drivers and Windows XP. For what reason exactly, I do not know.

    I know it happens when you do not uninstall your previous video drivers... but it may not be limited to this. I was able to reproduce the same error using some very old beta drivers (Happened to my Radeon 7200) by not uninstalling my previous drivers and installing the new drivers over top of them.

    Make sure you get non-beta ATI drivers if you don't have them already, and make sure they are the newest (Catalyst 3.2) to help narrow down any weird problems.

    You should be able to boot into safe mode and uninstall the drivers. From there, you can install new ones. It is important you install your drivers in this order:

    - TV WDM (All in wonder)
    - Display drivers

    If you do it the other way around, then that can cause some problems. No reason to provoke it anymore than it has been. :)
  3. TWill

    TWill TS Rookie Topic Starter


    I am using the latest drivers and have from the start (wxp-w2k-radeon-7-84-030228a1-008040c-efg.exe). Also, there are no old drivers to uninstall/remove because I am doing this on a fresh install of windows XP and XP does not even have generic drivers for the 9700.

    As far as booting into safe mode goes, I can, if i do it after the first reboot when the drivers are first installed. If i try and boot normal and then go into safe mode on a 2nd or 3rd reboot, the system is too corrupted and it just keeps rebooting.

    As far as what you said: "This is not a hardware error - I know from experience. This is a software issue which is probably brought up by a special set of circumstances between ATI's drivers and Windows XP. For what reason exactly, I do not know.", that is exactly what i think is the problem, but it looks more like a problem between the mobo drivers and the ATi drivers. I can't figure it out. The same card and the same drivers work just fine on my KT333 Epox board, and my geForce 4 works on both boards just fine.

    I started out with the latest "non beta" drivers and had this problem, spent hours on it, then i did another fresh install and when it came time to install drivers again, i tried the older drivers that came on both the mobo CD and the 9700 CD, but i still have the same problem.

    Only thing i can think of as being the problem now, is that this board is an nForce2, and my vid card is not from nVidia, but ATi!!! HEHE!
  4. krowdpeleeza

    krowdpeleeza TS Rookie Posts: 30

    Try setting the ATI SMART to disable in the windows xp services....I cant tell you where i read that it was a problem with the A7N8X mobo, but its worth the try....
    Also try setting your AGP to 4x or below in the bios...and disable fast writes...
  5. Nic

    Nic TechSpot Paladin Posts: 1,549

    I only recently bought an ATI card, and all I can say is never again! My PC wouldn't even boot, so I'm going back to nVidia, as ATI still have a long way to go before they can produce problem free products. And their tech support is awful - they won't even respond to emails. ATI sucks, big time. :dead:
  6. TWill

    TWill TS Rookie Topic Starter


    I tried exactly what you said to do, but no good still had the problems...

    On the other hand, i think i did manage to fix it... I installed a verry old set of Catalyst drivers (v2.4) and did not have any problems. I then updated the 2.4 to the latest 3.2 without uninstalling the old drivers. All is working now!!!!! i don't know why that fixed it, but it did. To test it, I did another fresh install, installed the old 2.4 catalyst drivers, then upgraded to 3.2 and it is still working, so it looks like i have my fix!!!

    thx for the help guys!!!
  7. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Strange indeed!
  8. Nic

    Nic TechSpot Paladin Posts: 1,549

    Sounds like the older drivers installed some required files that were missing from the latest drivers you had.

    Maybe the Catalyst 3.2 drivers you installed were the wrong language version and the older driver install ensured that the correct language files were present. I say this because I had a similar problem (though it didn't stuff my PC) with nVidia drivers.

    On the nVidia site there are two driver downloads, 'English' and 'International', and I always selected the 'English' driver (I do live in the UK, and we speak English over here). However, they don't state that the 'English' driver is 'American English' only, and I could not access the display properties control panel with this driver installed.

    After contacting nVidia tech support (there was some to-ing and fro-ing, and I mentioned that I had an older driver that worked perfectly, but it installed some additional files that were missing from the newer drivers that I downloaded) they informed me that I should be using the 'International' driver as this would install the required language files that I needed and eliminate the error.

    And guess what, it worked, but nVidia still won't specify American English only for the 'English' versions (tw**s). English did originate in England after all. :confused:
  9. young&wild

    young&wild TechSpot Chancellor Posts: 993

    Have you make sure that your internet connection is disconnected before attempting to install the drivers? Installing drivers while having the internet connection on will cause conflict due to simultaneous updating of drivers from the M$ website.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...