1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

ATI SAPPHIRE RADEON 9550 256MB - Restarts and In-Game Freezes

By cjb · 79 replies
Apr 9, 2006
  1. cjb

    cjb TS Rookie Topic Starter Posts: 51

    I ran the MSI Live Update thing just to check for any recent updates. It found a few so i tried the mobo drivers and they installed fine. Then i tried the VGA drivers (and the picture attached is the list i got - are they each the only VGA update i need, just newer versions; or are they all part of one big update?).

    However I downloaded the first file and installed it. Then installed the second, thinking that they were each indivildual updates. Obviously something went wrong as after i restarted the Catalyst Control Center icon dissapeared and my computer is acting grapics-wise as if there were no drivers installed at all (i.e. slow-bitty loading of pages and not ATI icon or file in the start menu. What on earth has gone on here? Somehow the "update" has uninstalled the Catalyst Control Centre but not replaced it! Ahhhh. Help please. Shall I just bung in the old driver CD and then do another update?

    Attached Files:

  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Try doing a system restore. That should fix it.

    Regards Howard :)
  3. cjb

    cjb TS Rookie Topic Starter Posts: 51

    this is driving me insane. CAtalyst Conrol Centre wont open :( :mad: :evil: . In the live update picture i attached are all the files needed to update or just the top one
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    I don`t know to be honest.

    Why don`t you just go to the msi site and update manually?

    Regards Howard :)
  5. cjb

    cjb TS Rookie Topic Starter Posts: 51

    1) The MSI site is useless and doesnt list my mobo
    2) After system restore catalyst conrol centre still wont open, McAfee doesnt work either.

    Im going to resore back to my origional point, then reinstall old catalyst conrol ccentre from driver CD.
  6. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    If your mobo is quite old. the MSI site will have it, but it`s probably in the archives somewhere.

    What mobo do you have?

    Regards Howard :)
  7. cjb

    cjb TS Rookie Topic Starter Posts: 51

    MSI KT6V, its not old but i know its socket 462.
  8. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Take a look HERE

    Regards Howard :)
  9. cjb

    cjb TS Rookie Topic Starter Posts: 51

    Okay...i was just about to let my computer meet my back garden via my window when the Catlyst Centre decided to work (only after a full uninstall-reinstall). But I still have the updated motherboard drivers instaled :)

    Please tell me if you find the mobo on the MSI website coz I cant.
    I guesss from this point I will have to do the following things:
    -install SP2 if possible
    -get better PSU
    -another stick-o-ram

    If theres anything else to try pleaes post it for me :)
  10. cjb

    cjb TS Rookie Topic Starter Posts: 51

    SoF2 worked for a lot longer than it ususally does but still crashed. Even after multiple driver updates something is causing it to just stop responding. Its not overheating (Temps were CPU 43C and System 32C).

    This is really very annoying. Im beginning to doubt a memory problem because it takes some time to crash and other games work fine on my computer.

  11. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Well, like you suggested earlier. It may just be that that game has a compatibility issue with your computer.

    Take a look HERE. for patches and other downloads.

    If that doesn`t help, I don`t know what else to suggest.

    Regards Howard :)
  12. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    You should perhaps upgrade to SP2. Freely available on CD from Micro$haft.
    Disconnect the PC from the internet temporarily and switch McAfee off during that time.
    Then run the PC and see how it goes.
  13. cjb

    cjb TS Rookie Topic Starter Posts: 51

    Ive sent a request via snail mail to Microsoft for SP2 on CD. I already have all the patches you've put a link to, but thatnks for looking. It looks like I may either have to just get a new gfx card if i want to play that game. Oh well thanks very much for your comments all much appreciated.

    BTW the crashes have now subsided. :):):)
  14. cjb

    cjb TS Rookie Topic Starter Posts: 51

    I dont believe it, Microsoft are charging £6.00 for SP2!
  15. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Tight fisted buggers.

    Maybe one of your friends will have a copy?

    If so you could use that. Just make sure it`s the actual sp2 disk and not a full Windows xp sp2 disk.

    Regards Howard :)
  16. cjb

    cjb TS Rookie Topic Starter Posts: 51

    I thought you could download it for free? Anyway I'll make sure I get just the SP2 disk, thanks.
  17. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Yes you can download it for free.

    However, didn`t you say you were having problems with it, when you downloaded it?

    That`s why I suggested you get it on cd.

    Regards Howard :)
  18. cjb

    cjb TS Rookie Topic Starter Posts: 51

    Yeah I had problems with downloading it, it just seems really scroungy that microsoft should charge for it when its free from the web.
  19. cjb

    cjb TS Rookie Topic Starter Posts: 51

  20. cjb

    cjb TS Rookie Topic Starter Posts: 51

    Hi again

    Ive finally installed SP2, and still the game hangs and the error message appears:(. If it were a driver problem it would mean that it would crash straight away surely, but it usually takes 5mins to crash. Also its probably not overheating as i can play other, newer and more demanding (CPU terms) games than this one. Im baffled, im sure you are too but any other suggestions wud be great.

  21. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    As I`ve already said. It could be ram/psu/mobo, or simply a compatibility problem with that particular game.

    To tell you the truth, I`ve run out of ideas on this one, I`m afraid.

    Regards Howard :)
  22. cjb

    cjb TS Rookie Topic Starter Posts: 51

    After finally sorting out the problems I decided to have a look inside that crappy PSU that came with my case. The first thing i noticed was that the "Void if Removed" sticker had been chopped down the middle...not a good start i think. So i proceed, and to little surprise i see some evidence of just how awful this PSU is. The problem?: There was a big black wire that was cut in half; two open ends of a wire that were supposed to be connected...Ah. My trust in quality PSUs has been strngthened even further.
  23. VerticalFactory

    VerticalFactory TS Rookie

    Hey guys,

    I've been reading the thread, and the suggestions that have been given are awesome. Really helped a lot. The problem I've noticed after scouring the internet is that ANYONE who has a sapphire radeon 9550 256mb model has had this problem as well. Another thing I've noticed is that it pertains directly and exclusively to 3d elements attempted to be generated by the card. I was just running the little car demo in the catalyst control center, and it instantly crashed. All of my drivers have been updated, save for my bios. I'm going to keep trying everything, but I'm pretty sure that from what I've seen in all of the message boards so far, this is a problem that almost EVERY 9550 user has. If I figure out a good solution, I'll keep you guys posted, in the meantime, keep at it! don't give up! I'm willing to bet you'd solve at least hundreds of users problems if you solved this.

    My one fear is that the solution will be: Sapphire makes a crappy product.
  24. cjb

    cjb TS Rookie Topic Starter Posts: 51

    Through a combination of illness, moving house and a broken computer i havent been able to keep the thread up to date, apologies. But i think you may be right VerticalFactory, in seeing the trend of the sapphire product.
    Ive put in a new PSU and stick of RAM and seems to be ok now (apart from the in-game crashes which still persist.)

    I think compatibility with other hardware may be the issue or just a poorly made gfx card. What problems have you had specifically VerticalFactory?
  25. VerticalFactory

    VerticalFactory TS Rookie

    Basically I've noticed an inability to operate at high resolutions (crashes often at 1280 x 1024, and has serious graphic artifacts at 1024 x 768) and whenever you attempt to generate ANY kind of 3d polygons or anything realtime, that would use openGL or direct3d, the screen just crashes right out. The computer keeps going, and I assume everything else works on it fine, but the display just craps out. I've done some research on the sapphire 9550 in particular and have discovered that sapphire cuts a lot of corners on their cards, and in fact uses a different design spec from ATI in the card design altogether, which can result in a lot of problems. First off, let me tell you that this is NOT a gaming vga card, by any means (sorry....I feel ripped off too, but I just wanted to use it for 3d modeling, lol) if you want to get a card that'll be able to handle the good stuff, hl2 fear, rotk, etc. etc. and you still want it to be AGP, then I would recommend ATI's 9800 model. A lot more stable, I've had mine at home (the 9550 is at the office) for like 2 years and it's always delivered. The key I think is to make sure you're buying from ATI themselves and not just a licensed manufacturer like sapphire, who can apparently make sucky cards with ATI's permission.


    That said, some of the helpful things I have been trying, and am trying are to make sure that, specifically, the AGP drivers for your chipset are installed. I had the drivers for my pci bus and motherboard and all installed, but I hadn't installed the driver for my agp slot, which with some chipsets is a different download. Do you have a VIA chipset? Apparently a lot of VIA motherboards had a lot of issues with both the 9600 vga card and it's closest relatives (which explains why I was able to find this problem on so many message boards), and at least with my giga byte mother board, they had developed a bios update that specifically addressed the issue of the faulty agp interactions. I'll keep you posted as to whether this works with my motherboard or not, as I'm going to have to flash it multiple times from the factory bios version. But I would recommend if you have a VIA chipset on your motherboard to look around your motherboard's site for BIOS updates that pertain specifically to the 9550 and 9600 "bugs".

    This problem is definitely what you in the UK call a "bugger" and what we in america call "FRIGGIN HORRIBLE PROBLEM"
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...