Faulting Module Game Crash

TheBorgInva

Posts: 15   +0
Hello.

I am trying to play one of my games which seems to crash immediately on startup but only on Window$ 11.

Long story short, my 2010 year laptop, running Window$ 10, needed to be replaced. Have this desktop (month aged) with W11. Installed a game called Hellpoint and it just crashes. I have spend long time looking for ideas online (people mention similar games), reinstalling, deleting files, disabling antivirus, singing, etc. No help. Even the manufactors say to format the OS. Um, no! So I tried something randomly and found it worked, on my Window$ 7 virtual via VirtualBox (on this Window$ 11 system). The game runs dead slow, because just a virtual for testing files and not need much memory, but it loads. It runs. Will not on my W11 but will on a virtual W7. I just do not understand and wanted to reach out to see if anyone reading might have some idea.

On W11, when I load game it crashes with a generic crash message from M$. In Event Log, is the common error each time:
Faulting application name: Hellpoint.exe, version: 2021.1.21.5621, time stamp: 0x61377c70
Faulting module name: GameAssembly.dll, version: 0.0.0.0, time stamp: 0x62f34d08
Exception code: 0xc0000005
Fault offset: 0x000000000031a533
Faulting process id: 0x0x5BA4
Faulting application start time: 0x0x1D8D78C04C69393
Faulting application path: C:\games\hellpoints\Hellpoint\Hellpoint.exe
Faulting module path: C:\games\hellpoints\Hellpoint\GameAssembly.dll
Report Id: e8d0c226-150a-43c1-adbd-7495392d0473
Faulting package full name:
Faulting package-relative application ID:

This W11 system specs are:
Windows 11 Pro 64-bit (10.0, Build 22621) (22621.ni_release.220506-1250)
12th Gen Intel Core i7-12700 (20 CPUs), ~2.1GHz
16G RAM
DirectX 12
NVIDIA GeForce RTX 3060 Ti with 8 GB GDDR6

According to Steam who also hosts this game, they have these as "recommended" specs:
Requires a 64-bit processor and operating system
OS: Windows 10
Processor: 4 cores, 3+ Ghz
Memory: 6 GB RAM
Graphics: GeForce GTX 1050
DirectX: Version 11
Storage: 6 GB available space

I think I am above that! I would have figured the game would be fine if it loads (at least) on a virtual W7, set at 4G RAM and generic display drivers, and ran on previous W10 laptop.

Anyone have anything new I can try?

Thank you.
 

Kshipper

Posts: 904   +215
TechSpot Elite
I gather you can run other games no problem? You can run benchmark programs like Passmark's Performance test or 3DMark? Did you build this computer yourself?
 

TheBorgInva

Posts: 15   +0
Yes, I can run other games just fine. Yes, tested with a couple of older ones (like DOS Box and 1990s) and some from 2000s. Works well with games the kids play which are, of course, newer like the LEGO games and online ones like Roblox, and free games using the Epic and Steam clients. Hellpoint (of course my game) is the only one of mine that (so far) does not work.

No, this is a system ordered from Dell (because I can use my discounts to save some bucks). All other utilities and productivity items I sue work just as fine as from my laptop.

I checked out those sites. The 3D Mark seems to be a paid item, so skipped that. A free trial of PressMark was available, so I installed that and attached the results. I ran it with default settings for medium testing.

I also did the System Requirements benchmark, also attached.

AntiVirus, etc, are disabled, but loads on the virtual W7 that is actively running AVG.

I also attached the DX Diag log if that would help you out.
 

Attachments

  • 2022-10-09 09_46_47-Hellpoint system requirements _ Can I Run Hellpoint — Mozilla Firefox.png
    2022-10-09 09_46_47-Hellpoint system requirements _ Can I Run Hellpoint — Mozilla Firefox.png
    61.5 KB · Views: 3
  • 2022-10-09 11_32_01-Greenshot.png
    2022-10-09 11_32_01-Greenshot.png
    62.6 KB · Views: 3
  • 2022-10-09 11_33_35-Greenshot.png
    2022-10-09 11_33_35-Greenshot.png
    107.1 KB · Views: 3
  • DxDiag.txt
    117.4 KB · Views: 1

Kshipper

Posts: 904   +215
TechSpot Elite
Ok cool. I was just trying to eliminate the "I built it myself" type of problems. Your system is powerful enough to run any game. You would only have trouble at 4k resolutions. So 1920 x 1080 or 2560 x 1440 if you have a widescreen monitor would both be fine at high detail.

I remember when I first got my RTX 2080 rig going and I could not run GTAV. The game would start but it would have a horrible frame rate, then it would crash to the desktop. I fiddled and fiddled with the graphics settings but each time it crashed it would set all the graphics settings to default.

I decided to try the GeForce Experience (It comes from Nvidia the maker of the graphics card). You create an account and log in and let it scan your computer for games then it looks at what you have and offers to make the changes that you allow by clicking on 'Optimize Settings'.

Guess what? My GTAV crashes stopped and my gameplay was buttery smooth. Why not give that a try first?
 

TheBorgInva

Posts: 15   +0
I just tried that option, but seems to not work. When scanning was done, it only found six games from the Epic client, and VLC. None of the dozens of other games I have. Wonder if it looks for installation files because most of my games I have set so I can can just run and play without installing. Games from 1990s to even 2022. You know, years ago I found for most games and programs, I can install it, compress the game folder, and then I can copy that compressed folder and extract and play on another system, or after a reload of the OS (did a lot of those during the early 2000s). So I can stop installing programs. Helped a lot over the years and became habit to speed time.
:(
 

Kshipper

Posts: 904   +215
TechSpot Elite
Ahh so maybe we have found your problem. Many programs and games leverage a shared library of dynamic link libraries and the game installer may even customize one of those DLLs for their own purpose. If you are not 'installing' the game from system to system then you may have components missing that it requires which would trigger weird error messages. That might explain why you are alone on this problem and you can't find any help.

As a test try doing the full install of the game as intended. If that works then you know what to do on any other game that won't work for you. =)
 

TheBorgInva

Posts: 15   +0
I admit I did not think of that because it worked before on W10 from an extraction, and on my virtual W7. So I went to pull up my saved installer, installed, but no help. Still crashes within a second and the same error in Event Viewer, other than a different path since this time this was installed on local C opposed to running from the extractions on my H.
I was crossing fingers on that one though.
 

Kshipper

Posts: 904   +215
TechSpot Elite
Ahh, I see. I guess the only thing I can think of is to try this title out on another rig similar to yours to see if it happens there. There has to be a way to figure out why it won't run for you. Rebuilding is actually pretty quick and easy for me to do so I wouldn't hesitate to do that if it would at least get the dialogue going with the software maker.