Belkin wireless usb adapter won't work with d link router?

By maddmatt02 ยท 12 replies
Jul 18, 2008
  1. I had my computer wired right to the internet, then my girlfriend got a laptop, so I went and got a wireless router(netgear wgr614) and set it up and figured why not make my desktop wireless so I got a cheap belkin usb network adapter and had it running for lamost a year and a half now.

    well the router stopped working so I went and got a d link 2310 wireless router. got the laptop on it no problem. but cant get the belkin to work. it finds the network, logs onto the router, but NEVER gets the internet. Ive uninstalled and reinstalled the software for it as well with no luck. could it be the usb adapter? wy would it work with netgear and not with d link???

    and I know it is not a range problem because my pc is in the same rom as the router and about 9-10 feet between antennas. I dont wanna just go out and buy a dlin adapter and have it not work either.
  2. maddmatt02

    maddmatt02 TS Rookie Topic Starter Posts: 88

    dont know why I didnt try this out before, but if I login to the router and get rid of any security, then my desktop get srigh ton and gets the internet, but wih security enabled, it will only log on to the router, and not access the internet....

    any ideas?
  3. tipstir

    tipstir TS Ambassador Posts: 2,474   +126

    What are you running with the Belkin? XP or Vista. Try using disabling the Belkin Wireless Manager and use XP or Vista Wireless to manage the connection? Everything should work. Make sure SSID is the same for the wireless router and the wireless adapters. Make sure the encryption password is the same for all devices. You need security don't turn it off. Try the WEP method first! If that works try the tigther one called WPA or WPA2. If you have to put everything in the same room and test it out. Don't rush through. Connect everything wired then slowly go wireless to trouble shoot the problem. Make sure the new wireless router can see all these wireless devices? If it can't then you know their is a problem. Update the firmware in the new router and also for the USB wireless an etc... Go static IP with the USB wireless until it can connect on it's own, but first you need a connection, that's why I sugguest using static IP instead of the DHCP from the router to assign the IP address automatically.
  4. maddmatt02

    maddmatt02 TS Rookie Topic Starter Posts: 88

    well, the laptop is 5 times as far away as the desktop, and it works fine. I also tried using the wep key and it still didnt work, it logs onto the router, just no internet. also it is win2k.

    and I tried to update the firmware twice but it gets to where it says the router is restarting and then it cant find the next page.

    and I know i have the network name and key code all correct. one good thing about no security though, where I live, youd have to be in my driveway to log onto my network, im on 10 acres and FAR from any house, I am gonna take the laptop around the yard and see if there is anywhere i can log on.
  5. raybay

    raybay TS Evangelist Posts: 7,241   +10

    There are great chunks of trouble these days, with conflicts between Microsoft, Microsoft Updates, Firewalls, and Security Software such as antispyware, antivirus, and other detectors and blockers.
    You have to include these problems in the mix of things to check and make right.

    What are you trying to log onto as an IP at those distances? Have you considered all the devices that can cause interference out there in the country... Electrical anomalies, etc.?
  6. maddmatt02

    maddmatt02 TS Rookie Topic Starter Posts: 88

    well, for those of you who dont like me running no security, youll love this. I have no firewall, antivirus, antispyware or anything on this computer.

    anyways, I havent considered anything interfereing, because my phone is a dect6.0, no baby monitors or anything else running in the 2.4ghz range, no bluetooth(except ps3 but its off) and anyways, desktop, lapotop and router are all in the exact places where they were when the netgear worked fine. that was the only change at all, the router.
  7. tipstir

    tipstir TS Ambassador Posts: 2,474   +126

    Don't forget the Microwave... I run W2K using Belkin wireless G adapter, most a mix G High Power, High Speed an etc.. I don't have DECT 6.0 but 5.8MHz DSS phone system. Security does slow down the wireless, but am in the same boat wireless around is me is unsecured, but they're very far.. Only the Windows firewall would cause problems here most of them do connect well.

    What progress have you made so far?
  8. maddmatt02

    maddmatt02 TS Rookie Topic Starter Posts: 88

    well, my only progress is I got the router running the newest fimware. dont know how, last time it was trying to install it wouldnt find the next page. then last night I was trying to go to because that was where i always had to go to log on, and it wouldnt work, so I got onto network magic and clicked on manage device or whatever and now it goes to and I looked and saw it say v1.04 which is the new version.

    and Im glad I gogt the new firmware, before almost all settings were grey'd out and not editable, now I can do all the port forwardign I want, and edit any setting I want to.

    I was messing with the security and then all the sudden looked at my belkin utility page and it showed internet, but before i got the network cable unplugged, it lost it. it will always log on to the router still, just no web. I figured one of my trials, I would disable NAT mode and turn it into an access point because when I log on i choose peer to peer or access point... all it did was make neither computer log on successfully, and make it so I couldnt login to the router to change it back. I was done trying for the night so i figured it set the router to default this morning and try again. well I started the laptop to burn a dvd and then saw I had the web... so Ill start up the other computer and see if it works.

    but like I said before, every appliance in the house, all equipment like router, pc's, phones, etc are all where they were when it worked flawlessly with the netgear. signal strength fills the entire bar in the office and out heren the laptop, it bounces between the 4 and 5 bars for signal strength
  9. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    Tipstir is on the mark with

    Compatibility of the encryption code is the issue.
    Cross vender will usually succeed with WEP and have problems with WPA/WPA2 --
    sure sign you need firmware updates. Sadly, even then it's not a 100% fix and
    Belkin's name is very frequently involved in this problem.
  10. maddmatt02

    maddmatt02 TS Rookie Topic Starter Posts: 88

    I have tried using a wep key and still no success. im starting up the desktop right now to see what it will do.
  11. maddmatt02

    maddmatt02 TS Rookie Topic Starter Posts: 88

    ok, is this enough security? I have my DHCP set to only give out 5 ip's.

    vonage adapter, laptop, ps3, and desktop (pci card and belkin wireless).
    also have mac filtering on allowing only these 5 mac addresses access.
    plus I reserved each individual ip for each individual mac address.
    but no wep key or anything. I just cant seem to figure it out using a wep key, or a wpa/wpa2.

    anyways, after I decided to screw security and just use mac filtering, my problem i had was, when I was setting up the router, reserving ips for mac;s, when setting up the computer, I just hit "copy my computers mac address" and manually entered the rest when setting those up. well, I obviously had it hardwired when setting it up, and forgot about my pci card and usb adapter having different mac addresses(so I set 4 ip's and just my pci's mac). so a quick trip to ipconfig/all showed me both, and I went back in and added the belkin. now it all works(not ps3 yet though but i always have trouble with that one, and now that I think about it I forgot to allow the psp mac) except I have one last question... for now.

    how often does a peice of equipment come with the wrong mac written on it, my belkin utility manager shows the mac of what im assuming is my router, because it isnt of anything else i own, plus it is VERY close to the mac address on the label on the router. it is identical except the last digit is a 1 in the utility manager and it is a 2 on the routers sticker.

    that question and of course if I am secure enough with my current settigns. I dont see how anyone else can get on to my network now with my ip's limited, reserved, and my macs filtered.
  12. maddmatt02

    maddmatt02 TS Rookie Topic Starter Posts: 88

  13. maddmatt02

    maddmatt02 TS Rookie Topic Starter Posts: 88

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...