BIOS: IDE not detected

By BorisandBailey ยท 5 replies
Oct 22, 2008
  1. I just built a computer for a sibling who is without one. There's no operating system in it yet. I need to install that from the cd/dvd combo drive. A new computer doesn't get much more fresh than this. But wait! I can't because the BIOS cannot detect the IDE connections in the CMOS! Even in the Boot Order, the cd/dvd is not listed.

    Okay, inventory: There's an MSI K9N6GM AMD motherboard, lower end, about $50. A Thermaltake 450-watt power supply. An IDE Sony cd/dvd combo drive. There's a SATA Western Digital hard drive. Not a high-end computer. It's not supposed to be, but it's better than an e-Machine. Once I have this resolved, I'll put Ubuntu on it.

    Now for testing...I tried switching IDE cables (I always be sure that they're on correctly, along with power connectors), and that didn't work. I tried a different cd/dvd combo drive. That didn't work, either. Now I'm thinking that just leaves the IDE connector on the motherboard...maybe it's faulty.

    But before I jump to conclusions, I thought I'd check over here to see if there's anything I might have missed.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Unplug the IDE1 completely

    Just put IDE0 to the HDD

    Confirm HDD set to CS (if not -> M try that too)
  3. BorisandBailey

    BorisandBailey TS Enthusiast Topic Starter Posts: 154

    Just one observation, Kims. The CD/DVD combo has an IDE connector. The hard disk drive has a SATA connector. Now I could use an adapter to connect the power from the CD/DVD to the SATA drive, but what about the IDE ribbon cable? The CD/DVD, of course, has a CS selection. Maybe I'm missing a link here.
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Oh, that changes everything!

    Please set PATA enabled in Bios
  5. BorisandBailey

    BorisandBailey TS Enthusiast Topic Starter Posts: 154

    I'll give that a try, doctor!
  6. BorisandBailey

    BorisandBailey TS Enthusiast Topic Starter Posts: 154

    Well, there's no specific PATA settings available. IDE can be enabled or disabled. Perhaps PATA is automatically enabled. I'm still at square one, but I talked with a colleague at noon and she mentioned somehting on the motherboard that I could "toggle." She's going to look it up in her notes from her certification class. More to come.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...