1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

BSOD 0x00000007F - Memory or video adapter

By Aimsbury ยท 36 replies
Feb 17, 2009
  1. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Did you try to load both Speedtouch and Belkin? Go back to RegCleaner and clean out anything Speedtouch/Belkin. Try disabling both your firewall and antivirus when attempting to install the next time. Sometimes security software will block the installation of legit software.Then only install the Belkin drivers. Make sure you don't connect the adapter until prompted to do so. Does this work?

    If not, clean again then reboot and run ChkDsk (just as I spelled it) in your Run box found in the start menu. This will go fast but it will take longer on step 2 if it needs to recover lost files. Then attempt to reinstall Belkin again (with security software disabled). Let us know what happens.
  2. Aimsbury

    Aimsbury TS Rookie Topic Starter Posts: 30

    Hi Route - hope you've had a good day. Have done everything you've said and it still seems to be hanging on the please wait screen. Going to leave it again to see what happens...

    Interestingly, the windows media update wouldn't install either...?
  3. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Try this approach: Go to RegCleaner and, again, search for anything Belkin and uninstall. Then go to your start menu and go to the Search function, click All Files and Folders, type Belkin in the box under "All or part of the file name", and then click Search. let it complete. If you have anything Belkin delete. Do you find anything in the Search?

    Now reboot, disable all your security software, and once again try to reinstall the drivers that came with your adapter, but don't have the adapter connected until you are prompted to do so. What are the results?

    If none of this works then get a hold of Belkin tech support and tell them the following:

    1. You originally installed their Belkin G+Mimo and it worked fine.

    2. Then tell them of your issues when updating the drivers.

    3. Next explain the process of registry cleaning, searching, etc.

    4. Lastly, tell them of the constant of the hanging at the "Please Wait" screen.

    * Get back with the outcome of the above and if you have to go to Belkin please tell us what they suggest.
  4. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Just read your last post. Scan for infections and run a harddrive diagnostics by utilizing the free utility provided by your manufactuer. get back to us with the results.
  5. Aimsbury

    Aimsbury TS Rookie Topic Starter Posts: 30

    Did a search for Belkin having deleted Belkin stuff using a combination of regcleaner and CCleaner. Loads of stuff came up. Am left with 4 items that it won't let me delete:

    Belkin folder in program files
    Belkin wcuiDLL.dll

    When I try to delete them it tells me access is denied

    Any ideas how to get rid of these? Sorry again for this problem to be dragging on!
  6. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Nothing to be sorry about in the least. Such is the nature of PCs and all the peripherals and software that comes with it.

    Do a search again and they come up in the list right click and delete. Does this work? If so then run chkdsk again.

    Do you have administration rights?
  7. Aimsbury

    Aimsbury TS Rookie Topic Starter Posts: 30

    Oh My! What a saga this is turning into! Put the windows disc back in to do a repair. Seemed to take a lot longer than last time which is good - taken a while to do all the updates etc. Have now deleted the belkin files, run a chkdsk, rebooted and there doesn't seem to be any of the files lurking.

    Re-Installing the belkin now... disc spinning, pressed next, connected to usb as requested... Please wait... disc stopped... still waiting... (mcafee off by the way)...

    Time now 22.39. Will let you know if anything other than please wait occurs
  8. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Ah, McAfee (there are a whole lot better options)! Did you disable before trying to install? I was going to suggest a Windows repair might be in order.
  9. Aimsbury

    Aimsbury TS Rookie Topic Starter Posts: 30

    ha ha ha ha ha! I can't get the Belkin website to work! Leaving the installation overnight. Will see what happens tomorrow. Luckily we can get onto the internet via cable rather than wifi so it's not as bad as it was a few days ago!

    Sleep tight - will update you in the morning. Night night
  10. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    http://www.belkin.com/ Can you access now?

    And did you disable McAfee when attempting to install? I am wondering if there is a conflict between McAfee and Belkin drivers after your attempted update.
  11. Aimsbury

    Aimsbury TS Rookie Topic Starter Posts: 30

    Morning - yup, all mcaffee was disabled (I think). Still had the please wait logo up this morning. Tried to set up a new network connection anyway and I got an error about the WZC function not working. Went to windows help page, got it to start and whoop whoop - used that to search for my wireless connection, entered the network key and I'm online wirelessly.

    Am still anticipating some issues if the Belkin hasn't installed propoery but been wireless for 15 minutes, can download, browse and the machine hasn't powered itself down yet which can only be a good sign!

    Just double clicked the belkin wireless networking utility shortcut icon on the desktop and after about 2 seconds, all the exclamation marks changed to ticks indicating connection problems turned to green ticks and now it's telling me the connection is 'excellent'.

    (Now on wireless network connection 22 though! LOL)

    Blimey! That was more drama than the Christmas episode of a soap opera!

    Will still try to get on to Belkin though. I can get on their website, but when you go into support and start selecting the network adapter section etc, the page hangs. I'll maybe try to call them on Monday.

    I'm hoping this isn't premature (it may all still go wrong again) but thank you so much for sticking with me! You've been a huge help! If I could hug you, I would!

    Thanks again, Amy x
  12. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Excellent! Do us a favor and let us know two things in the near future: a) if your connections continue and b) what Belkin had to say.

    Glad to be of help. Good luck and remember, if your hardware is working fine don't mess with the drivers!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...