Tech Stocking Stuffers: 18 awesome gifts under $50

BSOD after Windows 7 Update - Page_fault_in_non_paged_area - memory tests ok

By dogwhiskers ยท 11 replies
Dec 21, 2011
Post New Reply
  1. Dell Vostro desktop PC 230Gb Harddrive - 2Gb Ram in single stick

    - Formatted harddrive as wanting clean install
    - Installed Windows 7 Professional 32 bit (booted form Dell utility partition)
    - Install worked ok
    - Windows offered numerous updates
    - selected only SP1 and installed ok

    Everything seems to be working fine

    - Installed Office 2010 ok
    - windows offered numerous updates some office some security
    - Installed the Office updates - ok

    Took restore point

    - Installed the 6 or so Windows updats
    - Rolled back Windows to previous restore point and began selecting updates
    - managed to get most of them in but with 3 remaing everytime an update is attempted BSOD

    - Swapped the slots the RAM was located as the BSOD was saying 'Page_fault_in_non_paged_area' ucb_lh32.sys
    -error STOP 0X00000050 - usually a RAM issue.

    Carried out memory test using memtest86 (ran for around 6 hours and no errors found)

    - Remaing updates are KB2505438 and VIA-DISPLAY-VIA Chrome9 HC IGP FAMILY WDDM

    Everything looks fine but the BSOD is making me want to trash the PC and install something like XP instead.

    Any ideas - minidump files attached.

    Attached Files:

  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,243   +234

    It's the S3 graphics driver causing this. Go to the motherboards support website and get the chipset and graphics driver from there. Did this PC originally come with Windows 7 loaded?
  3. dogwhiskers

    dogwhiskers TS Rookie Topic Starter

    Think Windows 7 ultimate 64 bit was loaded but due to other issues decided to do clean install of Windows. Had a license for windows 7 pro 32 so installed that. Formatted disk first to get clean install so all drivers would be removed too including the graphics driver.

    Looking inside the Dell and there are a few VIA chips knocking around. No manual or system disk and the Dell website does not have a Vostro 100 desktop (there is a 200 or a A100) so will have to do a bit of digging to get the correct chipset.

    Current graphic is set for VGA so looks like an update required.

    Bit annoying if this is the issue as you'd think Windows 7 would be able to figure things out and give a better error message than indicating the Ram is duff.

    Will try updating the grahics driver and let you know.
  4. dogwhiskers

    dogwhiskers TS Rookie Topic Starter

    Having a real problem tracking down the driver.

    Went to the Dell website and the is no model Vostro 100 even though this is printed on the PC. There is a 200, A100, 1000, but no 100.

    Also as battery was removed from Bios in an earlier bid to resolve the BSOD the service number is removed so unable to contact Dell as this is required for all correspondence.

    Any ideas where to get the driver?

    In meantime no BSOD but also no further windows updates.
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,243   +234

    So you don't have either the Service Tag or Express Service Code for this desktop? Did this desktop come with Windows 7 or another version of Windows originally?
  6. dogwhiskers

    dogwhiskers TS Rookie Topic Starter

    Update - as with everything found a utility on the net that has found the drivers and updated them for me, called 'Slim driver' or something like that.

    So far its doing the job and its free. Its already found the graphics driver and updated that so its no longer a basic VGA. Something that Windows 7 was unable to do.

    The utility has 2 more drivers to install - taking restore point between each install so its taking time but the system is stable so far.

    Once all drivers instlled I will give those Windows updates a another go and let you know what happens.
  7. dogwhiskers

    dogwhiskers TS Rookie Topic Starter

    Hurrah success, drivers installed and final updates loaded sucessfully and no BSOD.

    For extra credit if theres a way to stop the PC trying to boot from network then that would be good but think thats for a different forum. Its PXE load thing but can't get into the menu to turn it off even with ctrl-S when its starting up. Annoying but pressing escape gets out of it and PC boots normally.

    Thanks for all the help.
  8. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,243   +234

    "Its PXE load thing..."

    The computer is set to try and boot from a non-existent network device. You have to get into the bios and set the hard drive or CD ROM as the FIRST boot device
  9. dogwhiskers

    dogwhiskers TS Rookie Topic Starter

    Not that simple as PXE will always come in first regadless of the boot sequence in the BIOS, apparently its designed that way.

    This can be turned off but need to get into the card menu to put the boot option to off. In meantime all that is required is to either wait or press <escape> to exit the PXE and the boot goes back to normal. Unfortunately can't get into the menu as this software may have been removed when the initial formatting was done but the NIC is already programmed.

    Not the end of thw world if no easy way to turn off this as its only 1 keystroke to get things working.

    The driver says its a Rhine II network card.
  10. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,243   +234

    In my experience, the only time I ever see this PXE thing is when there is no other boot device available. If you can live with this... good ;)
  11. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,243   +234

    This PXE comes from the computer sensing that no other boot device is present. The computer is trying to boot from the internal network card. ALL Intel bios have the ability to select the boot sequences from the hard drive, CD drive, removable devices and the network boot. Your computer is stuck on the network boot option first. This is not normal...
  12. dogwhiskers

    dogwhiskers TS Rookie Topic Starter

    Checked the BIOS and the order is harddrive, cd, removable then other.

    Cheked the boot device and in harddrive teh first is set to the SATA harddrive though there is some other device in there but that is second on the list.

    Its no big deal and the PC is working fine. Unable to find anything that would indicate some sort of boot from network in the BISO anyway, maybe that needs to be updated too but after just solved a BSOD issue don't really want to spend any more time on this. Thanks for all the help.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...