BSOD Before Full Boot Consistently, Hardware or Software?

By jjwabraham · 23 replies
Nov 25, 2009
  1. Hello community, I have been reading up on a problem that has hit close to home and find this to be an awesome site. I want to be affiliated in an ongoing basis once my issue gets resolved and I post exactly what solved it.

    I have been a nuts & bolts PC technician since 1994 and have helped many people with their home PCs. You know the old saying about auto mechanic's cars. Well, my wife's PC just developed a catastrophic symptom that has me stumped. We've had many training sessions about getting rid of temp files and shutting down periodically, especially after doing lots of graphic manipulations. When she shut down and restarted this afternoon, she got a BSOD Page Fault in Non Paged Area with the STOP Code: 0x00000050 (0xD84F5E58, 0X00000001, 0X8063CBE6, 0x00000000)

    When I got home, I tried several things, including Safe mode, swapping the two 512M DDR strips, changing to a 1GB DDR2 strip with the same results (after reading here), except that the first Address block changes with the following pattern 0xDzzz5E58, where zzz is always a different value, even when restarting with no changes.

    Every attempt at any Safe mode results in a reboot, regardless. All restarts for Normal result in either a reboot or the BSOD. The startup sequence is Acer Splash screen, blank, Windows Splash screen, blank, 2nd Windows Splash screen, blank, mouse arrow, Windows is Starting Up... Splash screen, blank, BSOD.

    Running Windows XP Home Service Pack 2
    Acer Aspire AST180-UD360A with AMD 3600+
    1GB of RAM (either 2 512 DDR in Purple slots or 1GB PNY DDR2 PC2-5300 in Orange Slot)
    Integrated Video using 256MB of system RAM
    250GB SATA HD
    The system has been working consistently well with XP Home for about 2 years now after I disposed of the Vista that came with the machine.

    My original thought was hardware, either RAM or Video, but the fact that it goes into BIOS and the initial splash screens points to either; video functionality is gone in its higher stage of operation, or its a Windows file thats corrupted. Any ideas from you folks would be greatly appreciated.

    Before I try reloading Windows and the agonizing process of getting back to where we were this morning, I hope to get some ideas from this forum. Thank you in advance and Happy Thanksgiving to all.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

  3. jjwabraham

    jjwabraham TS Rookie Topic Starter

    Great Suggestion, but No Go

    Kimsland, First of all, thank you for finally clarifying a tool that I've often tried to use, but rarely had success, the Windows Recovery console. Most of the time, it would fail at the Admin password with most customers because they didn't know it. I knew mine though and -- voila! -- a DOS prompt.

    I tried your suggestion and ran CHKDSK /R from the console. It went quickly for the first 67%, then took a while from 67% to 76% (when I got tired and went to bed). When I got up, it was completed and the reboot came up with a BSOD of BAD_POOL_CALLER and addresses of 0x000000C2 (0x00000043, 0xD6891000, 0x00000000, 0x00000000) at the same spot in the cycle, just after the Windows is starting up... splash screen.

    I tried a reboot into Safe mode, it did an automatic reboot just after the Windows is starting up... splash screen, and restarting in Normal mode, then went to the original PAGE_FAULT_IN_NONPAGED_AREA and the same address pattern.

    I'm wondering if it is possible to replace several potentially corrupted files from a working XP SP2 system to this one to repair the installation now that I can get into the Recovery Console.
  4. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

    In addtion to Kimsland's suggestions...

    The error you report (0x50) could be caused by either Defective memory (including main memory, L2 RAM cache, video RAM) or incompatible software (including remote control and antivirus software)

    Possible Resolutions:
    • If hardware was recently added, remove and replace the hardware to determine if it is causing or contributing to the problem. You might run diagnostics software supplied by the hardware manufacturer to determine if the component has failed. ... Unfortunately this may sometimes require your windows to boot, which obviously (in this case) wouldn't help.
    • Stop 0x50 messages can also occur after installing faulty drivers or system services. If the file name is listed, you need to disable, remove, or roll back that driver.
    Possible Diagnostics:
    • The new 0xC2 error is pointing at drivers. Recovery Console, or Ubuntu (or other Linux OS) might allow you to gain access to your windows partition, and thus do further diagnostics with the Minidumps, to find out what drivers / software may be involved with the failure. If you want someone here to analyze your minidumps, there are several here who can. Attach the most recent 5 or so in a zip.
    • If it is AV software that is involved, I would also consider looking for malware.
    • The original error suggests the possibility of memory issues...
  5. jjwabraham

    jjwabraham TS Rookie Topic Starter

    Nothing different was done, just a restart

    B00kWyrm, Thank you for your suggestions, however, nothing different has been done to the machine. She was downloading and trying out DVD label programs to find one that was easy to use. She spent some time manipulating graphics and decided to do a restart, to clear potential memory leaks prior to using the graphics in the latest application and got the BSOD. After calling me at work, and trying my suggestions with no go results, she shut down till I arrived home.

    I'm in the middle of trying the repair of Windows Kimsland suggested, but that has rarely been successful for me in the past. As mentioned, I have tried 2 RAM memory configurations, and the video uses the system RAM, but still leaves the L2 cache as a possibility. I will do a visual on the Mobo for the swollen caps suggestion and will post. Thanks again, John
  6. jjwabraham

    jjwabraham TS Rookie Topic Starter

    Windows Repair Worked, Well Sort Of...

    Kimsland, Thank you for your advice. I used your Windows Repair advice and was able to get Windows up with errors and an inability to get online (Progress, nonetheless).

    While Windows was finishing it's repairs/reinstallation of files, a pop-up appeared with a title of COM+ Setup Error, with the following pertinent info: COM+ exception OC_COMPLETE_INSTALLATION Setup message.
    The file specified was on the CD ROM titled: csetuputil.cpp (line 3406)
    Error Code 0x8007007F

    Then 3 popups describing files as corrupt/not found: C:\Windows\System32\inetcomm.dll, C:\Program Files\Outlook Express\msoe.dll, and C:\Program Files\Common Files\System\wab32.dll.

    The first time Windows started up, I immediately had to reactivate the Windows via phone because no connection was available. Once past that, there were a couple of Windows Recovered from Serious Error messages that I failed to get details on, because I was trying to figure out why my DLink Wireless card was on the Taskbar and I couldn't get a wireless connection. After restarting again, I got 2 more Windows Recovered from Serious Error messages with the following pertinent info: BCCode: C2 BCP1: 43, BCP2: D0B91000, BCP3: 0, BCP4: 0 OS Ver 5_1_2600 SP: 0_0 Product: 768_1 with a minidump file Mini112609-04.dmp and the second was BCCode: 10000050 BCP1: 43, BCP2: D90F5E58, BCP3: 1, BCP4: 8063CBE6 OS Ver 5_1_2600 SP: 0_0 Product: 768_1 with a minidump file Mini112609-05.dmp

    I've zipped 4 of the last 5 dmp files into an attachment, which should represent at least one from before Kimsland's rec worked and 3 of the 4 Serious Error Messages from recovery that happened. I had turned logging on during one of my F8 tries, so there are a number of logfiles available from this morning's install. Tell me which ones and I'll submit.
  7. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Firstly: Well done :)

    Only the first Minidump can be read
    Which Antivirus or 3rd party firewall are you using?
    Or to save the response, just uninstall them ;)
    (Do note that applications such as Norton and AVG also require removal tools to be run, which I can post for you)

    You can try Free Avira Antivirus and do an updated full scan if you like

    Also try this:
    1. Start > Run > Regedit > ok
    2. Go to HKEY_LOCAL_MACNE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management.
    3. Look for the "PagedPoolSize" key and change its value from “0”to "FFFFFFFF". (you should back up the old key first)
    4. Restart.

    Remove Temp Files:
    TFC :
  8. jjwabraham

    jjwabraham TS Rookie Topic Starter

    Replaced some files, goofed up

    Hi Kimsland,

    I've been playing and learning and in the process messed up the system. I now know that you shouldn't replace kernel32.dll from one system to another. I tried opening the Wireless Network icon from the Control Panel and received an error that stated the file wzcdlg.dll was corrupted. So I replaced it with one from my laptop, restarted, and tried again. Got the error to change to: a something or other entry point couldn't be found in kernel32.dll. Copied kernel32.dll, restarted, and got a new BSOD indicating that an entry point in ntdll.dll couldn't be found. Nothing to do but redo the Windows repair.

    I've been using AVG Free for years with far fewer problems (maybe 2 in all) than many customers whose Norton or McAfee installations were regularly violated by the latest and greatest viruses/malware. I've noticed there seems to be some animosity on this site toward AVG, with recommendations for the Avira and Aviva.

    I will do as you ask and remove the AVG if you think it is a likely cause. As far as the other Apps you recommended I still can't get onto the Internet, but I know where most temp files reside. I've also included minidumps 2 and 3 from this morning and the codes from 4 and 5 are posted in a previous post.

    Update: I finished the Windows repair install with a different setup disk and got the same set of errors with the COM+ and no wireless network installation as previously noted. So now I have Windows running with errors and no internet.

    The error message when trying to start Wireless Network is: Error in wzcdlg.dll Missing Entry Flashconfigcreatenetwork.
  9. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Hmm, that may have stemmed from me ;)

    Anyway, as I stated earlier just removing AVG is not enough
    You also need to run the AVG Remover Tool:
    (Note: This can be done even if Avira is installed or not)

    Please update Avira and run a full scan, and report on findings
    I would highly suggest to run a quick scan (normally 5 or 10 mins) with free Malwarebytes:
    Again report on findings

    I haven't checked the Minidumps, because I think this is likely it :) (how confident is that :))

    Oh, if you have ever had Norton installed, also run the Norton Removal Tool: (anyway it can't hurt)

    McAfee also has a removal tool, and I have quoted this before as well
    Think of AVG; Norton and McAfee, as the most attacked Antiviruses of them all with Malware, and that may help your understanding
    And do note, that its only those 3 (ironically) that you mentioned
  10. jjwabraham

    jjwabraham TS Rookie Topic Starter

    AVG Gone, Avira installed, Malware Tool Run

    Hi, Because my Windows repair hasn't been updated, AVG refused to deinstall. I used Kimsland's tools to remove the AVG, successful, Installed the malware detection tool and ran a quick scan and a full scan, 0 found. I've installed Avira and have scanned with 3 detections found as follows:

    ADSPY/Bho.O with file iwinGamesHookIE.dll
    ADSPY/Admedia.IU with file winGamesinstaller.exe
    ADSPY/Admedia.JQ with file webudater.exe

    One warning = Could not open a file to scan, system file not scanable.

    I don't really think these could be the culprit for BSOD issues.

    I will bring the computer downstairs and use the wired network to complete updates and scan again and try to get the wireless working again while I await any more input or comments. Thanks again for the help to get this far.
  11. kimsland

    kimsland Ex-TechSpotter Posts: 14,523


    So far so good :grinthumb
  12. jjwabraham

    jjwabraham TS Rookie Topic Starter

    At an Impasse, Can't Launch IE7 without SP2

    Hi, I've reached an impasse. I hooked up the troubled machine with a wire and the Avira was able to connect and update and I was able to have a Java Update download and install by clicking on the Update balloon. However, when I try to launch the IE7 icon, it errors at: Cannot find SHblahblah Entry Point in file SHLWAPI.DLL. The file in Windows\System32 is dated the Sept 1981 date and there are 2 SHLWAPI.DLL files in some update folders. Since the SHLWAPI.DLL file is protected, I can't delete it, but was able to rename it (??). I copied one of the update SHLWAPI.DLL files to the system32 folder, but same error. I'm thinking the renamed file is still active, so I'm in the process of starting in Safe mode to see if I can delete the renamed file, but if that doesn't work, I'm stuck. Any suggestions?

    Update 11/27- I do NOT recommend using a different SHLWAPI.DLL that has a different date than the core set of Windows files. Doing so causes Explorer.exe to show only desktop wallpaper and not show any Icons or Task Bar. Using ctrl-alt-delete will get the Task Manager and you can use File+New to get a Run window that lets you type in commands if you are fast enough. When I used the repair console to replace the old file, the system returned to the previous state. See below post for the solution that worked.
  13. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Hmm, the repair wasn't real fantastic was it? With all these errors :rolleyes:

    What I'd do is:
    • Confirm no malware (I think you are still in the process of this)
    • Run IE Reset Fixit Tool: [​IMG]
      • Or manually from HERE
    • Start > Run > SFC /ScanNow > ok (to confirm all Windows files are intact)
  14. jjwabraham

    jjwabraham TS Rookie Topic Starter

    Problem on its way to being solved

    Kimsland and all interested,

    I finally got to Internet Explorer and have downloaded SP2, which is now being installed. I had to uninstall IE7 from Add Remove Programs, so it was rolled back to IE6, which now matched the Windows XP SP1 file set from the Windows repair console.

    There was no serious malware or virus on the system, just an ADMEDIA.JQ and ADMEDIA.IU from Iwin games.

    Apparently the original BSOD was from one or more Windows core files becoming corrupted. Once all is complete, I'll post a summary. Thank you everyone for your input, especially Kimsland.
  15. kimsland

    kimsland Ex-TechSpotter Posts: 14,523


    Your first Minidumps stated: "Windows XP Kernel Version 2600 (Service Pack 2)"
    After Repair
    Your next Mindumps stated: "Windows XP Kernel Version 2600 (Service Pack 2)"

    You never had SP1, from what information you have provided
    How did you get to SP1 ?, seeming after repair, your Minidumps showed SP2

    Minidumps don't lie ;) So somehow you have not provided the correct sequence? Or You never had SP1 ?
    Can you explain this?

    Do note, that you should be installing the latest Service Pack, which is SP3
  16. jjwabraham

    jjwabraham TS Rookie Topic Starter

    Made Assumption of SP1, May Have Been Original

    Hi Kimsland,

    I used an original Windows XP Home CD and assumed it was an SP1. But the point is that the repair of Windows mixed Original files (Sept 2001) with SP2 files and IE7 files (which requires SP2 to run correctly). My guess is that the minidumps 11/26 #2 and #3 were reporting on the previous problems as SP2, and minidumps 11/26 #4 and #5 show:

    BCCode: C2 BCP1: 43, BCP2: D0B91000, BCP3: 0, BCP4: 0 OS Ver 5_1_2600 SP: 0_0 Product: 768_1 with a minidump file Mini112609-04.dmp

    BCCode: 10000050 BCP1: 43, BCP2: D90F5E58, BCP3: 1, BCP4: 8063CBE6 OS Ver 5_1_2600 SP: 0_0 Product: 768_1 with a minidump file Mini112609-05.dmp

    As far as using SP3, I've had a few problems with installing it on my laptop and with a few customers. I've avoided putting SP3 on my wife's machine because she expects stability over performance.
  17. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    You mean similar to this thread that you have had more issues than most others?

    No, its actually better to upgrade to SP3, for better Performance and Security ;)
    And then do the Security Updates, since SP3 was made available (many months ago)
    I can tell you now, that SP3 is working perfectly on all XP computer systems :) (including mine)
  18. jjwabraham

    jjwabraham TS Rookie Topic Starter

    I do seem to have more than my share


    I will do the SP3 and additional updates. The SP2 update was successful except that the USB mouse and keyboard stopped working, minor glitch. I was able to hook up a PS2 mouse that worked and moved to the next updates. Will keep you posted.
  19. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

    Hi John, and Kimsland,

    I have been dropping in, looking over your shoulders from time to time. If I may offer a couple of things...

    I would second Kimsland's advice on SP3.
    The security updates are significant. To me, security equals stability.
    And like Kimsland, I have had no issues with SP3.

    And one more thing so far... ADMEDIA.JQ etc are Adspy = Potentially Undesirable Programs (at least!).
    If stability is an issue for you, I might suggest that you may wish to reconsider Iwin games.
    This is not the first time I have seen gaming sites related to computer problems.
    (I would strongly suggest paying serious attention to the advice of a malware expert on this one!)

    Finally, returning to where the problems began...
    Downloading software...
    This too is often a source of computer problems.
    The software in question, this time, was DVD labeling software... even so.
  20. jjwabraham

    jjwabraham TS Rookie Topic Starter

    Thank you for your input, B00kwyrm

    I appreciate your input and advice, B00kWyrm. I agree that the ADSPY junk is potentially dangerous and I don't abide any of it when I find it, but I didn't think it was responsible for the BSOD's, but you never know, may have been poorly written code that corrupted some Windows files. The reason for the BSOD's still eludes me, but with all of the help and advice I've received, it has certainly been better than having to redo the whole thing.
  21. jjwabraham

    jjwabraham TS Rookie Topic Starter

    Latest: SP3 downloaded successfully and the problem with USB stuff was a lack of driver, which was found on the Windows XP CD (??). Why it worked before doing the first set of updates and didn't work after the updates is a mystery, but now in the past, so water under the bridge.
  22. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Thanks B00kWyrm, but we are presently in "BSOD Help & Support " forum, so Malware removal hasn't really been fully covered.
    But I do appreciate the input you give (actually anywhere :))

    If you feel that you would like to check for malware, please go through this guide: UPDATED 8-step Viruses/Spyware/Malware Preliminary Removal Instructions getting an all clear by a malware expert.

    Exactly how is it running now?
    You may want to finish off by running a cleanup with the just released new version of CCleaner
  23. jjwabraham

    jjwabraham TS Rookie Topic Starter

    Greetings from the Formerly BSOD Machine

    Well Kimsland, B00kWyrm, thanks to your help, I am communicating from the machine with all the trouble, which now seems fully functional.

    Here is a summary and lessons learned from my perspective:

    Problem: Started with BSOD Page Fault in Non Paged Area consistently, right after a normal reboot and the Windows is Starting Up... splash screen. No hardware was added or settings knowingly changed prior to a middle of the day restart.

    Kimsland suggested going into Window Repair Console (with instructions) to run the CHKDSK /R, which ran successfully, but no go.

    B00kWyrm suggested a possible memory issue and other stuff, but memory had been changed, no go.

    Kimsland suggested trying Windows Installation - Repair existing Windows installation option. Go, with errors and no wireless internet connection.

    I tried some things and learned some lessons while waiting for outside ideas and after some tiresome reinstallation review, got back to the previous step.

    Kimsland suggested trying an uninstallation of AVG and installing Avira Antivir antivirus and Malwarebytes' Anti-Malware. Go, with no infections and a need to update both.

    I brought the computer to the router downstairs and connected with a cable. The Avira Antivirus was able to find updates and download and a Java Update downloaded and installed, so a connection was there. When I tried to open the IE7 icon, there was an error with file wzcdlg.dll and IE wouldn’t open.

    So, I did a full scan with the Avira and 2 of the ADSPYs were back and were taken out. Then it occurred to me that if I uninstalled IE7 I might have a better chance with the IE6 that came with XP Home. Once the IE7 was gone, I was able to download and install all the updates through SP3. Problem Solved.

    Lessons Learned:

    It’s not a good idea to try to use other XP Home installations to copy suspected corrupted files from one to the other. Unexpected and time consuming mistakes will occur.

    When you use the Windows installation repair option, in an SP2 or SP3 updated machine, you save the trouble of a complete system wipe and reinstall of everything, but you’d better be prepared to deal with several compatibility errors.

    IE7 requires an SP2 or above system to work. If you use an SP0 installation disk, you should uninstall IE7 to be able to use a browser till you can update.

    Moderater: I consider this string closed once any other contributors wish to add anything of import toward lessons learned. Thank you again for all the help.
  24. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Thanks for the update :grinthumb

    Yes it was a few things (not just one) that needed to be done
    Although its not as perfect as a clean install, for all intentions if a User wants their computer fixed without re-install, the above did it. (in this case)

    Possibly a good tool to have available is UBCD4Win (especially whilst its working, as it needs to be "created" first) and, its free :))
    Here it is:
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...