BSOD in some games but only when attempting to move about in the game

By aec618
Mar 29, 2008
  1. I rarely play games but recently decided to try a few. Bought Silent Hunter 4 and needed a video card to run it, so got an ATI Radeon HD2400 AGP8X card 256MB. My game would load and run a while then kick me out to the desktop if I did too many things at once. Also tried playing my old copy of MS Flight Sim 98 and would get crash/program exit if I tried to move the airplane. Meanwhile bought a Saitek joystick that came with Flightsim X Demo. Installed it, and the game opens and loads great, looks teriffic. However, the instant I try to actually do anthing besides look around (e.g. fly the plane down the runway), I get BSOD stating (usually) Bad_Pool_Header and occasionally Page Fault in Nonpaged Area. Until now, my PC's been running like a champ. I update regularly, and run Norton Systemworks on a weekly basis to keep things tuned up.

    I did some online research and based on that, I thought I could have bad RAM; I tested it with Windows Memory Diagnostic and sure enough, bad RAM. Replaced it with two 1GB sticks of PC3200 from Crucial, re-ran WMD, no errors. Still had the same problem with the flight sim games. Solved the sub game problems by scaling back the graphics details in the game.

    Thought it could be the video card so I returned it last night and bought a GeForce 7600GS with 512MB. Also manually set my memory settings in the BIOS because leaving them set to "Auto" was running my 200MHz memory at 133 MHz (so said CPU-Z utility).

    Unfortunately the problem with the BSODs persists, apparently isolated to the two flight sim games, and occurs whether I use the joystick or not. Please advise how to proceed from here. I'd rather not do a complete re-install of Windows if I don't have to--thats a whole weekend deal! Even though my data is all backed up, I'd still have to reinstall the OS and all my software; and then those Windows Updates ad infinitum!

    I don't understand how the graphics would work fine most of the time (even within the affected game, as long as I don't "move"!) and then crash my PC at other times. I would have figured either the graphics would work or they wouldn't.

    One other spec I didn't list is my antivirus program: Symantec Endpoint Protection--one of those you get from your employer without charge or expiration--it's an AV, anti-spyware, and network firewall all in one.

    Thanks in advance for your help!

    ** Problem Solved 3/30/08 :D

    Thanks to Route44 for suggesting it was a bad driver. I also saw another post on this forum--somewhere ;) that talked about checking the audio driver as well as the video driver. Hadn't thought of that. I downloaded the latest driver for my onboard audio from the Asus website, and forgot that I should have uninstalled the existing driver first. But it's good that I forgot, because I got the same BSOD and figured I was on to something.

    So, I completely uninstalled the audio driver, disabled the onboard audio in the BIOS setup, rebooted, ran Norton Systemworks and RegCure to clean out any leftover junk, then installed the new audio driver and rebooted.

    Next I tried to reinstall Flight Simulator X Demo from the CD-ROM that came with my Saitek joystick, and noticed it reported a bad ZIP file during the unzipping process. So I nixed the install and downloaded the demo from Microsoft's website instead (70 minutes on a cable modem connection!!). Ran that install routine successfully, loaded the game, and it WORKS! I just "flew" a jet into a lovely tropical Carribean airport without issues, and actually was even able to land the darned thing without crashing (the plane or the PC!)
  2. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    BAD_POOL_HEADER: A pool header issue is a problem with Windows memory allocation. Device driver issues are probably the most common, but this can have diverse causes including bad sectors or other disk write issues, and problems with some routers.

    PAGE_FAULT_IN_NONPAGED_AREA: Requested data was not in memory. An invalid system memory address was referenced. Defective memory (including main memory, L2 RAM cache, video RAM) or incompatible software (including remote control and antivirus software) might cause this Stop message, as may other hardware problems (e.g., incorrect SCSI termination or a flawed PCI card).

    Update your graphics drivers and see if it brings stability. Years ago when I ran Thief: The Dark Project I would get kicked out. For some reason both my video and audio drivers were the issue with this game, but not others.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...