BSOD Invalid_work_queue_item

By alpha1solo ยท 10 replies
May 29, 2009
  1. Hello all,

    I have a Dell latitude 430 with 1.5 GIG Ram that has received several BSOD with the above message in the past several days. No changes to hardware or software that I can see. I have run extensive Dell diagnostics tests and Dell claims it is software related. I stumbled on your article below

    I am going to run the Memtest86 as suggested, but as the Dell Ram test passed, I am writing this simultaneously to see if someone can help me analyse the crash dumps. I have already reseated the 512 mem and the 1GB is non removable on this model. I have run a chkdsk /f on the 80 gig 2.5 HD, checked for non-standard or newly installed SW, removed all temp files, and defragged the box. I have tried setting up the crashdmp utility on my pc, but have not been able to successfully read the contents of the dumps.

    Can someone please assist?

    Thank you,

  2. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Question, does this PC have a Media Card installed that you use to transfer didgital media to your PC, particularly SD?
  3. alpha1solo

    alpha1solo TS Rookie Topic Starter

    Yes it does

    It does in fact have an SD card that a used for the first time shortly before this PC began misbehaving.
  4. snowchick7669

    snowchick7669 TS Maniac Posts: 660

    Have you recently updated any of your drivers?

    I've seen this occur when a device driver update has been obtained through windows update
  5. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Hey snowchick three minidumps are 0x96 and they only cite a Windows driver, nothing else specific but it is definitely driver related.

    The other two errors are oxA and both gave a very long list of drivers unable to load. In both the Windows driver sdbus.sys was cited as the problem, thus my inquiry about the Media Card, particularly SD.

    Possibility: Drivers are corrupted as you suggest OR the SD Card has gone bad.
  6. snowchick7669

    snowchick7669 TS Maniac Posts: 660

    Thanks Route44,

    Was just popping my head in :)

    Sounds like you have this one under control.

    Have a good weekend!
  7. alpha1solo

    alpha1solo TS Rookie Topic Starter

    No recent windows updates, programs, or drivers appear to have been installed or updated.
  8. alpha1solo

    alpha1solo TS Rookie Topic Starter

    I tried to read an SD card from his PC about a week or so ago, but was having issues with it even recognizing the hardware being installed correctly in the PC. I can try to disable the device in Dev Mgr Monday AM and see what happens. I will post as soon as I am able to do so. Thank you.
  9. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Yes, please let us know. It sounds like your Dell system and the SD media card are having issues.
  10. alpha1solo

    alpha1solo TS Rookie Topic Starter

    Okay, I now have the laptop back in front of me. I have checked and the device appears to be working now so if memory serves, I did try to update the driver when I tried to use it last time. The device is using a Microsoft driver so windows update may have pulled it down

    sdbus.sys is the driver version 6.0.4069.5512

    My end user does not need to use the device so I have now disabled it and will give it to the user to see if this clears up the issues.
  11. alpha1solo

    alpha1solo TS Rookie Topic Starter


    Route44, Thank you for your assistance. I am going to call this resolved at this point as I have been banging away on the PC for 2 days solid without incident. Excellent forum you guys! Thanks again for the help.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...