BSOD - USB printer causes crash in PartMgr.sys

By faejon ยท 12 replies
Feb 23, 2006
  1. I have done some research and am unable to find a solution. I am hoping that the experts here can provide me with a resolution.

    I am trying to resolve a hard crash with reboot. I have a USB printer that was working fine. I attempted to upgrade the drivers for the printer and the steps call for me to disconnect the USB, run the driver install, then plug in the USB when the install asks for it. When it comes time to plug back in the USB printer the system reboots.

    I am attaching a couple of minidumps as well as the log output of a larger kernel dump with symbols and a backtrace.

    Here is the relevant information from the event log.

    Event Type: Error
    Event Source: System Error
    Event Category: (102)
    Event ID: 1003
    Date: 2/22/2006
    Time: 6:17:56 AM
    User: N/A
    Computer: FAMILY
    Error code 1000007e, parameter1 c0000005, parameter2 f9abcc26, parameter3
    f9c818f0, parameter4 f9c815ec.
    0000: 53 79 73 74 65 6d 20 45 System E
    0008: 72 72 6f 72 20 20 45 72 rror Er
    0010: 72 6f 72 20 63 6f 64 65 ror code
    0018: 20 31 30 30 30 30 30 37 1000007
    0020: 65 20 20 50 61 72 61 6d e Param
    0028: 65 74 65 72 73 20 63 30 eters c0
    0030: 30 30 30 30 30 35 2c 20 000005,
    0038: 66 39 61 62 63 63 32 36 f9abcc26
    0040: 2c 20 66 39 63 38 31 38 , f9c818
    0048: 66 30 2c 20 66 39 63 38 f0, f9c8
    0050: 31 35 65 63 15ec

    Event Type: Information
    Event Source: Save Dump
    Event Category: None
    Event ID: 1001
    Date: 2/22/2006
    Time: 6:17:10 AM
    User: N/A
    Computer: FAMILY
    The computer has rebooted from a bugcheck. The bugcheck was: 0x1000007e
    (0xc0000005, 0xf9abcc26, 0xf9c818f0, 0xf9c815ec). A dump was saved in:
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Both minidumps crash at PartMgr.sys. Partition Manager.

    Since this problem only occured after you`d tried to install updated drivers for your printer, try uninstalling the drivers, and reinstalling the original drivers.


    A system thread generated an exception which the error handler did not catch. There are numerous individual causes for this problem, including hardware incompatibility, a faulty device driver or system service, or some software issues. Check Event Viewer (EventVwr.msc) for additional information.

    Regards Howard :wave: :wave:
  3. faejon

    faejon TS Rookie Topic Starter

    I have uninstalled the drivers and reinstalled the old drivers from the original CD. The crash occurs during the driver install when it asks you to now plug in the USB device.

    So, the crash occurs when the USB device is plugged in regardless of which driver versions are installed.
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Have you tried using a different usb socket? Maybe a different usb cable.

    Regards Howard :)
  5. faejon

    faejon TS Rookie Topic Starter

    I have tried all the available USB ports on the computer with the same result. I don't have another USB cable.

    Let me give you some more info. The Printer is the HP PhotoSmart 1115 which has 2 memory card reader slots. The slots are not loaded with any memory cards at this time. If I start in Safe Mode and insert the USB cable then windows detects and installs the device. It registers in Device manager as a DOT4 printer and it also registers a generic storage device (memory card slots).

    There is obviously a conflict with Partion Manager for the memory card slots and something else but what I don't know.

    I have another memory dump from my latest attempt to insert the USB cable if you want me to attach it I can. If you just want the debug text from windbg I can provide that as well.

    Thank you for the responses.
  6. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    I have a feeling your latest minidump will say the same thing, but you may as well attach it anyway.

    Regards Howard :)
  7. faejon

    faejon TS Rookie Topic Starter

    Additional minidumps

    I have attached 4 additional mini dumps from today 02/23/2006.

    I have been checking date/timestamps on drivers files trying to find if any of the files have mismatched version numbers. So far no luck.

    I am afraid I will have to do a format and reinstall.

    Again, thanks for looking.
  8. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    All four minidumps crash with exactly the same problem as your last batch.

    Before you go and start reformatting. Go HERE and follow the instructions for testing your hard drive.

    Regards Howard :)
  9. faejon

    faejon TS Rookie Topic Starter

    I read your FAQ before I posted.

    I did check the disk for errors from the tools menu (Hard Disk C: Properties -> Tools -> Error-checking -> press Check Now). I used the options Automatically fix file system errors and Scan for and attempt recovery of bad sectors. I believe this is the same as command line chkdsk /f /r. It requires exclusive access to the hard disk and will run on next boot.

    The disk check did not turn up any bad blocks.

    I also used a Fedora Core 2 boot CD which has memtest on it. I ran that for 24 passes and they all passed.

    Here is a list of items checked:

    USB cable - passed
    Hard Drive - passed
    Memory - passed
    Driver files - uninstalled / reinstalled / checked for version mismatch - passed

    I have another printer, not the same model, that I am going to try tomorrow. If that works without crashing I am just gonna swap printers. This is apparently a conflict between Microsoft and HP but I don't really have the time or tools to test each .dll and driver file.

    To make matters worse the HP uninstaller does not remove everything. After I uninstalled the printer I still found registry entries and driver files in C:\WINNT, C:\WINNT\System32, and C:\WINNT\System32\drivers. In my tests I moved those HP files out of the way and then reinstalled fresh.
  10. BigDaddy

    BigDaddy TS Rookie

    Similar PartMgr.sys error

    I too am trying to resolve a similar hard crash with reboot. I have a USB printer that was working fine with my PC. I decided to give the HP Photosmart 7550 to my wife. Unfortunately it refuses to install on her PC.

    Using the CD that came with the printer, I attempted to install the drivers for the printer and the steps call for me to disconnect the USB, run the driver install, then plug in the USB when the install asks for it. When it comes time to plug back in the USB printer the system reboots. When it finishes the reboot, it goes to a blue screen with a PartMgr.sys error.

    I have spent many hours uninstalling all the printers on her DELL PC. Even with the other printers uninstalled, I get the same blue screen with the same error message. I have followed HP's instructions to the letter many times over with no success.

    Google found your post and I was pleased to find something written on what seems to be the same or a very similar problem. I was listening in to find out what fixed your problem, hoping it might pertain to mine as well.

    My wifes PC is a DELL 2400 with Win XP Home Edition, SP2 installed and 512 MB RAM. Other than refusing to work with this HP printer, the DELL has been without problems.

    I'm a retiree with minimal experience so I am not up to your level of experience with PC's. I usually get by on my own with little need to ask for help. But this has me stumped.
  11. faejon

    faejon TS Rookie Topic Starter

    BigDaddy I am sorry to say I was unable to resolve the issue with that printer. What I ended up doing is swapping printers with another computer.

    The HP 1115 works great on my wife's Win 2000 computer and the other computer now uses a HP 720c. It's not a photosmart printer, but then, never used the HP 1115 to print photos before it stopped working on that computer.
  12. N3051M

    N3051M TS Evangelist Posts: 2,115

    Have you guys tried going down to Device manager>USB, uninstall everything under the tree related to USBs and reboot so it reinstall default drivers for the USB ports, incase that got somehow corrupted?

    Edit: does it only affect the printer or other USB devices connected?
  13. sjolin

    sjolin TS Rookie

    Device Management

    This from a non-tech: The last poster suggested going to Device Manager and uninstalling all usb devices. I went there (control panel, system, device manager, etc.), uninstalled just the HP5500 items, rebooted, put in the original HP CD and ran install until it told me a later version was already there and I should just plug in the usb device, which I did. Checking device manager, I see that the printer is re-installed. So far I haven't had the crashes I'd been having with such regularity, but I want to see what happens as time passes.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...