1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

BSOD when connecting USB wireless adapter

By eerievon ยท 8 replies
Jul 21, 2011
Post New Reply
  1. Hello,

    I've recently run into a problem with connecting my usb wireless adapter. Every time that I try to connect it to my computer I will get a bsod within a minute or so after the driver has been installed. I've tried using the driver that windows installs automatically and I've tried using the one that is posted on the website as the most current and up to date one and I still have the same problem. I've ran chkdsk, did the defrag and ran some other clean up utilities and that did help everything run smoother but still no matter what I do, the system will crash when I connect the wireless adapter. When I can catch what file caused the bsod, I see one of two files responsible for the crash either athrusb.sys or nwifi.sys but most of the time it has been athrusb.sys
    I've attached the only two dump files that I could find in the minidump folder. The adapter is a SMC Ez Connect g 802.11g wireless USB 2.0 adapter

    Any help is greatly appreciated

    Attached Files:

  2. Mark56

    Mark56 TechSpot Paladin Posts: 1,880

    The minidumps are both very similar and both name the athrusb.sys wireless LAN driver from Atheros. Is that a driver for an old wireless card or a previous USB adapter?

    Have you still got a wireless card fitted. If so remove it and try again.

    nwifi.sys was not in these two dumps but that is a windows miniport driver.

    Use this guide to make sure there are no old wireless drivers still installed.
  3. eerievon

    eerievon TS Rookie Topic Starter Posts: 20

    Hmm...I don't know on that for certain. The only wireless adapter I've used is the SMC one and that one is currently disconnected.
    I'm going to try that link out and see what happens.
    Thanks again
  4. eerievon

    eerievon TS Rookie Topic Starter Posts: 20

    Well I followed that guide to uninstall the hidden drivers, thanks for that. I didn't see anything that was Atheros though I wasn't sure what to look for and was just looking for something that said Atheros. I did go through and remove all the extra usb and network adapters and then reinstalled the wireless adapter and that is what i'm using currently and so far it hasn't crashed.

    thanks again and I'll keep you posted as to whether or not this works :)
  5. Mark56

    Mark56 TechSpot Paladin Posts: 1,880

    That sounds encouraging. Drivers don't always have the manufacturer's name on display but sounds like you got rid of the one that was causing the problem.
  6. eerievon

    eerievon TS Rookie Topic Starter Posts: 20

    Well it was encouraging for a little while :)

    The computer didn't crash at all for the couple of hours that I was on it. So I went ahead and started a download to test it through the night and it appears that just shortly after I went to bed it crashed on me. When I got up this morning I was greeted by the logon screen and had the little msg telling me that windows had just recovered.
    I went and uninstalled the driver, and took out the usb device and tried it in another usb port. It took a few minutes but it crashed again and then I did the same thing a couple of more times and have the crash logs to prove it :)

    Attached Files:

  7. Mark56

    Mark56 TechSpot Paladin Posts: 1,880

    There is still a problem with athrusb.sys and also a file called sptd.sys which is related to Daemon tools, do you have that software, if so uninstall it, that particular driver is known to cause problems. Once done follow this.

    Open the windows explorer and click on the > next to the C: drive or which ever drive Windows is installed on. Then click the > next to Windows > System32 then click on the word 'Drivers' so all the drivers are listed in the right hand pane. Scroll down the list to find athrusb.sys and sptd.sys. Right click on each one in turn and select rename. Change the .sys to .old

    Sptd.sys should not be there after Daemon tools is uninstalled but it may get left behind.

    Now try the USB device again and see what happens. If it still causes a problem repeat the above process for the driver nwifi.sys and test again.

    The reason for changing the extension of the files to .old is to stop it from being used, but reversible if it causes any other problems as you can go back and reverse what has been done. This is preferable to deleting it.
  8. eerievon

    eerievon TS Rookie Topic Starter Posts: 20

    didn't know that about daemon, uninstalled it and went through and changed the .sys file names and still crashed :) that is the log 23696. I tried to go back in and change the nwifi.sys file but even when I try it in safe mode I get a msg telling me that I have to have permission from some long series of numbers before I can change it.

    Attached Files:

  9. Mark56

    Mark56 TechSpot Paladin Posts: 1,880

    The 23696 minidump clearly states Memory Corruption so we need to check your RAM. The other minidumps are just the same as before. The nwifi.sys is a protected Windows diver so that would by why it won't let you change it's name, not to worry.

    Please remove your memory sticks leaving just one in place and run the PC to see if you still get BSOD's, if you do, swap the sticks so you try each one in turn. There is a good chance the BSOD's will only occur on one of the sticks.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...