BSOD woes - ntoskrnl.exe, rdyboost.sys, Ntfs.sys

Not open for further replies.


Posts: 19   +0

I built a new computer three weeks ago and started receiving numerous BSOD's about a week into its life.

During the BSOD, I've seen reports of a wide range of errors, but by far, the most common errors are PAGE_FAULT_IN_NON_PAGED_AREA and MEMORY_MANAGEMENT. The BSOD analysis program BlueScreenView has highlighted the file ntoskrnl.exe as the main culprit in every case. Files Ntfs.sys and rdyboost.sys have been highlighted before, as well.

Update: Since I've written this thread, my computer has blue screened three more times. On the latest error and in addition to ntoskrnl.exe, BlueScreenView has also highlighted filename afd.sys.


I've run Memtest86+ for seven passes and no errors came up. I've been able to temporarily fix the BSOD's for 2-3 days at a time by installing Windows Driver Kit 7.1.0., but the blue screens have been coming back with a vengeance.

Also, while my computer is in its fragile state, Firefox has been crashing non-stop.

Attached are my five most recent minidumps. Any advice will be greatly, greatly appreciated. If I'm missing anything important, please let me know. Thank you so much in advance!

My computer specs are:
Windows 7 Professional 64-bit
Intel Core i7-860
Gigabyte GA-P55A-UD4P
G.Skill 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800)
XFX Nvidia 7900GTX
Rosewill RG630-S12 630W PSU



Posts: 12,015   +81
magicchef that is certainly a boatload of BSODs. What we needi is the five most recent minidump files in one Zip file.


Posts: 12,015   +81
When we see so many different error codes and system crashes that is a good sign of memory corruption. Believe it or not this was cited as the cause of your problems.

I know you did memtest but bad RAM has been known on occasion to pass. You have G.Skill memory which is excellent.

Go to your BIOS and see if your motherboard set your memory voltage to the correct voltage as per your RAM's specs. We have seen many corruption reads due to the fact of wrong voltage settings rather than the memory itself being corrupted.

What make is your motherboard and does the mobo manufacturer recommend your particular memory for your board?


Posts: 19   +0
  • Thread Starter Thread Starter
  • #5
Thanks for the quick reply! :)

I'm currently using a Gigabyte GA-P55A-UD4P motherboard. The memory I'm using is on their compatibility list. These are the tech specs found on Newegg:

Capacity 4GB (2 x 2GB)
Speed DDR3 1600 (PC3 12800)
Cas Latency 9
Timing 9-9-9-24
Voltage 1.5V
Buffered/Registered Unbuffered

And in the BIOS:

BCLK 133.28 MHz
CPU Frequency 2932.18 Mhz
Memory Frequency 1599.32 Mhz
Total Memory Size 4096MB

Vcore 1.104V
DRAM Voltage 1.536V

Extreme Memory Profile (X.M.P.) [Profile 1]
System Memory Multiplier (SPD) [Auto]
Memory Frequency(MHz) 1600 1600
Performance Enhance [Standard]
DRAM Timing Selectable (SPD) [Auto]
Profile DDR Voltage 1.5V
Profile QPI Voltage 1.1V
x Channel Interleaving 6 Auto
x Rank Interleaving 4 Auto

>>>>> Channel A (&B) Standard Timing Control
x CAS Latency Time 9 Auto
x tRCD 9 Auto
x tRP 9 Auto
x tRAS 24 Auto

>>>>> Channel A (&B) Advanced Timing Control
x tRC 40 Auto
x tRRD 5 Auto
x tWTR 6 Auto
x tWR 12 Auto
x tWTP 24 Auto
x tWL 8 Auto
x tRFC 88 Auto
x tRTP 6 Auto
x tFAW 60 Auto
x Command Rate (CMD) 2 Auto

>>>>> Channel A Misc Timing Control
x B2B CAS Delay -- Auto
x Round Trip Latency 44 Auto

>>>>> Channel B Misc Timing Control
x B2B CAS Delay -- Auto
x Round Trip Latency 46 Auto

Sorry if that was way more detail that you needed. Maybe there's something that's off beyond just voltage. Thanks!

Update: My computer just crashed again. BlueScreenView is highlighting ntoskrnl.exe, ataport.sys, and fltmgr.sys, now. :(



Posts: 12,015   +81
One error is0x0000001A: MEMORY_MANAGEMENT
This memory management error is usually hardware related.

Requested data was not in memory. An invalid system memory address was referenced. Defective memory (including main memory, L2 RAM cache, video RAM) or incompatible software (including remote control and antivirus software) might cause this Stop message, as may other hardware problems (e.g., incorrect SCSI termination or a flawed PCI card).

Both cited Windows OS drivers and the thing about OS drivers is that they are usually too general to be of much help.

Try this: Go into your BIOS and set your RAM voltage as close as you can to 1.5 volts.

* If you only have one or two minidumps just attach as is. Three or more put into a Zip file.


Posts: 19   +0
  • Thread Starter Thread Starter
  • #7
The best I can do is manually set the DRAM voltage to 1.500V, rather than leave it on Auto. I'm still getting the same readings (1.536V), though.

Do I have any other options?


Posts: 19   +0
  • Thread Starter Thread Starter
  • #9
Hehe, well, I set it to 1.5V manually. DRAM Voltage still reads 1.536V, and I just blue screened. :(

I turned off my computer and switched the positions of the two sticks of RAM with each other. (I can't switch lanes because my heatsink is blocking one of them.) Upon boot-up, I get the message that there was a failure to boot because of OC'ing or because the voltages were too high. I enter BIOS and the DRAM Voltage read 1.586V. So, I reset the DRAM Voltage to Auto and saved and quit. It read 1.536V again, so I set the DRAM Voltage back to 1.50V manually. (Sorry if that was confusing.)

It's been about ten minutes and I haven't blue screened yet, but it's too soon to tell. And for some reason (I forgot to mention this earlier), my HDD indicator on my case keeps flashing (I have no other active applications but Firefox running.)

Thanks for all the help, thus far! I really appreciate it, Route44.


Posts: 12,015   +81
Okay, so far with your system memory running at 1.5v you are experiencing stability. Why it jumped your voltage to a higher setting under auto is confusing.

When you manually set it in the BIOS at 1.5 did you save it before exiting the BIOS?

Also, concerning your harddrive have you had this issue before? It wouldn't hurt to run a harddrive diagnostics at this point.


Posts: 19   +0
  • Thread Starter Thread Starter
  • #11
Ah, well, when I first manually set it to 1.5V, it blue screened once. I did remember to save (F10). After switching the sticks, it has hasn't blue screened yet. (The voltage jumped while it was manually set at 1.5V.) Firefox is still crashing, though, but not as often. I'm now also getting errors trying to update Windows (Codes 800706BA & 800706BE), which has never happened before.

Today, my HDD indicator is flashing once per second while idle. When my computer was unstable and the HDD was busy (even though I wasn't doing anything) it was a likely sign of an impending BSOD.

I don't know if these problems are all related--they're just all happening at the same time. When Firefox was constantly crashing, that was a huge indication of instability, however.

How do I run a HDD diagnostic?

Thank you!


Posts: 12,015   +81
Find the make of your harddrive, go to your manufacture's website and download their free harddrive utility. If it is a Seagate or Maxtor you will use their SeaTools. It will work like Memtest, i.e. burn the ISO file to a CD, set your CD/DVD drive to first bootable, place CD in ROM drive and reboot. It will load almost as soon as you boot-up. Chhose your tests. Make sure yo run S.M.A.R.T., short and long tests.

Western Digital has their own utility. Run the tests as well.

* I'm wondering if it is your psu.


Posts: 19   +0
  • Thread Starter Thread Starter
  • #13
I'm going to have to try that tonight! So far, my computer has only BSOD twice since we last spoke.

This is my plan, please tell me if it's logical. If there are no errors with my HDD's, I'm going to try to repair Windows with the installation CD. If that doesn't work, I'll format my computer. And finally, if that doesn't work either, I'm going to RMA my RAM.


Posts: 12,015   +81
I have been in search of an answer to your dilemma. A man I higherly respect, Mr J.L. Reich, who has deep knowledge of PCs wrote me in regards to your continuous issue. Here is what he suggested:

1.536 may be correct. Often there is a small difference in the actual and what is listed in the general specs. It is just so close they round it off.

Checking the power supply is a good start: To determine if it is functioning properly and that it is of decent quality and that it is adequate for the system.

Also check for BIOS updates and that the CPU is actually supported.

In the MIT section of the BIOS make sure the "performance enhance" option is set to "standard". It is usually set to "turbo" by default. Make sure the memory timings are correctly set. If not set them manually. You may need to set the timings to "manual" to see them, if they are correct set it back to auto, if not make the necessary changes and leave it on manual.

Before reformatting consider the above. Also, let us know what the harddrive diagnostics show.


Posts: 19   +0
  • Thread Starter Thread Starter
  • #15
I'm just a newbie here, but I'm very, very impressed with your level of dedication to helping others! :) Thank you so much.

Anyway, I went ahead and set "Performance Enhance" to standard. My memory timings match the product's tech specs. I do have another question regarding timings, though. Under my RAM's customer reviews on Newegg, a few customers have advised to set FSB : DRAM to 1:4. But according to CPU-Z, my FSB : DRAM is currently set at 2:12. Is this a big deal? Also, I couldn't find where to adjust it in BIOS.

Also, how would I test my PSU? I would think that 630W would be enough to power my CPU, three small HDD's (200, 300 and 640GB) and an Nvidia 7900GTX.


Posts: 12,015   +81
Yes 630 watts would be enough but what we're testing for is whether or not your power supply is delivering the power/watts/amperage it is rated for. In other words, is it supplying the power it says it is designed to provide. If not then that is a serious issue because the psu is the backbone of a system.

I need to leave for a couple of hours but I'll get back to you as soon as I can.

Update: from jlreich

If it isn't there then it isn't adjustable. "System Memory Multiplier" is the closest you are going to get. This is not a bad thing. Some setups have it some don't. If you don't have it don't worry about it.

Did setting the performance to standard make any difference?

What about checking for a BIOS update? What version are you running? BIOS F7 shows "enhanced memory compatibility". F10, the latest released on 04/23, shows CPU micro code updates. If you are running less than F7 I would go ahead and update to F10.

If it is set for standard performance, you are not overclocking, all the ram settings/timings are correct, the powers supply is good, and BIOS is updated and CPU is officially supported with current BIOS then it comes down to the board or the ram. My vote is for the ram. But if possible I would like to see some known good compatible ram swapped in there to make sure the issue goes away. It doesn't have to be the same speed or anything, just compatible DDR3. If that is not possible then I would RMA the RAM.


Posts: 19   +0
  • Thread Starter Thread Starter
  • #17
Hey Route44,

Sorry I've been away. I was in the process of moving back home from college and didn't have access to this computer for a while.

However, after 2-3 days without turning on the computer, it crashed three times in a row during boot-up. I popped in the Windows 7 installation CD and ran a repair. I forgot exactly what it fixed, but it had something to do with my HDD missing an important file(?). My computer has not crashed since; it's been three days now!

I'm running BIOS F6, by the way. I'm not 100% sure whether or not setting Performance Enhancement to "standard" has helped because my computer did BSOD a few times afterwards.

Everything seems to be okay now, though! Thank you so much again for all your help.


Posts: 12,015   +81
Great! I was wondering what happened to you but the whole college thing moving been there, done that. :) Enjoy these years while you can.

Believe it or not, my next suggestion was going to be a Windows Repair but you were ahead of the game. Good move on your part.

Thanks for getting back to us.


Posts: 19   +0
  • Thread Starter Thread Starter
  • #19
Hi again Route44!

My computer has been running problem-free until today. I went back to my college town to visit for the week, and when I got back home tonight and turned on my computer for the first time in five days, it would constantly BSOD just as Windows finishes loading. I tried to run Startup Repair from the installation disk again, but it wouldn't start for some reason.

I gave up and turned off my computer, trying again in another hour. This time, Startup Repair was able to run, and it fixed the problem, which happened to be the same as last time. This is part of the repair log:

Root cause found:
System volume on disk is corrupt.
Repair action: File system repair (chkdisk)

This is actually the second time that this particular problem has occurred--BSOD after a few days without using the computer. Any idea what causes this? TIA!


Posts: 12,015   +81
This sounds like a harddrive issue. First make sure your cables are secure. Second run the harddrive diagnostic utility on your harddrive(s).


Posts: 19   +0
  • Thread Starter Thread Starter
  • #21
Hi Route44,

I have two Maxtor SATA drives (200GB & 300GB) in my computer and one Western Digital HDD. The 200GB Maxtor HDD is my main drive.

I installed and ran SeaTools for Windows today and these are the results for my SMART check, Short, and Long tests:

SMART check - Pass
Short DST - Fail
Long DST - Fail

Maxtor 6L300S0
SMART check - Pass
Short DST - Fail
Long DST - Fail

Maxtor 6B200M0
SMART check - Pass
Short DST - Pass
Long DST - Pass

What should I do now? TIA


Posts: 12,015   +81
On those desks with fail back up everything important NOW. I can't stress this enough. Trying to access information from a crashed drive is very expensive.

The good thing is your main drive Maxtor 6B200M0 passed all three. Are you in a RAID set-up?

* By the way, kudos to you for being patient and runnin all the tests on all three drives because it takes a lot of time to do so.

Did you use the WD utility on your WD?


Posts: 19   +0
  • Thread Starter Thread Starter
  • #23
Hey Route44,

Just got back from visiting my college town and graduation! When I turned on my computer again, same problem--failed to boot after an extended time without use. I got a few error messages this time, however.

Message 1:
"Windows failed to start...etc.
File: \windows\System32\drivers\tcpip.sys
Satus: 0xc0000098
Info: Windows failed to load because a critical system driver is missing, or corrupt."

Message 2:
"The system has experienced boot failures because of overclocking or changes of voltages.

Last settings in BIOS setup may not coincide with current H/W states.

Current CPU Speed: 2.93GHz
Current BCLK: 133MHz
Current Memory Speed: 1333MHz"

It looks like my memory was clocked back down to 1333MHz (from 1600MHz, which my motherboard supports.)

And to answer your questions, I'm (edit: ) NOT in a RAID set-up. My Maxtor 6B200M0 passed all three. I backed up my data on the faulty 300GB HDD and removed it. (It was actually giving me problems a year or two ago--my computer wouldn't detect it sometimes.)

I found the Western Digital Data LifeGuard Disagnostics program to be much more comprehensive than SeaTools. The WD utility scans all HDD's I believe, not just WD ones.

My dad thinks my computer is giving me problems because I'm not using a jumper on my main HDD (bc I can't; it doesn't have the pins for it). Is this true? Also, is there something wrong with my memory? BIOS was giving me error messages about voltages and downclocked the memory.

Sorry for the long wait again. I should be staying at home now, so I can answer your replies more quickly now. Thanks for your help.


Posts: 12,015   +81
STOP error 0x98 means that the trial period for the Microsoft Windows operating system has ended. STOP code 0x00000098 may also
display "END_OF_NT_EVALUATION_PERIOD" on the same STOP message.

What OS do you have installed?

Does your motherboard support 1600MHz as standard or does the memory need to be overclocked to run it?


Posts: 19   +0
  • Thread Starter Thread Starter
  • #25
I'm using Windows 7 Professional.

I need to either enable Extreme Memory Profile (XMP) or to set System Memory Multiplier (SPD) to 12.0 to run the memory at 1600MHz.

Here's a customer review for my motherboard (GA-P55A-UD4P) which may or may not relate to my problem, assuming it's memory related:

"Other Thoughts: Maybe this is something that everyone but me knows, but no one talks about. If you enable the XMP in the BIOS, it will undo any overclocking you've done by setting everything to Auto. Re-entering the overclocked settings undoes nearly everything that the memory profile set. So I entered everything manually. I found that it could handle any kind of torture test for any length of time and then hours later bluescreen while I was reading a book. Even with no overclocking and everything set to spec.

Here's the caveat; when enabling XMP, it automatically sets the memory voltage *and* the QPI voltage. Intel specs say 1.5 V memory and 1.1 V QPI *and* less than 0.5 V difference between the two. My Corsair Ball-stix, like most 1600 MHz modules, needs 1.65 V. 1.65-1.1=0.55=random flavors of bluescreen. Once I got that right (QPI=1.25), it was happy to run with a base clock of 160 (x10 rather than 133x12) and no more bluescreens."

(My QPI is also automatically set to 1.1 V.)

Here are my five most recent minidumps, if you have the time. Thank you so much!


Not open for further replies.