BSOD woes - ntoskrnl.exe, rdyboost.sys, Ntfs.sys

By magicchef ยท 36 replies
Apr 26, 2010
  1. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    All errors are 0x00000050: PAGE_FAULT_IN_NONPAGED_AREA
    Requested data was not in memory. An invalid system memory address was referenced. Defective memory (including main memory, L2 RAM cache, video RAM) or incompatible software (including remote control and antivirus software) might cause this Stop message, as may other hardware problems (e.g., incorrect SCSI termination or a flawed PCI card).

    Three specifically cited memory corruption with the other two citing the OS drive ntfs.sys.

    I think it is time to contact Gigabyte about your memory issues especially with voltage. Tell them your error codes and the minidumps were read with multiple memory corruption reads but that memtest showed no actual corruption.

    Also make sure you tell them the different steps you attempted to rectify and how you came back to find the memory voltages were changed without any doing on your part.
  2. magicchef

    magicchef TS Rookie Topic Starter Posts: 19

    Ok, sounds good. I'm going to run memtest while I sleep tonight to see if anything comes up before I contact Gigabyte.
  3. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    That is a good idea. Olease keep us updated.
  4. magicchef

    magicchef TS Rookie Topic Starter Posts: 19

    Hey Route44,

    I ran memtest last night for 9 hours/13 passes; there were zero errors. After a bit of googling around, I think my my instability has been due to overclocking my memory with the wrong voltages set. My computer has been pretty stable at 1333MHz so far, but I won't know if everything is okay until I try to boot my computer after a week without use. I'll probably have to contact G.skill about how to properly set my frequency to 1600MHz, though.

    I've been having problems with my new video card (XFX 5770), however. Would you be able to help me with this, Route?
  5. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Overclocking? Did you mention this previously or did we deal with it because ocing will cause issues. Contact the mobo manufacture as well concerning the G.Skill and how you should go about ocing this RAM to get it to run to its designed specs.

    *** What did you do about the harddrive that failed the diagnostic tests?

    * What is going on with your 5770?
  6. magicchef

    magicchef TS Rookie Topic Starter Posts: 19

    Oh, hmm... well, my memory is automatically detected at 1333MHz. I don't know if setting it at 1600MHz is considered overclocking or not. Sorry to confuse you.

    I removed the harddrive that failed. It's in my dad's hands now--I don't know what he plans to do with it.

    I fixed my original problem with my video card, but now I have more issues. Here's the background story (I posted this on

    I just installed my 5770 yesterday and had problems from the get-go. Upon power-up, the video card's fan would rev at 100% and my computer would not POST, no matter how long I waited. It usually takes about 10-20 hard reboots to get my computer to boot normally. After that however, everything runs smoothly.

    There are times, too, when my video card boots without the fan going crazy, but there's still no display.

    This whole hard rebooting a million times seems to be taking a toll on my main HDD. Sometimes, when the video card starts normally and my computer POSTS, my main HDD isn't detected and consequently, Windows can't start. My previous card (7900GTX), still runs without a hitch.

    I've been researching my particular problem and haven't come across a working solution. I've uninstalled my previous Nvidia drivers. I've tried updating my BIOS to no avail. I've also tried switching memory slots, which some have reported to work, but my computer doesn't POST afterward. I've tested the 5770 on my dad's system and it booted fine on the first try!

    On a less serious note, the boot and Windows start screen is displayed in a 4:3 aspect ratio, rather than 16:10. These screens were 16:10 on my dad's system with my card.

    I've swapped power supplies with my old computer (Nspire 550W) and now my video card starts normally. My main HDD (Maxtor 6B200M0) is still occasionally not detected, however. Also, 4:3 aspect ratio still remains. Do you have any ideas why?

    My computer ran fine all of yesterday since I swapped PSUs. Before I went to bed, I put my computer to sleep. When I tried to wake it up this morning, however, I couldn't get a display and my keyboard and mouse weren't working. I had to flip the switch on my PSU to get my computer going again. But when Windows started, I started to get BSODs again (four most recent minidumps attached).

    Any idea what's going on with my computer? Thank you, Route.

    Attached Files:

  7. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Your four errors are: 0x24, 0xA, 0x1A, and 0x50. Three only cited Windows OS drivers but the 0x50 error specifically cited memory corruption as your issue.

    I am wondering if your motherboard might be the problem. Notice, I said might.

    And a poor psu will certainly cause issues.
  8. magicchef

    magicchef TS Rookie Topic Starter Posts: 19

    Goodness. How can I find out whether or not my motherboard is the problem? My motherboard doesn't quite fit in my case (mobo's back panel connectors don't completely reach the back of the case and is slightly misaligned with its I/O panel. I have to semi-forcefully tug on my video card to screw it in place.), so I wouldn't mind RMA'ing it.

    I ordered an OCZ ModXStream Pro 500W PSU yesterday hoping its better quality than my Nspire and Rosewill PSUs.
  9. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Check to see if the back of your motherboard is touching anything metal.
  10. magicchef

    magicchef TS Rookie Topic Starter Posts: 19

    The back of the motherboard isn't touching anything metal.
  11. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Just checking to see if it was shorting out. It happens from tiem to time.

    I should have added this in my previous post but do you see anything else in your system build that might be grounding out your system? You have had to do some modifications and I am wondering if there in might be the issue.
  12. magicchef

    magicchef TS Rookie Topic Starter Posts: 19

    Could you please give me an example of a possible modification? (I don't believe I did anything out of the ordinary to my system.)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...