1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

C-Media Sound Driver Conflict

By risingTide ยท 76 replies
Jan 17, 2008
  1. turbo1

    turbo1 TS Maniac Posts: 353

    just as i thought & that would explain it all.your sound chip not being detected.

    ok,please go to Start > Help & support.under Pick a Task,select keep your computer up-to-date with Windows Update.

    Download all that it tells you to download (updates) & install.

    after installing all the updates,Run the driver CMI8738_WDM_0639XP & dont forget the basic things before you proceed in istalling the driver."8738 in Motherboard".if thats the default then leave things unchanged.
  2. risingTide

    risingTide TS Rookie Topic Starter Posts: 101

    I try to keep my updates current, but I checked for updates and there were three. None of which were high priority. 2 software (Root Certificate and Silverlight) and 1 hardware (VIA Rhine II Fast Ethernet Adapter).

    I tried to reinstall the driver again with the appropriate selections, but it still hangs like before.

    Thanks so much for your help turbo1/kimsland...I really am at a tight spot!

    What next?
  3. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

  4. risingTide

    risingTide TS Rookie Topic Starter Posts: 101

  5. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Well I did get something from this.
    McAfee installed, I wonder if you are able to fully un-install (temporarily of course) this product then try the audio driver install again
    Note: you will require all your registrations - so forth, actually better to have it ready for re-install.

    Also I started searching around for drivers again, but gave up thinking you have a few already ! But I came across a board (I closed the page without copying the link) that stated that he could not install the Soyo CMI8738 fully until he removed all USB devices (he thought it was keyboard - and attached a PS2 keyboard) and successffully installed them.

    The drivers still concern me a little, I think you may want to search for a few others with your Windows version - I usually use driverguide.com that site is very good, but I have never posted a link because free registration is required to download the drivers (using your email address) you may want to check that too, as a first reference to these drivers Soyo Technology Corp Ltd CMI8738/C3DX PCI Audio for your Windows.

    Well there's another 3 ideas !

    I would like you to continue posting here to, ie don't format or not respond, I'd like to know the really simple answer to all this !!
  6. risingTide

    risingTide TS Rookie Topic Starter Posts: 101

    Okay...well I did the online driverscan on DriverGuide.com and it says that I have the latest driver for CMI8783...

    Now I'm on to trying the USB issue...will post back.
  7. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    And McAfee after that !

    I may be away again (I'm in and out a lot, but I like letting people know)

    I'll check replies later - you know the reply that says I solved it :)
  8. risingTide

    risingTide TS Rookie Topic Starter Posts: 101

    I removed all USB devices and tried to reinstall the driver but it just hangs like before.

    And as far as the McAfee goes...I had this problem BEFORE I had it or any other virus software installed. (As a general rule I reinstall all device drivers first before software when I do a fresh install.)

    So, I hate to say it but I'm kind of back to square one. I really don't want re-install XP...
  9. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Uninstall all the sound again in add/remove in device manager (also show hidden devices from view in the device manager toolbar)

    You really should try another sound driver download for your OS (i keep forgetting to look - i think Xp) from driverguide

    Once I had a strange one like this, I installed another sound card, then uninstalled the sound card, then the original sound card worked.
    Something must have reset somewhere

    Hmmm. Maybe more minds may help here.
  10. risingTide

    risingTide TS Rookie Topic Starter Posts: 101


    I started second guessing myself as to whether or not I really had McAfee installed or not when I was trying the sound drivers before. So I bit the bullet and uninstalled it and tried to install the sound drivers then (note that all USB devices were still disconnected). Alas, same thing happened with the hang on install.

    So, I uninstalled all the sound in device manager again (which was only the mciqtz32.dll actually). And then tried three separate C-Media Sound Drivers:

    cmi8738_WDM_0639XP (the one you linked to from downloads.com earlier)

    You can find the latter two here on Soyo's site SY-K7VSoyo Dragon+

    The first one gives me the nice "8738 in motherboard" box to choose from first...and then installs and hangs.

    The second one just gives the

    message and closes. And the third one is similar to the first but just skips straight to the hanging without asking me for the "8738 in motherboard" selection box.

    Whew. Thanks for hanging in there with me!! What's next?
  11. turbo1

    turbo1 TS Maniac Posts: 353

    after reading your unknown devices,it appears that:

    Sound, video and game controllers (19/5/0/0)
    Audio Codecs
    CMI8738/C3DX PCI Audio Device
    C-Media Electronics Inc CMI8738/C3DX PCI Audio Device
    Soyo Technology Corp Ltd CMI8738/C3DX PCI Audio Device

    and after getting through to your boards manual,you have the SPK5 Audio Connector Card & One Flat Cable for Audio Card.

    in C-Media site,none was listed as CMI8738 for mainboards except CMI8738 for PCI sound.

    as im thinking that you need that SPK5 to run the C-Media 6 channel solution.

    lets have kimsland suggestion,un-install the sound driver in Add/Remove or you can run the un-install program that comes with the CMI8738 driver.

    install again the sound driver using your motherboard's CD.
    if nothing happens,use the one you downloaded from C-Media (CMI8738_WDM_639XP) driver.

    but this time when you double click the setup.exe,before you proceed with the installation,tick the radio button that says "8738 in sound card (rear speakers jack individually)".

    this feature is already a functionality of a PCI sound card.

    try it.
  12. risingTide

    risingTide TS Rookie Topic Starter Posts: 101

    Okay, I tried to un-install the sound driver/applications that I have.

    However, when I click on any of the "Uninstall.exe" files for any of the CM8738 drivers nothing happens.

    Also, when I try to uninstall the AudioRack application (either through the Add/Remove Menu or the Program Menu shown here View attachment 28125 ) I receive this screen View attachment 28122 . Now, no matter what I check off (the default is all of them), when I click continue the screen just flashes and the prompt comes back up. It will do it indefinitely until I click on the Cancel button.

    Also, when I choose "Uninstall Device Drivers and Applications" from the Program Menu (see screen shot above) and try to uninstall the driver I receive this View attachment 28123 .

    So it seems like I don't have a driver installed, but I do have AudioRack installed and can't uninstall it. Isn't that a problem?

    Anyway, I continued onward and tried to install the driver from my mobo CD. Everything looks like it installs correctly, it asks for a reboot, but when I reboot nothing has been installed. So then I tried the CMI8738_WDM_639XP driver as suggested, but with the option "8738 in sound card (rear speakers jack individually)" checked instead, but I receive the same result...the hang.

  13. turbo1

    turbo1 TS Maniac Posts: 353

    you cant have a fresh install of the driver unless you solved the un-installation problem.

    this maybe the conflict now,your sound chip not being detected.that's why it hangs.it cant find anything.

    find something that will un-install the driver,use a third party utility software that can be downloaded free.
  14. risingTide

    risingTide TS Rookie Topic Starter Posts: 101

    With turbo1's help I've managed to completely uninstall AudioRack with Revo Uninstaller and then ran CCleaner afterwards to make sure that everything is really gone. I've also tried a few more versions of the CMedia driver but none complete installation...I mostly receive the ""Our audio chip provides mult-speaker surround..." error listed multiple times below.

    I also tried another install of AudioRack (thanks for the file turbo1), but alas, I simply receive this error on install View attachment 28172 .

    Still stumped.
  15. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    New sound card sounds good !
    Also may help (as stated above)
  16. turbo1

    turbo1 TS Maniac Posts: 353

    with all the solution hunting that you've tried,still,your sound chip dont respond to all the drivers known for CMI8738 model.

    if it doesn't switch back on,then i guess your sound chip just served its purpose.

    kimsland's solution would be it,time for a new add-on sound card now.and I want to say well done for getting this far. :)
  17. risingTide

    risingTide TS Rookie Topic Starter Posts: 101


    Thanks so much for the help. I'm going to try to borrow a sound card from a friend and see if it works. I'll post back to keep the thread updated for other folks. 2 questions until then though:

    1) When I use my friend's PCI sound card should I disable my onboard one in the BIOS first? I would think yes, but since kimsland said something about it making the onboard one mysteriously work I just wanted to make sure I shouldn't leave it on.

    2) Here's another BSOD View attachment Mini012508-01.dmp ...is it related?

  18. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Yes disable in bios - I'm hoping that the Windows software (registry/system files) may change something. The hardware device, can be disabled during this. And then re-enabled later on - after removing the PCI sound card.
    Firstly just make sure you get sound, from the next card.

    BugCheck 1000000A, {d0f605e8, 2, 0, 804dc25d}
    Probably caused by : srv.sysSrv.sys
    is the network server device driver that controls network connections to a machine
    May have just been a one off glitch, but I would suggest checking for updates on your network driver too.

    The hardware on the machine is falling apart ! lol
  19. risingTide

    risingTide TS Rookie Topic Starter Posts: 101


    After a brief hiatus I am back...with an unexpected development (at least in my opinion).

    First of all, as far as #2 goes above...I have the latest updates so hopefully it was just a fluke (although I have had quite a few BSODs of various sorts as mentioned earlier).

    Okay, so I turned off the onboard sound in my BIOS and I borrowed a PCI sound card from my friend (Creative SB Live! Player 1024 Sound Card). I installed it and fired up XP and received the usual Found New Hardware balloon at the bottom right. So it pops up a few more balloons there and then I get a prompt asking me to insert my XP CD. I do that and I get another prompt about "do you really want to install these SoundBlaster drivers even though they are unsigned" to which I clicked Continue. A few seconds later I receive this error View attachment 28317 . So I click Finish (my only option) and then immediately receive another prompt about installing something else for the SB card (I think drivers but I can't remember the exact wording). Anyway, it was the usual prompt about "choosing from a specific location, or just searching" so I just did the search (since I don't actually have the drivers nor does my friend) and it searched the XP CD for awhile and eventually seemed to find it and did the folder copy icon bit like it was installing them. However, in the middle of that I received an error that it couldn't find some file called "gamenum" and I was asked to insert my XP2 upgrade CD to search for it on there. Well, I do actually have an XP2 upgrade CD ($4 from microsoft) and I inserted that CD, but apparently that file wasn't on there because it couldn't find it so I had to just click cancel for that file. It continued copying for a little bit and then ended.

    So I basically received an error on the install of the Multimedia Audio Controller and then another during the drivers right?

    My device manager currently looks like this View attachment 28318 and before trying another else I figured I would post to get some advice on the next step. Honestly, I was expecting this card to work just fine, thus proving I had a bad onboard audio chip. However, that first error seems to indicate something else may be awry than a bad chip, right?

    I was thinking that I should try to make this PCI card work in other ways first before coming to that conclusion, is that correct? Any help on that would be very much
    appreciated (as usual)!

    I really want to get to the bottom of this...
  20. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Please look at all the info numbers and part numbers on your new sound card, and go to google and add the word driver to a search.
    It may be that the drivers you have are not for your Windows version.

    Sorry very brief I must rush off.
    Also I was wondering if you should open a new thread under audio forum. You may get better advice.

    This one is a week old now.
  21. turbo1

    turbo1 TS Maniac Posts: 353

    you are trying to install a driver that does not contain a Microsoft digital signature.perhaps its for win 98 or 2000.

    & for the model creative SB live! series (except 24-bit/external),creative Labs dont support the driver anymore,it's service has ended up.

    unless you can find & try a OEM driver for EMU 10k1 (sound chip) 16-bit signal processor for winXP version.but no guarantee it will work.
  22. risingTide

    risingTide TS Rookie Topic Starter Posts: 101

    Well, when I start to install that driver everything looks real good until I get an error that says "The file 'gameenum.sys' on Windows XP Professional Service Pack 2 CD is needed. Type the path where the file is located and then click OK.' Here's the screenshot View attachment 28343 . I've tried searching from both my Original XP CD and my XP SP2 upgrade CD but that file isn't on either one. So I have to just click Cancel. It continues the installation for about 2 seconds and finishes, but nothing changes.

    Where can I obtain that file?
  23. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Yes I have that file in C:\WINDOWS\ServicePackFiles\i386 it's a microsoft file.

    I will edit this, when I work out where it comes from (SP2 disc?; sound driver?)

    Hmm DirectX 9.0C is looking good http://www.microsoft.com/downloads/...11-62fe-4f61-aba1-914185249413&DisplayLang=en

    Edit: (Home page drivers)

    These drivers from here: http://www.soyo.com/content/Downloads/155/&c=35&p=21&l=English


    C-Media v6.30(old drivers).

    Audio Rack

  24. risingTide

    risingTide TS Rookie Topic Starter Posts: 101

    I've tried those drivers numerous times and always get the errors that have been posted previously. I actually started with those drivers in the beginning (I usually go straight to the company's site if I can).

    Guess I'm a little confused...why is the newest Directx looking good?

    Thank you to both of you again as you help.
  25. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Because it's a Microsoft file.

    It's either in DirectX or SP2 or in the full version of the Xp CD
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...