1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Cannot Acquire Network Address

By drworm73 ยท 29 replies
Aug 23, 2008
  1. Thanks to many of you I was able to get my PC build past a huge hurdle, but now I am stymied again. I built a PC from scratch and now have XP media edition installed. I installed the drivers that came with my Motherboard (Gigabyte), including the ethernet driver. Now I want to go online finish getting set up, but I cannot get online.

    I have a motorrola cable modem that is directly connected to the PC. The Connection recognizes the modem, but constantly says "AcquirinIg Network Address". I called Comcast, and they were not able to help me. I was told to call Microsoft, but that will cost me a bundle.

    Someone outthere has to have the answer.
  2. drworm73

    drworm73 TS Rookie Topic Starter Posts: 22

    SO I have done some work over the weekend and I have come to realize that my PC for some reason will not automatically acquire an IP address. When I do ipconfig I get a bunch of nothing. The first and last listings show nothing and the two middle ones show "". How do I find the tcp/ip settings so I can manually input them. Also, I am setting this up for my father at my house...if I put in the tcp/ip numbers here, will it be able to connect at his house?
  3. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    from a command prompt ipconfig /all will display the configuration.

    In a wired lan, the parms are in the NIC settings.

    However, I first suggest you use the Network Wizard and choose the first choice
    "connects directly to the internet"

    This will enable the DHCP so that the NIC will acquire the settings from the Modem.
  4. drworm73

    drworm73 TS Rookie Topic Starter Posts: 22

    Tried that...no change.

    Here is what I get when I type ipconfig /all:

    Host name: tony
    Primary Suffix:
    Node Type: Broadcast
    IP Routing Enabled: No
    WINS Proxy Enabled: No

    Ethernet Adapter Local Area Connection

    Connection Specific DNS Suffix:
    Description: Realtek RTL8168C (P)/18111C(P) PCI-E Gigabit Ethernet NIC
    Physical Address: 00-1F-D0-5A-D5-D6
    DHCP Enabled: Yes
    Auto Configuration Enabled: Yes
    IP Address:
    Subnet Mask:
    Default Gateway:
    DHCP Server:
  5. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    hum; that's proof that you're not getting the config from the modem.

    What firewall are you using? The default windows FW will allow port 67 (dhcp) for sure.

    Baring that, you have a bad NIC or a bad modem. Find a friend with a laptop and
    wire the laptop to your modem. If that works, it's got to be your nic or it's driver.

    by the way; post some specs on your system using Edit Profile and include the
    make/model of the modem and the nic or usb device being used.
  6. drworm73

    drworm73 TS Rookie Topic Starter Posts: 22

    NIC? What is the NIC?

    I know that the modem is fine as my son's PC is wired in to the router (when I don't have the modem directly conected to the new PC), and it works fine.
  7. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    NIC: Network Interface Card. That is what the ethernet cable is connected to inside the computer.

    Have you updated the NIC Driver? you should.
  8. drworm73

    drworm73 TS Rookie Topic Starter Posts: 22

    Well the NIC is built in to the MoBo. I Downloaded the most recent ethernet driver from Gigabite, but no go. However if that is the problem at least it gives me someone to call. Calling micorsoft will cost me $80.
  9. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    AH! I've seen that chip flood the router/modem and induce failures.

    try setting the link speed to 10mb half-duplex, which will not induce the data overrun condition.
  10. drworm73

    drworm73 TS Rookie Topic Starter Posts: 22

    okay, is that done in windows in the connection properties window? I am not at home at the moment so I cannot try it, but I will this evening.
  11. drworm73

    drworm73 TS Rookie Topic Starter Posts: 22

    Well I tried that, and it did not work. I changed it to 10 mib half-duplex, and restarted the PC...nothing. I did ipconfig and got the same results as before. Can't I just get the tcp/ip settings and put them in manually? Also...will have have a different result if I take this to my dad's house and try it on his connection? After all that is where it will live.
  12. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    leave the 10mb half duplex setting.

    the other TCP settings will vary depending upon the ISP and if you have a router.
    netmask is always, but the gateway IP and DNS settings are from the ISP.
    Worst case issue is a modem w/o a router and the ISP gives you a public IP address.

    This is why we highly recommend using DHCP to get this all consistent and correct instead of trying manual settings.
  13. drworm73

    drworm73 TS Rookie Topic Starter Posts: 22

    Well the problem is that my ISP says it is software problem and I should call microsoft, but that does not seem to be the case (and it would cost me $). I suppose I could call Cisco, who makes the router, but the problem with that is that I am building this for my father and he does not have a router. Actually I am pretty sure he has DSL where as I have cable.

    I think I will lug the thing over to his place tomorrow morning and see if I have any better luck through his modem and connection.
  14. plaitne

    plaitne TS Rookie

    sr but post above makes me smile :)

    hi there , ist my first post in forums :)
    as y understand conection is established but no ip aquired.Y had same problems with network aquiring - solution is as folows : go to start klick run and put this line in
    netsh int ip reset e.txt and hit enter. U should se a quick flash of cmd window. Then have a look for ur local area connection icon in ur taskbar on the right , right klick that icon and klick status. In the window ull see go to support and u should see ur Adress type , ip address , subnet mask , default gateway , if they all got numbers on the right it meens u got net connection , if not - restart ur pc.
    and sory for my writing ym not english :)
  15. drworm73

    drworm73 TS Rookie Topic Starter Posts: 22

    Don't worry about the english, makes sense to me. I'll give it a shot when I get home.
  16. drworm73

    drworm73 TS Rookie Topic Starter Posts: 22

    no luck so far...the cmd (dos) screen said:

    Initialization function failed initHelperDLL IPMOTR.DLL failed to start with error 10107
  17. plaitne

    plaitne TS Rookie

    at least now we know whats causing it :)
    try this link (hehehe To be able to post links or images your post count must be 5 or greater. You currently have 1 posts.
    Please remove links from your message, then you will be able to submit your post.)
    Mkay ....

    In the later versions of windows, TCP/IP is considered a core component and cannot be uninstalled. Several things can corrupt the TCP/IP stack. This recipe explains how to reset the stack.
    Many programs like to adjust and change the TCP/IP stack. In older versions of windows the stack could be corrected by uninstalling and reinstalling. However, since the stack is now a core component, uninstalling is no longer possible. Thank goodness, however, that it can be easily reset.

    1. Left click the Start button
    2. Select run
    3. In the open box type: netsh int ip reset c:\resetlog.txt

    c:\resetlog.txt will show what changes existed. You can change this to whatever path you wish.

    This command rewrites the TCP/IP registry keys. Essentially, this causes the same result as the removal and the reinstallation of the protocol.
  18. Worthy

    Worthy TS Rookie Posts: 18

    hmm i think this is getting too complicated.
    1) are other computers recieving the connection by DHCP (automatic IP)?
    if so, then that computer will also be on DHCP (so set it to automatic in properties>TCP/ip settings)
    if not, then get details from the other computers about the default gateway, dns server, subnet mask

    ill explain in detail if i made that sound too simple :D
  19. drworm73

    drworm73 TS Rookie Topic Starter Posts: 22

    all other computers run fine through this connection when using automatic detection, but this new one does not.
  20. drworm73

    drworm73 TS Rookie Topic Starter Posts: 22

    I get the same error
  21. Worthy

    Worthy TS Rookie Posts: 18

    so under "status" when you enable the connection, what does it say? if it says disconnected then its a cable/adapter problem, if it says aquiring for ages then its a ip issue.
  22. drworm73

    drworm73 TS Rookie Topic Starter Posts: 22

    It's the latter, but the bizare thing is that every other PC on the network works just fine. The new one is the one that is fracked up. Will it make a difference if I try in on another interrnet connection?
  23. plaitne

    plaitne TS Rookie

    y dont get it :)
    Gimme your ISP name , is it phone line or cable ?
    Right ur soons pc concets to router - modem - ISP. So in this case u gotto connect to router which must be configured to alow you to aces internet . So follow istructions how to configure it aswell. Then its the way YOU connect to router - wireles or cable ?
    The command lines y gave u previously couldnt fale in settings like these your pc - (router)- modem - isp.(sometimes routers solve all problems with ip aquaering them selves)
    So the way y understand it you'r not wireing things up correctly.
    Lets make sure that modem is fine with ur pc by instaling it there . If it does work fine the only thing that is left is to configure router to alou you to acess internet .And that may involve mapping ur pc to connect frough modem , but as y sayd router is in between so u need to check settings.
  24. drworm73

    drworm73 TS Rookie Topic Starter Posts: 22

    Well I fixed the problem...sort of. Tore the whole beast down, put it all back together re-installed everything and it all worked just fine. I have no idea what caused it this past week, but I am off to deliver the computer in a few hours.

    Thanks for all the help
  25. plaitne

    plaitne TS Rookie

    :) well done :D
    Probably ur registry keys were corupted in some way .
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...