1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Canon MP730 - error: wrong cartridge

By Lokalaskurar ยท 10 replies
May 5, 2011
Post New Reply
  1. Righty then, methinks I gots here an olde Canon MP730 (know). It's about 8 years old, and I'm tasked with getting it back up and running. It worked perfectly fine right until yesterday - when all of a sudden, a wild Error appeared.

    First things first; I do not have to actually fix it. If some component is permanently broken, fine!, as long as I know why it's broken, and which component, I'm satisfied.

    1. I can (and do) access 'Print' and I print a document, just like any printer.
    Document is being sent to s-pool.
    2. Says on computer that 'There has been an error!'
    3. [Looks over at printer] eq. to POST code has appeared:


    I always have a load of different cartridges laying around. So I swap them all for the recommended genuine OEM Canon cartridges, just like new.


    I'm puzzled. So what should/can I do?

    I am very interested in hearing some TechSpot-members' thoughts.

    Also, I'm translating the error message, there is a chance that those who coded the printer in my language did so very badly (not uncommon...) - e.g. there is a possibility that the error message is actually supposed to be "Wrong Cassette."

    My goal:
    Preferably, get the printer back up and running.
    Secondarily, if unfixable, sit back and enjoy the error-reading on TechSpot :) .

    The printer has never been cleaned :D - so maybe I have to change the ink depository if there is one/some. (pardon for poor translation from my native tounge :p ).
  2. Lokalaskurar

    Lokalaskurar TS Enthusiast Topic Starter Posts: 544

    80 views and no suggestions. Keep 'em coming.
  3. Lokalaskurar

    Lokalaskurar TS Enthusiast Topic Starter Posts: 544

    Ok, so I've reset (something) after I've changed the ink cartridges. Now it will print, but only the CMY, not CMYK that is.

    What will I have to do in order to get the black ink cartridge working?

    Don't be shy when it comes to mentioning service commands, I know my specific printer's "Service Mode"-code.

    Edit 2:
    The printer can copy just like in the old days, but it still cannot print in black.
  4. kristain

    kristain TS Rookie Posts: 47

    The following may work: remove all the ink supplies. Remove the printhead and soak it for about 5 minutes in 0.5" of very hot water. Gently blot the printhead on a soft damp paper towel to remove the excess water, then replace in the printer and then reinstall the ink supplies.
  5. Lokalaskurar

    Lokalaskurar TS Enthusiast Topic Starter Posts: 544

    Great, I also thought of this actually. I'm trying it now.

    And if it breaks, don't worry, I've had a good time with it (like 8 years)!

    Haha! The water turned pitch-black! :haha: , like HTML #22222!

    Hm... it actually turned more like #330033 when poured out. Now, I can tell that the printer head really needed a bath just from looking at the resulting water-colour.

    Let's dry it and snap it into the printer, then.


    Ok, let's reset the Ink Count... Menu-3-Copy-'Pound sign'

    Shucks... still no results... a well, can't blame a man for trying! :)

    Any other suggestions?
  6. r3dark

    r3dark TS Rookie Posts: 45

    check to see if the metal contacts that make contact with the print cartridge are clean if not i recommend using some rubbing achohal and a cotton swab to try to clean the contacts.
  7. Lokalaskurar

    Lokalaskurar TS Enthusiast Topic Starter Posts: 544

    Checked them all right, perfectly clean, not even a fatty fingerprint. I even kept the contacts (the entire circuit board) out of the water previously.
  8. gartht

    gartht TS Rookie

    Associated help

    Wondering if you ever got this resolved - I have a similar problem and looking for advice/expertise ...

    Printing went horrible (some perfect, some blank lines, some overwritten lines, etc.) - looks like verical problem, although far left and right tended to print well. Tried alignments, cleaning, nozzle check, etc. - no fix. Removed print head to clean for first time (~730 printed pages have been through this thing) - lots of gummed up ink removed - very carefully. Put cartridge back in and now I have "Wrong cartridge" coming up. Have tried recleaning print head and electrical contacts multiple time and had no luck.

    Any and all ideas welcome. And if I must buy a new print head and sourcing ideas would also be appreciated (I'm in Canada).
  9. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    Your reference to wrong cassette makes me think that there might be a problem with the paper feed perhaps? Or maybe the PC thinks the paper is in a different place to where it actually is - or even the wrong sort of paper?
  10. gartht

    gartht TS Rookie

    It definitely refers to the print head / tanks - with print head removed it says "No cartridge" ...
  11. Lokalaskurar

    Lokalaskurar TS Enthusiast Topic Starter Posts: 544

    Yeah, in my case I actually had to replace the 'cartridge head' (or whatever it's called in English). The cassette which holds the ink cartridges anyway.

    But in your case, I think you've had a whole lot of luck which I didn't.

    The million dollar question: have you reset your printer ink count? Some printers need that.

    I know that the MP730 model need to be reset all the time every time something happens. Even if I even forgot to close the 'cassette' latch, it needed a full reset.

    I know that my particular printer's code to access the service setting was Menu-3-Copy-'Pound sign'. Whether there is a 'Canadian edition' or not (probably because of the built-in modem) -- I am not familiar with. But if there is, the code for accessing the service settings is probably not the same as mine.

    So my idea: (if you have a MP730...) reset the ink count. It can be done from the service settings, and there are some very good explanations online on how to do so. First: you'll need your code for accessing the service settings. Start from there.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...