Canon Powershot A75 driver troubles

By AJtheIrishLass
Nov 1, 2007
  1. I had been using my Windows XP SP2 computer with this camera without any problems with a USB connection. About three months ago, the computer stopped recognizing the camera, so I updated the driver. It worked for awhile, then stopped again. I've tried uninstalling and re-installing the driver to no avail. It doesn't matter if I use the installer with the driver or if I use the camera & scanner wizard on XP. I still get a message saying that the camera was not found.
    Issues I've ruled out:
    Outdated driver-I used the most current one for XP on Canon's website
    Bad USB port-I've tried plugging the cord in to all three
    Bad cord-I've switched out the cable
    Suggestions are appreciated :)
  2. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    If you have connected to the USB ports on the back of the PC and still get the problem you could try disconnecting the internal connection for the USB front panel -these have been known to fail. Do other USB devices on your PC work OK?
    As a last check to confirm it is the PC, connect the camera to another PC and be sure that it is visible as an external device.
    If this is so, it is most probable that you have a software related problem.
    Boot into safe mode (F8 on startup) and open the control panel -> system > device manager and then go to the USB devices at the bottom of the list. Remove the lot and reboot.
    Windows will reinstall them and hopefully clear the error. If not the next best option is a reinstall of windows itself.
  3. AJtheIrishLass

    AJtheIrishLass TS Rookie Topic Starter Posts: 27

    Yeah, that's the really weird part. It's just this one device. :(
    I'll try these other two as well. Thanks!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...