Cant Boot XP prgiso.dll error

By surfersaiyan ยท 7 replies
Jul 3, 2008
  1. hi guys. OK, so i made my first post feeling triumphant the other day since i pulled my system back from the brink of despair when i had xmnt2002 and autochk errors. you can see in my other post how i repaired that!

    but now, i think i might have done something worse! when i boot XP i get my [modified] splash screen, and XP appears to be booting normally. but when the splash disappears, as though going to the login page, i get a message for a split second before the computer restarts and then just goes into a never-ending cycle of starting and re-starting.

    the message is something like
    error: c0000135 (unable to locate component)
    This application has failed to start because prgiso.dll [something]
    [something] the application may fix this problem

    so, time to fess up what i did.
    i was using paragon partition manage 9 (portable) to redistribute the free space on my hard drive after getting rid of a couple of unused partitions. it said that all the changes had been made and that i needed to restart. no worries, but thats when i got this error on reboot. (i thought i was being prudent and made a paragon rescue cd but little bloody good that turned out to be!)

    WHAT NOW?? i am using BT2 to get online and actually used it (and qtparted) to fix my last problem. i can use BT2 to see all my windows files so its all still there, it just seems theres something wrong with the boot sequence.

    any suggestions appreciated!

    surfersaiyan xx
  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    This is a common error when using Paragon. You will find plenty of help at the Paragon site, or when I get a minuit, I will post a long list of what to do.
  3. surfersaiyan

    surfersaiyan TS Enthusiast Topic Starter Posts: 100

    I'd really appreciate the advice when you get a minute, since i was hard pressed to find anything on the paragon site.. maybe to stressed to absorb anything!! thanx in advance!
  4. surfersaiyan

    surfersaiyan TS Enthusiast Topic Starter Posts: 100

    hi everyone, i'm still having problems with this, or in other words, i havent sorted it out yet!

    i've been onto the paragon forums and one of the senior guys on there reckons maybe "the system partition has lost its drive letter."

    anyone got any ideas and how i might fix this? (any chance raybay could get back to me on this would be awesome!)

    i can access all my windows files and partitions by using a Live BackTrack2 or Ubuntu CD and using QTParted or GParted to make any changes to the partitions. would this help?

    (dramatic effect!)


  5. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Go to Start -> Settings -> Control Panel -> Administrative Services -> Computer Management -> Disk Management.

    There you will see all the recognized drives and the DLA or Driver Letter Assigned to each... You can use this link to change any drive letter, EXCEPT the boot drive, and is a fairly easy fix once you become accustomed to strolling around in Disk Management... It works well, and is a respectable fix, or even just a check or affirmation of what you have there.

    Any drive that has been formatted, EXCEPT C:\, can be changed to any other drive letter from D to Y, provided those drive letters have not been assigned. You can move them all around, but you must retain the integrity of the boot drive.

    Good luck.
  6. surfersaiyan

    surfersaiyan TS Enthusiast Topic Starter Posts: 100

    OH MY GOD I FIXED IT!! and it was so simple in the end.

    firstly i must say a big thank you to RayBay for his kind advice and for sticking with me. however, since i was actually unable to get anywhere near anything in my windows, the old "Start -> Settings -> Control Panel ->" fix wouldnt work.

    ok, so to the fix.

    i make another paragon recovery disc, the one with Boot Corrector on it. i did the mbr and some other stuff, checked the drive letter but that all seemed fine. still no boot, same error.


    i installed Paragon Partition Manager 9 on my mates computer, so i could make the recovery disc and Boot Corrector. when that didnt work i had a crazy idea.. "i wonder if his install has the dodgy *.dll i'm missing?"

    i did a search and found it almost straight away. so i copied it onto a usb-drive and then used ubuntu to copy it across into my windows\system32 folder.


    where there was previously an error message PPM9 seemed spark into life and began finishing what it was doing previously (re-distributing the free space on the hard drive) and then straight into windows YAY!!

    but what was most surprising for me was that i thought i would never get away with it, as i thought that using ubuntu, especially from a live cd, i was not able to write to the NTFS partition (copy the file across).

    but i simply copied the offending *.dll from another computer and pasted it into mine. problem solved. much learned. less hair. more wrinkles.

    I hope that by solving this problem by myself I have not only learned something but also been able to pass on what worked for me and what didnt work.


    its been a long hard couple of days with the missus bangin on that she couldnt use the computer that i'd stuffed up

    i'll be a bit more careful in the future and wont go mucking about with partitions willy-nilly!!
  7. CCT

    CCT TS Evangelist Posts: 2,653   +6

    As a bit of info that prgiso.dll isn't a Windows feature it is part of the Paragon software. For Vista they say to copy it (and another) dll from the System32 folder to (one of) the Paragon folders before using Paragon. It seems some XP installs also need this to happen.
  8. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Thanks. That information is good to know.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...