1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Can't connect to internet, new XP install

By macx · 7 replies
Jan 21, 2009
  1. Had such a problem with the previous XP sp2 / latest Firefox install on my desktop that the recommended fix was so far beyond my comprehension (an IT engineer I am definitely not, and the recommended fix was just so much Greek to me) that I just backed up everything and reformatted the C drive.
    Have done that several times in the past with no problems.

    Reinstalled Windows, everything seems to be going fine, but it won't connect to the internet. I've checked and it's set to auto detect. Right now I've got the same cable plugged into my laptop and it's working fine.

    Tried to activate Windows and it couldn't connect, also a couple other installs tried to connect without success. Unplugged / replugged several times, every time I plug the same cable into the laptop it works fine.

    Tried clicking IE and it couldn't find the internet either.

    Have not had this problem before on a couple similar reformats.
    The connection was working fine on the desktop before the XP reinstall.

    What am I missing?

  2. k.jacko

    k.jacko TS Rookie Posts: 483

    you made sure all device drivers are installed? ie. network adaptor?
    Right click My Computer > Management > Device Manager > Network Adaptors
    check to see you don't have a yellow hazard sign next to your adaptor name.
    if so, that's your problem.
    If its ok, are you connected to a router? or just straight to a modem?
    When you plug the cable in, your system tray should show the network icon looking for an IP address, does it do that?

    Try this lot out and let us know how you get on.....
    ...good luck :)
  3. macx

    macx TS Evangelist Topic Starter Posts: 720

    Yes, I managed to get into Device Mgr and my 1394 Network Adapter does not have any yellow ? by it. I tried updating the driver (from the Windows disc - is that right?) and it said there were no better drivers available than were already in there.

    At present I'm hooked straight to a modem - same modem and cable I've got the laptop hooked to that I'm using to reply to this.

    Now I don't see anythng in the system tray.

    I got into "Repair Connection" and it said it couldn't because it wasn't
    querying TCP/IP for settings. I checked and TCP/IP is enabled.

    Apparently I next need to know just what isn't querying TCP/IP for settings,
    and how to make it do the querying.

    So far all I've got for Firewall is the Windows firewall, so there shouldn't be anything in a Firewall blocking it.

    As usual, I'm again at a loss with this Windows.

    Thanks for any further help or ideas.

    EDIT: Got into ipconfig, did the loop thing, all came back apparently OK.

    Then got into STATUS of the 1394 connection and it doesn't show any info for anything - probly bcuz "it" (whatever that is) isn't querying TCP/IP info from the server (?)

    Hope that helps, I've not got much more than a general idea of all of that. Certainly not enuf to proceed with anythng.
  4. k.jacko

    k.jacko TS Rookie Posts: 483

    No mate, your 1394 is your firewire adaptor
    You should at least one other network adaptor, otherwise you have more serious issues.

    Cat5e cable i presume?

    You don't see the "2 little blue monitors overlapping each other" icon?
    Check your 'Network Connections' you should have a 'Local Area Connection' icon, double-click it, get the properties on the TCP/IP settings and make sure its all set to DHCP (dynamically assigned). Also check the box that says "show icon in notification area when connected" then click OK and lose down the properties page

    It won't do anything if you're trying this on your 1394 (firewire) adaptor

    The above may fix this issue

    No, there shouldn't but you could disable it temporarily whilst we fix this connection issue.

    Report back with your findings soldier! :D

    edit: i take it you have XP 'WITH' SP2 installed at least?
    what motherboard make/model do you have?
  5. macx

    macx TS Evangelist Topic Starter Posts: 720

    Yes, cat5 cable. Yes, XP2 sp2 installed. I'm in "Network Connections" - there in bold it says
    "LAN or High-Speed Internet" and it shows the double blue monitor icon
    and it's labeled "1394 Connection Connected 1394 Net Adapter"
    I do not have a "Local Area Connection" icon. in Network Connections.

    Don't know if it applies, but in the 1394 Connection Status / General,
    it shows Connected at 400.0 Mbps but nothing sent or rec'd. (which I
    can see if it indeed is the Firewire)

    I did get it to show in the notification area, but again it's the 1394 Connection.

    The little indicator lights are on where I plug the cable into the mboard on back and
    they go off when I unplug the cable.

    It's an ASUS P4C800E Deluxe board if that helps, and I've tried the ASUS setup CD
    looking for drivers etc with nothing happening.
    And I did try it with the Firewall turned off, no different.

    Just a side note - I was in Leicester (spelling?) quite a number of years
    ago, and hope to revisit that along with the rest of the Isles someday
    within a few years after I retire. Am working with a gentlemen from
    I believe the western part of the Isles, forget exactly where. Small world!

    ok, got into TCP/IP Properties, it is set up to obtain an IP addr automatically,
    then in Advanced TCP/IP Settings, it is DHCP Enabled - don't know if this matters,
    but under that there are no Gateways listed in that box. In General, it also has
    "Obtain DNS served address automatically" checked.

    In "1394 Net Adapter Properties, it calls it a Net Adapter, says it's working properly, and it's "using this device"

    In Connection Properties is says "Connect using: 1394 Net Adapter". Also on there,
    the TCP/IP is checked, Client for MS Networks is checked, File and Printer Sharing
    was checked, I unchecked it, no help.

    My, Windows is well named, I feel like I've been thru 1,000 of them, and probly couldn't find more than a dozen of them if I tried. Confusing to say the least, esp when I don't understand half of what they say to start with.
  6. k.jacko

    k.jacko TS Rookie Posts: 483

    Leicesters sucks, lol!
    Nottingham rulz m'kay?

    all the stuff youv'e would be correct, BUT, since you are NOT running the internet through your firewire adaptor (1394) it won't make a jot of difference.

    You say that your RJ-45 (network) port shows lights, (green and orange?) when the cable is plugged in, and they go out when the cable is taken out? That shows activity and that the card is alive at least.
    BUT, if you cannot find it in your device manager, you really do have issues. You should have at least 2 network adaptors in your device manager. 1394 and the one we're trying to find/configure.
    According to Asus' website its an Intel onboard network card.
    Hmm.... ok the best thing i can suggest, is to insert the mobo driver cd.
    Look for network drivers and install them. It's either lost them somehow or you never actually installed them once you'd reformatted. Some mobos/driver disks auto install, some you have to manually install each device driver. Probably the latter in this case.
    So, do that and see what happens.
  7. macx

    macx TS Evangelist Topic Starter Posts: 720

    Yessir, that does make sense.
    And I do remember seeing that it's an Intel network card.

    But - aHA! - both lites are orange on the card plug in - I guess that's a clue.

    Had that disc in before, opened up the Drivers section, here's the options
    Intel Chipset Inf Update Program
    Intel Application Accelerator Driver
    Promise FastTrack 378 Driver ( never did install that one when I built the machine)
    SoundMAX Audio Driver & Application
    USB 2.0 Driver (I do have some yellow ? by one of the USB listings in Dev Mgr)
    and Intel PRO/1000 LAN Driver (bet that's the one, hey?)

    Will give that mess a spin and see - I didn't have any luck trying to select and install
    them before, probly just not finding the right command.

    Well, well, turns out I just wasn't waiting long enuf after I selected the LAN
    drivers for the next window to pop up - I'll go thru the "install software"
    and "install Base driver" and see - what's "Install SNMP"?


    I'm connected on the desktop - at long last!

    That was it the whole time - I had to install the software and the driver(s)
    off the ASUS disk. Just wasn't giving it enuf time for the next window to
    open before, thought I wasn't doing something right and it wasn't responding.

    Well, thank you SO very much - an educational experience, to be sure,
    you helped me explore many murky corners of this Windows I'd been
    in at some point previously but n ever could have found without help, and
    surely learned some things in the process. Now if I can just REMEMBER

    You'd probly be surprised, but i actually spec'd out and built this desktop
    myself about 3 years ago - when my old used PC wouldn't render home]video
    without dropping too many frames. That's when I found Techspot and my
    PC and Windows education really began. Did a bunch of research, found
    out what was desirable nd what wasn't, found the individual components in
    various places - actually quite a bit of it on eBay - and away I went!

    The thing is, I just don't work with it enuf in that depth often enuf to remember
    everything I learn at any given time.

    Anyway, thank you so very much!!

    Now to reload everything else I had harvested out of the C drive before I

    Cheers! (My friend Rupert uses the term "mate" frequently, too ;-))
  8. k.jacko

    k.jacko TS Rookie Posts: 483

    Thats the one buster! :)

    Patience is a virtue..........is it not?

    Glad you got it sorted macx, its an education for us all on here.
    We live, we learn, we pass it on.
    Rinse and repeat!

Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...