Can't ping router/gateway

By Loaner ยท 8 replies
Jul 12, 2008
  1. I am trying to fix an XP computer that has a very strange problem. It can release and renew its tcp/ip address so it is obviously talking to my router (wired connection). It can ping itself but it cannot ping the router that it got its address from. Self address in this case is, router/gateway is The exact same problem happens at another location where it gets its address from a cable modem.

    I have shut off the Windows Firewall, uninstalled all antivirus/internet security suites, etc. I have deleted and replaced the winsock and winsock2 registry keys with known good copies. I have attempted to reinstall the tcp/ip stack from the inf folder. I have done a repair reinstall of XP (which is always a pain in the behind because you have to reactivated by phone). Nothing is working.


  2. ITGuy702

    ITGuy702 TS Member Posts: 70


    Do you have other computers connected to the router that can ping it? Also, have you tried power cycling (unplug the power...wait a few seconds...plug it back in) the router?
  3. kimsland

    kimsland Ex-TechSpotter Posts: 14,523


    ipconfig /release <enter>
    ipconfig /renew <enter>

    Note: the gateway is usually the routers IP

    You can also reset the router (that is full reset of all internal settings)
    By downloading the manual from the manufactures support site.
    Usually it's a matter of holding in the tiny button (using a pen tip, or pin) whilst the router is on (sometimes for 20 secs, but refer to your manual on this)
  4. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    Brand name and model of the router?
    Some have config settings to disable ping reply. Usually this is applied to the WAN side,
    but some apply to LAN or both Wan and Lan -- check it out.

    Can you ping
  5. Loaner

    Loaner TS Rookie Topic Starter

    Yes, I have 3 other computers wired to this router and one wireless that are not having this problem. Remember I said that it does get its DHCP address from the router and has the same problem at a different location where it gets its address through a cable modem. The problem is not the router, it is the OS.


  6. Loaner

    Loaner TS Rookie Topic Starter

    I really do appreciate the responses that have been posted here but I want to repeat some key items that make this a non-trivial problem:

    1) the computer in question has the same problem at two separate locations. Its home location is served by a cable modem and gets its address successfully from the cable supplier's DHCP server. /Release and /Renew works successfully. It cannot ping that DHCP server or anything at all actually past its own address. The same symptoms are happening here back at my shop with my router.

    2) Its home location is on Shaw cable, my shop is on Telus ADSL.

    3) All other computers on my router are working fine. It is not the router(s).

    Thanks everyone, I hope we can figure this out. I have been in the computer business for 27 years now so please understand that I do know how to do the basic problem solving processes. That I why I brought this computer from its home to my shop so that I could eliminate the ISP influence.

  7. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Onboard NIC ?

    Can you install a PCI NIC card and try that?
  8. Loaner

    Loaner TS Rookie Topic Starter

    Fresh thinking!

    Yes! It has an onboard NIC. Just as you suggested, I installed a PCI NIC and it works! Thank you, thank you, thank you!

    Still, the problem is a little weird. After all, it could still connect to the router by DHCP to get an address.... To confirm, after I installed the PCI NIC and it worked, I plugged the wire back into the onboard NIC and it still failed. That means the problem could be hardware related (not likely since it can get an address) or TCP/IP stack related (specific to the onboard NIC).

    But who cares? The problem has been solved by a workaround. Once again I thank you and all who responded to my problem. I would like to be more involved in this community and intend to do so, just because I have 27 years of experience to offer.

  9. CCT

    CCT TS Evangelist Posts: 2,653   +6

    I got hit by an onboard NIC failure coincident with my router failing. Could ping the router but not get through.

    Had to change both.

    The only clue I might have had was my mobo running hot for 2 days and I couldn't figure out why.

    Now I know.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...