CD/DVD-RW Drive not detected

By LSE ยท 7 replies
Mar 17, 2008
  1. I upgraded my optical drive a while back with a Sony NEC Optiarc CD/DVD-RW. It worked fine, and recently I put in a secondary hard drive, Seagate, 80gb IDE ATA. That also worked properly, but I decided to move it another computer & make it the primary hard drive. After I removed it & booted up my system it said 'secondary drive not detected', so I went into the Bios & put the secondary drive on off. When it booted up I noticed that the D:(optiarc) drive was not there. After I finished working with the other comp I decided I didn't need it there & put the secondary drive back in the main comp and it worked properly, but the optiarc still is not detected. I looked in the Bios, in the boot sequence, & next to IDE cd drive it says, 'not installed'. The jumper settings I had when it was working was main drive on master, secondary drive on slave, & optiarc on cable. I put the both the secondary & optiarc on slave to see if it would detect it, but I got the same results. I also went to manage under my comp, and the optiarc disk is not there. How come it's not recognized now?

    Other spec on my comp are:
    Dell 8250
    Pentium 4 3.06ghz HT 478 pin
    Phoenix Bios
    512mb(2*256) RDRAM PC1066
    Main hard drive: western digital 60 gb IDE ATA
    Secondary hard drive: seagate 80gb IDE ATA 7200rpm
    Optiarc is also on IDE cable.
    OS: XP home sp2

    Any advice is appreciated, thanks.
  2. Matthew

    Matthew TechSpot Staff Posts: 5,332   +101

    Not sure what you're suggesting here:

    If you somehow have three devices on the cable (not something I've ever seen), it goes against the entire design concept of ATA Master/Slave (from my understanding) and it's not going to support a third device. Remove the optical drive from that cable, install it with it's own ATA data cable attached to a separate host adapter.
  3. ressn

    ressn TS Rookie

    you must check the cable if it still works.
  4. LSE

    LSE TS Rookie Topic Starter

    I'm very sorry, I meant that the optiarc is on it's own IDE cable connected to the motherboard. The two hard drives are on a separate ATA data cable.
  5. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    Ensure the dips on both drives are selected for cable select.
    Then place your primary drive on the END of the cable and your slave on the middle.
    Ensure the drives are on the FIRST channel of your IDE.

    If BIOS does not SEE your drives, then you have a a hardware issue - more than likely your cable is loose/bad
  6. Matthew

    Matthew TechSpot Staff Posts: 5,332   +101

    LSE, set your BIOS to the factory default settings. Perhaps you disabled something you shouldn't have when you were playing around in there.

    If you can't see your optical drive in the BIOS, try another ATA cable. If you still can't, try switching the host adapter that your optical drive/HDD's are using. Maybe one of the host adapters on your motherboard is defective (although this would be unlikely).
  7. LSE

    LSE TS Rookie Topic Starter

    I manually reset the bios(can't do it in the actual bios), and it recognized the optiarc dvd drive on the first start up. :)
    Thanks very much Zenosincks for your help, and thanks tedster & rssn for your advice. I won't be playing around in my bios anymore, lol.
  8. Matthew

    Matthew TechSpot Staff Posts: 5,332   +101

    Aww don't let that scare you off :D! You're welcome!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...