1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Classic bsod case

By jacket · 106 replies
Jul 31, 2009
  1. Not So Classic BSOD...

    I hope I'm doing this in the right forum.

    I just recently put together a new computer. Most of the parts are brand new except for my graphics card which is an ATI fireGL 3600

    GIGABYTE GA-EP45-UD3P motherboard
    Intel Core 2 Quad 2.83GHz
    8GB G.SKILL 240-Pin DDR2 SDRAM DDR2 1066 Dual Channel Kit
    SIGMA MONSTER 850W power supply

    I only put the computer together for a week and I've already had 7 BSOD. First with windows 7 (since I was testing out the 64 bit version that I planned to purchase come it's release) and I assumed it was just the new beta operating system.

    So I downgraded back to my Vista 32 bit and the blue screens still haven't stopped. I have the minidump files that states ntkrnlpa.exe is not working or corrupt. If need be I will post the minidump files that I have available.

    After which I did a memory diagnostic test that stated that I had an error with physical memory. However, I was unsure exactly what that entitled. Yes I am a first time builder so I am quite at a loss at the moment.

    The BSOD is relatively random. It happened once while I was only checking my graphic's card drivers, then tonight in the middle of my typing on microsoft word (which resulted in me losing work, so I am a little disheveled)

    Any and all help would be greatly appreciated. I have looked at other topics but at this moment I am not sure exactly how much is similar to my problem and what is not even close.


    I hope this is the right text, i'm sorry if i posted the incorrect information

    This is from the first crash

    FAULTING_MODULE: 81800000 nt
    READ_ADDRESS: unable to get nt!MmSpecialPoolStart
    unable to get nt!MmSpecialPoolEnd
    unable to get nt!MmPoolCodeStart
    unable to get nt!MmPoolCodeEnd
    81846316 ??              ???
    LAST_CONTROL_TRANSFER:  from 81846316 to 8188fc44
    WARNING: Stack unwind information not available. Following frames may be wrong.
    9513f7ec 81846316 badb0d00 00000002 818e7c9d nt+0x8fc44
    9513f8c0 8181ba90 9513f86c 029a9cf0 859a9000 nt+0x46316
    9513f8f4 819fb83e 95134278 9513f980 00000006 nt+0x1ba90
    9513f938 819fa81f 82dc7101 951342e8 00000014 nt+0x1fb83e
    9513f9a8 81a82470 00000000 82dc7101 9513fd30 nt+0x1fa81f
    9513fd4c 8188c96a 0000004f 0220f2a0 00000014 nt+0x282470
    9513fd64 778c0f34 badb0d00 0220f230 00000000 nt+0x8c96a
    9513fd68 badb0d00 0220f230 00000000 00000000 0x778c0f34
    9513fd6c 0220f230 00000000 00000000 00000000 0xbadb0d00
    9513fd70 00000000 00000000 00000000 00000000 0x220f230
    81846316 ??              ???
    SYMBOL_NAME:  nt+46316
    FOLLOWUP_NAME:  MachineOwner
    IMAGE_NAME:  ntkrnlpa.exe
    Followup: MachineOwner
  2. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    In your next post attach your five latest minidumps. This kind of thing happened to me when I built a new rig. BSODs after BSODs. Came to find out after 3 months of pulling my hair out it was my Sunbelt Firewall.

    At this juncture it could be anything.
  3. jacket

    jacket TS Rookie Topic Starter Posts: 65

    Alright. I tried to read the dump files myself but I can't figure out how to connect the symbols to the file to make it legible in any way.

    Tonight I'm possibly going to attempt to memory test each individual ram stick to see if that's the case.
  4. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Is there any way you can put your dumps into one Zip file?
  5. jacket

    jacket TS Rookie Topic Starter Posts: 65

    okay, here's all of my dump files in a single zip format.
  6. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    One error is 0x50: PAGE_FAULT_IN_NONPAGED_AREA
    Requested data was not in memory. An invalid system memory address was referenced. Defective memory (including main memory, L2 RAM cache, video RAM) or incompatible software (including remote control and antivirus software) might cause this Stop message, as may other hardware problems (e.g., incorrect SCSI termination or a flawed PCI card).

    This error only cited a Vista driver as the culprit but generally OS drivers are too general to be of much help

    Two errors are 0xA and these are caused either by hardware or drivers attempting a higher IRQ Level that they have no business doing. One gave a Vista driver but the other one specifically cited corrupted memory as your issue.

    Two are 0x8E errors and they are almost always caused by hardware and are particularly a strong indicator of corrupted memory. One specifically cited memory corruption as your issue.

    Here is what I suggest:

    1. It may not be memory corruption per se. Check the RAM voltage as set in your BIOS and does it match the manufacturer's voltage spec? If you have overclocked ease back the timings/voltage.

    2. Try running with 4 gigs and then two gigs of RAM. Are you getting BSODs?

    3. See this link and follow the instructions: https://www.techspot.com/vb/topic62524.html

    Let it run for a LONG time. The rule is a minimum of 7 Passes; the more Passes after 7 so much the better. There are 8 individual tests per Pass. Many people will start this test before going to bed and check it the next day.

    If you have errors you have corrupted memory and it needs to be replaced.

    Also, with errors you need to run this test per stick of RAM. Take out one and run the test. Then take that one out and put the other in and run the test. If you start getting errors before 7 Passes you know that stick is corrupted and you don’t need to run the test any further on that stick.

    * Get back to us with the results.
  7. jacket

    jacket TS Rookie Topic Starter Posts: 65

    I checked in the bios to see what the voltage, I feel a little silly saying that I'm not entirely sure where the voltage statement was, but I'm willing to admit I am still not entirely educated in this field. I believe that the information it provided was 1.8 v while my ram goes up to 2.1 v

    If this information sounds incorrect or if I am looking in the wrong area, I would appreciate being corrected.

    However, I ran the mem test again and it errored on the 8th test. So this means I'll test out each of the sticks themselves.

    I'll reveal what I've come across after I've gone through the motions. I'll wait until I've gotten a response about the volts before I continue. (aka i'll wait about an hour then I'll shut down and begin testing)
  8. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    The memory errors are your main concern here. Those voltage parameters sound correct. But to make sure go to G.Skill's website (excellent memory by the way), find your model and check out the specs. If 1.8v is the standard and your BIOS show this then that is good to go.

    You can run Memtest without needing to know the voltage specs, but I would check out the specs first anyway.
  9. jacket

    jacket TS Rookie Topic Starter Posts: 65

    I looked up the qualifications of my ram and it states --- Test_Voltage 2.0 ~ 2.1 Volts

    Does that mean it's not getting enough power? Sorry for all the questions by the way.
  10. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Don't worry about the questions. The questions are good. In your BIOS set the memory voltage to 2.0v. See if that stops the BSODs. We have seen a rash of memory corruption errors this year where the issue isn't corrupted memory per se but rather the motherboard didn't set the voltage correctly.

    If this does not stop the BSODs then test each stick with memtest and replace the bad RAM.
  11. jacket

    jacket TS Rookie Topic Starter Posts: 65

    may I ask what screen particularly that I edit the voltage in? I went into the bios but I'm a little nervous about switching around the volts (obviously with my current situation) Also when I was in the voltage section of my bios (or at least I thought that was the correct) and it wouldn't let me raise the volt past 1.85 I think.

    Thank you for being understanding about all my questions though.
  12. jacket

    jacket TS Rookie Topic Starter Posts: 65

    Okay, I ran the memcheck with all four 2 gb ram sticks in and it reported an error on the 8th test (as I said)

    I removed all ram sticks and tested them one at a time. (actually I tested 2 at a time at first, the two checked out after 9 tests. I then tested the others individually and then all together once more.

    They all checked out with no errors after letting it run 7 and more test passes.

    I'm not entirely sure but if I have another BSOD I will give an update. I'm a tad worried what this could be. A part of me is thinking that perhaps one of the sticks was not in correctly and that might of been the cause of all the problems.
  13. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    RAM sticks not set properly can indeed cause issues. It really can be that simple and nothing to worry about.

    You have a lot of memory installed and, again, watch for BSODs since memtest has recorded errors. Keep us up-to-date.
  14. jacket

    jacket TS Rookie Topic Starter Posts: 65

    Okay, maybe it isn't the memory.

    I was just sitting today looking at a forum and then it randomly blue screened on me again. Here is the dump file. I wasn't doing anything straining on the computer. The only program on was firefox with one tab.

    I am at a loss for what is wrong now.
  15. jacket

    jacket TS Rookie Topic Starter Posts: 65

    Again it is crashing without warning. I checked the cpu's temperature and it wasn't getting any hotter than 32 C and the entire comp is under 35 C. It's barely been on for a few minutes so I'm just not finding any rhyme or reason for why this is happening.

    There's the second dump file for today. I really am at a loss for what else this could be. unless I should just go ahead and reinstall my OS for the 4th time.
  16. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Your first error is 0xA and and as has been defined before these are caused either by hardware or drivers attempting a higher IRQ Level that they have no business doing. This simply cited an OS driver.

    The second error is more promising. It is an 0xD1 and these are usually caused by drivers. Though this cited hardware it specifically noted that the ATI driver atikmdag.sys could not be loaded. There is quite a bit on the internet concerning this driver and Vista.

    See this link: http://forums.amd.com/game/messageview.cfm?catid=260&threadid=104677
  17. jacket

    jacket TS Rookie Topic Starter Posts: 65

    Okay, I uninstalled the update KB952287 (which when in the update manager it stated that the update had failed even though it was still installed), and I also cleaned my registry. I'm a little nervous about the last option that they suggest by http://www.repairyourpcnow.com/resources/atikmdag-has-stopped-responding.php on option #4.

    We'll see how this goes. I hope that this is the option.

    Can I ask if this isn't the issue, is it possible that it's a faulty motherboard issue? I have asked a few programmer friends at school and, without looking at the dumps yet, they suggested that it is possibly a faulty motherboard.

    I just wanted to ask your opinion on this route.

    Also thanks for all the help you've provided so far. Is there anything else you can think of? Or do you think I should go through with option #4. I don't overclock my machine (I've always been nervous about such a procedure) so I'm not entirely sure what to set my clock to.
  18. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Working in the registry one must be very, very careful. A great free registry utility can be found at MajorGeeks.com and it is RegCleaner.

    I suggest doing the following...

    1. Download Driver Cleaner Pro or Driver Sweeper (both have free versions) to your desktop screen and install.

    2. Download the latest diver(s) for your video card but don't install them.

    3. Uninstall your video card drivers and reboot your PC into Safe Mode. Run Driver Cleaner Pro or Driver Sweeper. If it doesn't find any video card drivers that is quite okay.

    4. Reboot and install new video card drivers.

    * Tell us if this fixes your problem.

    * Are you concerned about Fix #4? I can say that the utilities they list are legitimate. But do the above first.
  19. jacket

    jacket TS Rookie Topic Starter Posts: 65

    I was just worried about messing with my clock, that's all. I've never messed with a cpu clock before and without knowing much about it, I'm worried about messing it up.

    Also, I'm in the middle of trying your suggestion. For some reason though while I was preparing to do this, my computer bluescreened twice. It said it was because of my antivirus this time when I had windows 'check for solutions' on it's own.

    I'll post up the other two dumps just incase and I'll progress with what you asked me to do.
  20. jacket

    jacket TS Rookie Topic Starter Posts: 65

    I did as you said, after I had installed the graphic card driver it BSODed again

    Here's the new minidump.

    I'm considering that perhaps my registry is flawed or something. I think maybe I should reinstall vista again?
  21. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    The only thing definitely cited was the Avast driver aswMonFlt.sys. In the mix of another dump was another Avast driver ashServ.exe which is the main executible for the Avast security suit. I must make it clear that this driver was not cited as the cause.

    Avast is a very stable software so at this point I am not thinkingthis is your issue at this time.

    Let's approach this from another angle. Go to the Virus and Malware removal forum. Read the UPDTAED 8 Step sticky and follow the steps; don't skip any steps and when your are done then post at that forum the required 3 Logs.

    We are trying to determine if you are infected.
  22. jacket

    jacket TS Rookie Topic Starter Posts: 65

    A virus on a computer that I have a new installation in with no access to the internet over two OSes? I hadn't even used my back up files when these started to happen. As I said, it was all completely new parts.

    I'll try what you ask, but I highly doubt this was caused by a virus.
  23. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Sorry, but I didn't see where you posted you hadn't been on the internet yet. Uninstall Avast and tell us if you are still getting BSODs. Besides Avast what other security do you have loaded, if any?
  24. jacket

    jacket TS Rookie Topic Starter Posts: 65

    It's fine, I'm doing the scans anyway just to be safe. However, they haven't found any sort of virus or ad-ware. I apologize if I sounded rude. I truly am grateful for your help. I just am doubtful that it's a virus, that's all. thus why I'm still doing the test to be completely sure. Perhaps a virus carried over at some time when I installed or maybe something is corrupt. I don't know.

    I usually use Avast and Lavasoft Ad-aware.

    ~~ add-on ~~

    Okay, Now my computer is crashing before I can finish anything really. It's doing it more often now and I just noticed that there's something strange about my harddrive. it's supposed to be 500 gigs but it's only showing up as max at 120 gigs. I think I'm just going to wipe it, wipe the partition and then reinstall vista and see if that helps any.
  25. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    jacket, before reformating I strongly suggest running harddrive diagnostics first. If there is something physically wrong with it no amount of reformating is going to help.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...