Connecting to router but rarely Internet, and when I do DNS lookup fails

By sirsnipps ยท 31 replies
Jan 3, 2012
Post New Reply
  1. Vrmithrax

    Vrmithrax TechSpot Paladin Posts: 1,352   +293

    Just something to check on, sirsnipps... What internet security settings or software are you running? I ask, because I was experiencing very similar behavior on my son's computer, and it turned out to be a flaky setup of Comodo firewall software. For some reason, the Windows firewall was on as well, and the system kept flipping the "network detection" settings between established private network and a new unknown public one. It was driving us bonkers for the longest time, and we ran round and round with different wireless connectors, etc. But, as is happening with you, even wired ethernet had issues, which pointed me away from hardware and towards something in the drivers or operating system. Once we uninstalled and reinstalled the security software, everything worked fine.

    Might be worth a check...
  2. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    The dongle -> direct to the system works fine, which says
    1. dongle is ok
    2. system is ok
    3. firewall is ok too
    imo, the router
    • settings need to be adjusted
    • may not be compatible with this dongle
    • just may be dead
  3. Vrmithrax

    Vrmithrax TechSpot Paladin Posts: 1,352   +293

    Hmmm, maybe I'm reading it wrong, but I was understanding that he couldn't connect wirelessly, through direct ethernet, or with an external dongle. Which sort of points fingers back towards system and/or firewall, considering everyone else is having no issues with the same router (so it can't be dead)...
  4. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

  5. wrt54gs7

    wrt54gs7 TS Enthusiast

    In case you haven't read carefully all posts, probably you have not. The router could not be dead, it is functioning perfectly as dhcp server.
  6. sirsnipps

    sirsnipps TS Rookie Topic Starter

    Hi guys, sorry for not replying for ages, I didn't exactly have access to the internet. As it turns out it's all fixed and the problem was so obvious I'm almost embarrassed to tell you. As Vrmithrax suggested it was simply that my firewall was out of date since it couldn't update, uninstalling it fixed everything. The stupid this is I did actually think of this when it first happened but for some reason never did it.

    Oh well! Thanks for all the help everything, I appreciate it.
  7. wrt54gs7

    wrt54gs7 TS Enthusiast

    I thought you have already tried disabling the firewall but still no luck. Anyway it is good that the problem has been fixed.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...