Copying failure - delayed write popups

By enderlicious ยท 19 replies
Jul 24, 2011
Post New Reply
  1. I've been having issues with my computer. It appears that I got the trojans and other malware cleaned up/removed (covered in a different thread).

    I've been trying to move files and stuff off the system drive onto an external HD (raw drive w/USB connector). I'm currently trying to clean off my camera card onto that external drive - both are connected by USB, I try copying from one to the other and midway through I get (yes, plenty of space at the destination):

    Error Copying File or Folder
    Cannot copy IMGPxxxx: Cannot find the specified file/
    Make sure you specify the correct path and file name.

    And a (bunch of these, which hang around forever and keep popping up):

    Windows - Delayed Write Failed
    Windows was unable to save all the data for the file
    K:blahblahblah. The data has been lost. This error may be a failure of your computer hardware or network connection. Please try to save this file elsewhere.

    I've got system instabilities, which is why I'm trying to get everything cleaned off the installed HD so that I can wipe it (and all the partitions? - I *did* divide up the drive, so I could try and keep the data separate from the C drive - but stuff is telling me to wipe the whole drive).

    Partition magic said it couldn't start up because the partition table was bad. I reset the pagefile to 0, ran a chkdsk (scheduled after reboot), defragmented C, and then reset the pagefile, and then partition magic decided it could boot. I did nothing with it at that time, but close it.

    I thought, 'Whee, maybe I can move files now?'

    The drive I wanted to move to hadn't automounted. So I checked Safely Remove Hardware - it wasn't listed, so I yanked the USB cord, and then replugged in. OS found and mounted the drive. Cool.

    I checked out some of the files which I'd moved the last time or two, and they were viewable (unlike trying that after transferring the first time). Cool.

    So then I tried to copy everything to that directory, telling windows it was fine to over-write everything that was there (I don't know which files it did or didn't copy last time - and I didn't want to go thru every directory comparing whether or not files got copied, and if they were working, or only partial copies).

    It bailed again.

    Tried viewing the image(s) that worked just prior to this copy attempt. And now they won't preview, load, etc...

    So I'm not sure if my computer will let me copy files. I'm not sure if the files I copy are actually copied. And I don't know if I can view them later.

    Sorry, no second computer to pull the USB/drive to, in order to find out if it's just my system that's ****ed up (most likely), or if it hasn't actually copied anything I need copied (a worrisome possibility).

    I wouldn't mind a pointer to a good reinstall guide, especially one that covers what I should be checking to make sure I did prior to wiping. I think I've got my bookmarks saved, and some other stuff. But I'd really like to make sure I don't lose settings, forget which plugins I've got, or other stupid ****.
  2. Rabbit01

    Rabbit01 TS Evangelist Posts: 787   +58

    I'd boot up using Ubuntu live CD (there're other Linux version, but this is the only one I've played w/), then copy the images and other important files to elsewhere. Once they are store safely on another drive, then troubleshoot/reinstall Windows.
  3. enderlicious

    enderlicious TS Rookie Topic Starter Posts: 55

    Don't have one of those. Don't have a burner. Thus getting one requires a lot of hoops to be jumped through.

    OTOH, firefox is lagging this to hell and gone, which means it's time to use WTM to force-quit it, and time to restart.

    I'm going to see if Safe Mode helps at all...
  4. Rabbit01

    Rabbit01 TS Evangelist Posts: 787   +58

    No burner, not a problem. You can follow the instruction from Pendrivelinux and boot Linux from a USB flash drive. Copy your files to an ext HDD before whatever Windows problem you're experiencing corrupt the data.

    As for the FF settings, bookmarks, plugins, etc., I back those up using FEBE. You can find that here:

    However, if you're using FF5, than download FEBE v7 from here:
  5. enderlicious

    enderlicious TS Rookie Topic Starter Posts: 55

    I need to have an empty flash drive to put that on right? My problem is that I'm trying to clean up a card+reader (closest I've got to a flash-drive) onto a HD, so I've got space.

    Turns out I've only got the Windows Recovery Console setup. Don't see an option for Safe mode. Damn.

    And, it turns out this command (that I'd used):
    chkdsk /f /r

    Started another check when I had to restart (I'd already completed it once, last time around). After I had to hard-boot, because it said 'keyboard failure' (which is now happening about ~66% of the time).

    The third time through the reboot cycle, it didn't want to do a complete chkdsk check... it just started that up, and said, Oh, completed that...

    Monkeyed around in the WRC, looks like I might be able to copy files - but it won't let me make a directory mkdir J:Stuff (denied, and doesn't look like there's a way to give myself more permissions) - the command works fine in C:\Windows - but not on the HDs/flash stuff.

    I'll download the iso for linux to the HD, but I don't think I'm going to be able to boot with it.

    Then I'm going to make a couple of directories, so that I can try moving/copying stuff with WRC after reboot.

    Currently I'm going to see if I can find out how to reset chkdsk & get safemode as a bootup option. Then I'll see about rebooting.

    Will check here once I've got that stuff done.

    note: I'm getting the delayed write failed popups, even though I've not done anything on this reboot - where are those stored, and how can I flush them?
  6. enderlicious

    enderlicious TS Rookie Topic Starter Posts: 55

    Downloaded the linux. Can't put it on the current HD (nor can I make a folder), because I can't reach it from windows. It doesn't automount. So check SRH, it doesn't show, I pull it out & replug it in, and then it shows stuff - but I can't change anything on the drive anymore.

    To turn off the chkdsk, you need to permit this registry change:

    autocheck autochk * /r\DosDevice\C:
    changes to:
    autocheck autochk *

    I'd been outsmarting myself, since I have a registry monitor - I basically disable any changes I don't understand :) So I should be able to get that fixed.

    Looks like I need to F8 to get into safe-mode. Don't know if that will help.

    I haven't been able to figure out how to flush the delayed write popups (which is also preventing me (I'm guessing) from safely dismounting that external drive.
  7. Rabbit01

    Rabbit01 TS Evangelist Posts: 787   +58

  8. enderlicious

    enderlicious TS Rookie Topic Starter Posts: 55

    sfc /scannow

    Tells me that I need a Windows XP Professional Service Pack 3 CD

    Which I don't have. In fact I don't have a SP2, which is one of the other reasons I've been putting off the reinstall (besides having to find the plain install disc).

    How do I get some of those, so that I don't have to try updating my system from the net (ie: letting it sit with security holes while it downloads and installs SP2)?

    And how would I get SP3, since it wants it in a CD form?


    I found some info on delayed write stuff:

    But not sure if it applies to me. And one of those 'tests' is just prod it with bigger and bigger blocks, which will cause corruption if it is what the problem is (which I could use less of on my data!).
  9. Rabbit01

    Rabbit01 TS Evangelist Posts: 787   +58

  10. enderlicious

    enderlicious TS Rookie Topic Starter Posts: 55

    nlite looks like just what I was looking for.
    I'll have to get stuff together, and try it.

    Any ideas for uncorrupting, or restoring the files on the drive which has been suffering from those write delays (not holding out a lot of hope... but).
  11. Rabbit01

    Rabbit01 TS Evangelist Posts: 787   +58

    I don't think recovering files on the external HDD is possible, since data might not have been transferred completely in the first place. What about the data on the source drive? Whether you've copied and deleted those or moved them, if those sectors haven't been over-written, it might be possible to recover them.

    Some options:
    Recuva -
    Photorec -

    In my one time test, Photorec was able to recover files after the drive repartitioned.
  12. enderlicious

    enderlicious TS Rookie Topic Starter Posts: 55

    I wasn't worried about the stuff I was trying to copy - I understand it might not've made it.

    I was concerned about the drive getting corrupted - and losing data I'd already saved to it. I don't know that that has actually occurred, but I do know that files that appeared to be accessible aren't accessible. And I can't create a folder on that drive...

    Not sure how much time I've got to devote to it right this instant. My weekend kinda wasn't planned to dump 8-10 hours on this.
  13. Rabbit01

    Rabbit01 TS Evangelist Posts: 787   +58

  14. Rabbit01

    Rabbit01 TS Evangelist Posts: 787   +58

    See if these settings will allow you to creat directories on the external drive.

    in recovery console, type:

    set AllowRemovableMedia = TRUE


    set AllowAllPaths = TRUE
  15. enderlicious

    enderlicious TS Rookie Topic Starter Posts: 55

    Surprisingly, they're actually seagate drives.
    The one I've got an issue with is a raw HD with a USB interface, not an 'external'.
    I downloaded the SeaTools (tutorial is in flash, and manual is PDF - both of which I've disabled), and had some issues with my mouse.
    Restarted, and it didn't like my mouse. Swapped mouse out.
    Tried running it, but perhaps my computer was running slow - ended up with several instances running, used task manager to kill the extras.
    Ended up with Windows explorer running a Data Exception Protection error. Had to reboot.
    Reboot, and ran SeaTools.
    I had mounted the new drive and the drive that had the issues (hoping to copy one to the other). SeaTools only showed the new drive, and the internal drive.
    Couldn't get it to show up in 'My Computer', nor in the Safely Stop stuff...

    Currently unsure how to make the HD attempt to mount.
  16. Rabbit01

    Rabbit01 TS Evangelist Posts: 787   +58

    I've had issues in the past w/ USB drives (Flash & HDD) that didn't show up in My Computer but was listed in Disk Manager. Right click on My Computer, then Manage. On the left, you should see System Tools, Storage, Services and Applications. Disk Manager is listed under Storage. If the drive is listed then you should be able to right click on it and select Explore. As for having the drive displayed in My Computer, I don't recall what I did.
  17. enderlicious

    enderlicious TS Rookie Topic Starter Posts: 55

    I couldn't find Disk Manager under storage. However, Safely Remove Hardware came up with something, even though it didn't mount any of the partitions. I was able to check out the properties, and then troubleshoot. From the troubleshooting menu, I got a link to the Device Manager (Control Panels/System/Hardware), and *that* troubleshooting guide came up with this:

    Windows cannot use this hardware device because it has been prepared for "safe removal", but it has not been removed from the computer. (Code 47)

    To fix this problem, unplug this device from your computer and then plug it in again.

    (which, obviously, hasn't been working the last 40-80 times I've done it in the last week).

    Windows is starting to crawl, so it's about time for my reboot. We'll see what's new after this fresh reboot.

    Tried disabling it (and re-enabling) for my next restart...
  18. Rabbit01

    Rabbit01 TS Evangelist Posts: 787   +58

  19. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    Delay Write Error is a known condition for some HDs and/or drives accessed via Mapped Drive Letters.

    Access your Registry and look for
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management
    find the key LargeSystemCache (reg_dword) and make sure it is 0 (zero) and not 1 (one).
  20. Neil010

    Neil010 TS Rookie Posts: 53

    I have spoilt one of my external hard disks like that. You should never disconnect an external hard disk during active data transfer. However for me, only one sector was spoilt. I can't access it. I also had a friend who ahd that issue, but his was because he had dropped it. I don't think it's a virus issue.

    Anyway, try download your Camera's contents on another path in your hard disk, and hopefully you'll be able to use it.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...