1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Copying to/from flash drives stuck on "5 seconds remaining" for 30 sec before finishing

By Marty9231 ยท 4 replies
Nov 20, 2014
Post New Reply
  1. Hello!

    It may seem like a simple problem, but I know nothing of the subject and I've had the problem for ages.

    Whenever I copy large files (Movie size, think 700MB+), the copy progresses very fast (~100MB/s) until it reaches about 99% where it gets stuck for about 30 seconds to a minute, and it says "Time remaining: 5 seconds" during all that time.

    I have this problem with any flash drive, in any USB port (2 & 3). It also happens when copying to network drives and external harddrives, which leads me to think it's a software/windows issue.

    Some vital information:
    • The flash drive I mainly use is USB 3.0, quite new and easily capable of ~150MB/s writing speeds. It reaches about 120-130 MB/s during the copy until the final point where it still says 130 MB/s but does nothing for 30 seconds.
    • USB port is also 3.0, and I've also tried every single other port in my computer. None are broken, and none ever show any signs of being slow.
    • The flash drive is NTFS formatted, but it used to be FAT32. I ran checkdisk to see if there was anything wrong, but there wasn't. It's NTFS since I occasionally need files >4GB.
    • I tried using TeraCopy to bypass the issue, but this way doesn't reach speeds of over 20MB/s which takes even longer in the end. It does fix the 'hanging at 99% issue'.
    • I tried converting the drive back to FAT32, which removes the issue of it hanging at 99%, but again the speed doesn't go above 20MB/s which means it takes longer in the end, making it not worth it.

    What bothers me is that the files transfer at the maximum speed right until the very end, where it just magically gets stuck for 30 seconds or more, before finishing like nothing happened.

    Please advise!!

    P.S.: I shamefully have to admit I never safely remove my hardware. :confused:
  2. learninmypc

    learninmypc TS Evangelist Posts: 8,585   +559

    Although I've had the same happen on my downloads, this "P.S.: I shamefully have to admit I never safely remove my hardware." could be part of the problem, good luck. :)
  3. verneronomous

    verneronomous TS Enthusiast Posts: 42

    You know years ago I have come across this problem and it ended up being the standard windows drivers that it installs when plugging into port. On the machine I was using I installed the correct driver for that flash drive from manufaturers website. If that does not work try the same flash drive in another computer. Maybe a pc or even a mac. It was weird but the same flash drive in windows would do what you are talking about and when I put it in my mac it worked flawlessly. Very odd indeed....let me know what you find...
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,545   +429

    I wonder if this is not related to incorrect calculation of time remaining, which has been an issue on computers for decades. I'd bust out a stopwatch and repeat the copy with a large file several times. Then look in Performance Monitor for write speeds, and see what you come up with for times.

    Now this assumes a constant write speed, but this is probably a pretty valid assumption. I would ONLY use USB3 for this. I would also format the flash drive as exFAT rather than NTFS.
  5. jobeard

    jobeard TS Ambassador Posts: 12,443   +1,415

    Try to verify the target drive causing the delay - - I would believe that the target being the pc drive might behave differently than when the flash drive is the target.

    Here's why: Mass loading data into a DMBS is always a performance problem and resolved by
    * deleting all indices
    * perform the mass load
    * redefine and update all indices

    What's that got to with PC copies?? The Windows Search! Mass loading directories/files has the same issues as the DBMS :sigh:

    DISABLE Windows Search before the copy -> PC and then reenable it

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...