Cpu i5 9600kf motherboard MSI Z390 A-Pro. Fresh bios and drivers innstalled. CPU-z shows this in multiplyer window - x49 (8-46) Core frequency jumping

Core ratio multiplyer jumping from 8 to 49! This leads to inadecvate performance in games. I tried in fefolt mode -result is the same- just numbers different x43 (8-46). Could anyone help me, please?
 

neeyik

Posts: 997   +962
Staff member
It's supposed to do that, if you have Intel C-State and Speed Shift enabled - these drop the CPU clock multiplier down, when the load on the processor isn't high, to save energy. You can disable them in the motherboard BIOS, to force the CPU to run at its maximum clocks all the time.

Check pages 60 and 61 for the relevant sections in the manual for the motherboard:

 
  • Thread Starter Thread Starter
  • #3
It's supposed to do that, if you have Intel C-State and Speed Shift enabled - these drop the CPU clock multiplier down, when the load on the processor isn't high, to save energy. You can disable them in the motherboard BIOS, to force the CPU to run at its maximum clocks all the time.

Check pages 60 and 61 for the relevant sections in the manual for the motherboard:

Thank you. I tried what you suggested. Didn"t work, core frequency keep on jumping
 

neeyik

Posts: 997   +962
Staff member
Double-check all of these BIOS options:

OC > Misc Settings
EIST = set to Disabled
Intel Turbo Boost = set to Enabled
Enhanced Turbo Boost = set to Auto or Enabled (warning, putting this to Enabled should force the CPU to run permanently at full clock settings for all cores)

CPU Features
Intel C-States = set to Disabled
C1E Support = set to Disabled
EIST = should read the same setting as above
Intel Speed Shift Technology = set to Disabled
 
  • Thread Starter Thread Starter
  • #5
Double-check all of these BIOS options:

OC > Misc Settings
EIST = set to Disabled
Intel Turbo Boost = set to Enabled
Enhanced Turbo Boost = set to Auto or Enabled (warning, putting this to Enabled should force the CPU to run permanently at full clock settings for all cores)

CPU Features
Intel C-States = set to Disabled
C1E Support = set to Disabled
EIST = should read the same setting as above
Intel Speed Shift Technology = set to Disabled
Now everything works fine. CPU at 4900 mhz, memory without xmp at 4226mhz (native xmp 4133mhz).
I really appreciate your help.
PS I didn't find C1E support inCPU features and in CPU-z multiplier bar (8-46) visible, but x49 stays stable.