Daily BSODs on Vista after up-downgrade

By nynaeve · 4 replies
Jan 4, 2011
Post New Reply
  1. Good afternoon all,

    I seems to have got myself into a pickle with my computer.

    About two years ago I purchased a Dell Inspiron 530 large tower on Vista Ultimate 32x, it was the perfect PC at the time with no problems up until 3 months ago. I did a test upgrade to Windows 7 Enterprise 32x using a copy I borrowed from work with the intention of getting my own copy once the activation period came to the end.

    Once this finished I downgraded once again to Vista because I didn't have enough money to purchase my own copy of the win7 licence.

    Since I downgraded I have had Blue Screens consisting of 0x..C5 and 0x..D1. My understanding is that these BS are caused by lazy drivers that cause the RAM to go over the top and crash out.

    The most recent two 0x..D1 Blue Screens were was USBPORT.SYS which was my iPhone Charging at the front USB port so I unplugged it only to be followed by ads.sys I believe, it restarted before I could make a proper note of the error code. Although all of the other BS before this did not mention anything else other than 0x..D1.

    I made updates of the Wireless Drivers, Wireless mouse and keyboard and graphics card to no avail. I also tried Hirens Boot CD for Memtest and found no problems with the RAM sticks with one or both sticks in when tested.

    I recently had the AV "Bit Defender" come to the end of its life and installed AVG (Not the best of choices when it comes to AV, been causing a good few problems with many PCs lately!) before I activate Bit Defender again or change to Sophos. Although the BS were occurring before Bit Defender stopped working so I doubt this is the issue. I installed AVG before removing "BD"

    The Firewall seems to have done a funny turn on itself as well, I can't turn it on in the Windows Security Centre, it also does not let me do it manually claiming that the settings are out of date, when I try to update them I get the message Windows Firewall could not update the settings. (No other information available..)

    I then found out Vista had sent itself back to the unsupported SP1 for no explainable reason, it has refused to update to SP2 using the message "Service Pack Did Not Install. Reverting Changes" once at stage 3 of 3 100%. Sevice pack Prep package did not resolve this issue and SP2 is still not installed. I also tried making a manual install. This has prevented me from getting updates (Most likely vital to solving the issue) from working.

    I am not sure if posting in the section of the forums was correct as it is trying to resolve the BS issue primarily, but I believe it might come down to updates not being installed.

    Thank you for your time.:)


    EDIT: Forgot to add System Info

    Operating System: Windows Vista™ Home Premium (6.0, Build 6001) Service Pack 1 (6001.vistasp1_gdr.100608-0458)
    Language: English (Regional Setting: English)
    System Manufacturer: Dell Inc.
    System Model: Inspiron 530
    BIOS: Phoenix - AwardBIOS v6.00PG
    Processor: Intel(R) Core(TM)2 Duo CPU E6550 @ 2.33GHz (2 CPUs), ~2.3GHz
    Memory: 2046MB RAM
    Page File: 1333MB used, 3010MB available
    Windows Dir: C:\Windows
    DirectX Version: DirectX 10
    DX Setup Parameters: Not found
    DxDiag Version: 6.00.6001.18000 32bit Unicode

    Graphics Card:
    Card name: ATI Radeon HD 2600 XT
  2. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    How to find and post your Minidump Files:

    My Computer > C Drive > Windows Folder > Minidump Folder > Minidump Files.

    It is these files that we need (not the folder). Attach to your next post the five most recent dumps. Notice the Manage Attachments button at the bottom when you go to post the next time. You can Zip up to five files per Zip; if you only have one or two you don’t need to zip them, just attach as is. Please do us a favor and don’t Zip each one individually.
  3. nynaeve

    nynaeve TS Rookie Topic Starter

    Hi Route

    These are the 5 most recent date modified minidump files

    Attached Files:

  4. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Sorry for the delay; I've been ill but I didn't want you hanging so to speak.

    Your issue is with memory corruption. Therefore you’ll need to run memtest on your RAM.

    See the link below and follow the instructions. There is a newer version than what is listed; use the newer. If you need to see what the Memtest screen looks like go to reply #21. The third screen is the Memtest screen.

    Step1 - Let it run for a LONG time. The rule is a minimum of 7 Passes; the more Passes after 7 so much the better. The only exception is if you start getting errors before 7 Passes then you can skip to Step 2.

    There are 8 individual tests per Pass. Many people will start this test before going to bed and check it the next day.

    If you have errors you have corrupted memory and it needs to be replaced.

    Step 2 – Because of errors you need to run this test per stick of RAM. Take out one and run the test. Then take that one out and put the other in and run the test. If you start getting errors before 7 Passes you know that stick is corrupted and you don’t need to run the test any further on that stick.


    * Get back to us with the results.
  5. nynaeve

    nynaeve TS Rookie Topic Starter

    Ok thank you I will give this a run and see how it goes. Hopefully my fears are not for the RAM sticks themselves, although it would be a good chance to upgrade them to the 2g versions if this is the case.

    Hope you get better soon!

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...