Dell Poweredge 840 won't power on, green light on motherboard blinks

By ace38 · 5 replies
Feb 16, 2011
Post New Reply
  1. It worked just fine last night while setting it up, got Vista loaded on and updated. Shut the machine down and this morning, it wont power on and the green power light on the motherboard flashes. No pattern, just an on/off flash.

    I can't believe it would be the motherboard but I suppose anythings possible, just be odd after working perfectly otherwise. I'm kinda stumped, does anyone out there have any experience with these servers and has an idea?

    Thanks in advance
  2. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    This is a quote from the manual, no mention of Vista. I'll look into it further as this is probably a driver issue.

    EDIT. There are no drivers listed on the Dell site for anything other than the OS's below. What OS was on it before?

  3. ace38

    ace38 TS Rookie Topic Starter


    An operating system won't prevent power up.
  4. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    I did not mean to imply that it would, but what will you do for drivers or have you already acquired all the correct Vista drivers to run this server. Have you installed the chipset drivers? If you intend to use this as a server it will need a Server OS, Vista is unlikely to be up to the job even if you can get the correct drivers to make it work.

    When a PC won't boot it can be due to a failed power supply, faulty connections on the mobo, a fault in the bios or on the mobo, the CPU or the memory. Quite a few to choose from.

    This can be dealt with by process of elimination by stripping the machine back to the least number of components that it needs to reach POST and then adding the parts back in to find what caused the problem.

    All you need to have connected is the power supply, mobo & CPU and monitor. Disconnect absolutely everything else, hard drives, Ram modules, PCI cards, keyboard & mouse. If it has onboard graphics use that and remove the graphics card. Hit the power button and if you get something up on screen shut down and then fit one memory stick and see if it will reach POST, if not try another memory stick and so on. If one stick gets you to the POST screen then try it in all the different slots to see if a slot is faulty.

    If you have got this far then one by one add the components back in and test as you go until you come across the one part that was causing the problem.

    If at the start of this process the machine will not start then remove the CMOS battery for about ten minutes, replace it and try again. If still no go you need to either use another known good power supply or test the existing one with a volt meter, voltages should be listed by cable colour on the PSU case. If the power supply is OK then it has to be the mobo or the CPU. You could test the CPU in a compatible known good PC. And you can test the mobo with a compatible know good CPU and see if it will reach post.

    Hope this helps and you can find the problem.
  5. ace38

    ace38 TS Rookie Topic Starter

    Vista set up

    All the drivers, including surprisingly the PCI-e network card. And as I stated, the machine ran fine to the point I shut down after updating. I had checked all connections, cleared the CMOS and stripped it to the bare minimums, still no go. The PSU checks out as OK, so I just ended up parting it out.
  6. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Sounds like this must have been a faulty mobo.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...