Direct3D Problems in Win2K, not in Win98

By Per Hansson · 42 replies
Jun 19, 2002
  1. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Well as I said I changed nothing, on the morning it worked on the afternoon it didn't...

    My PCI bus is within spec (FSB=133)

    Altough now it has stopped... Go figure ;)
  2. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Just tried out the DirectX 8.1 hotfix to no avail...

    For the ones of you interested here is the info:

    As you know I'm running Win2K and this fix is for the english version of WinXP but I just took the d3d8.dll file and overwrote my current one and tried it out, it didn't work...

    Here is a pic which atleast proves that the file was in use:

    (The problem was exactly the same as before, no change at all...)
  3. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Today I tried this: Install Win2K, install ATI drivers 6071 WHQL i.e. what this means is that I'm using DX 7.0

    Running Max Payne or any other DX 8 game was imposisble since they requier it (wouldn't even start)

    But I tried UnrealT and that worked fine in D3D (It is a DX7 game)

    I then tried it in the config I have now with DX 8.1B where nothing seems to work but it worked there to...

    I'll make a list of games that work and not after I've gotten myself some sleep.

    Although for now this appears as some kind of DX8/8.1 bug...

    What is the ver of DX after 7.0, 8.0? if so where can I download it?
  4. JAV

    JAV TS Rookie Posts: 210

    You can try here, but I don't know if the files/dl's are still active.

    Got a game from 2000-2001 that has DX8 included with it? Seems I have a few that gave me the option to install it when I installed the game, but I already had it installed. :cool:

    Good luck, get some sleep & save the $400 'til this is figured out. ;)
  5. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Diablo1: works (DirectX3 game)
    Startcraft + SC BW: works (DirectX5 game)
    Settlers3: works (DirectX6 game)
    C&C: Tiberian Sun: works (DirectX6 game)
    SIN: works (DirectX 6 game)
    NOX: Works (DirectX7.0 game)
    Diablo2 + LOD: FAILED! (DirectX7.0A game)
    Need For Speed: Porsche 2000/Unleashed: FAILED! (DirectX7? game)

    Well, this pretty much says it all...

    Microsoft implemented something really bad in DX7.0a which wasn't there in 7.0, if anyone knows of a place that lists everything Microsoft fixes between the different service packs don't hesitate to tell me!

    This test was done on the rig which I have had problems with all the time, nothing was changed before the games where run...

    And sound still hangs after a while, probably a DX7.0A+ bug too...
  6. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Can anyone answer to the post above?
    I tried another approach today: Go completely beta

    Installed WinXP Pro, DirectX 9 beta ATI 6118 leaked display drivers (made especially for DX9)

    VIA 4in1 1441 (official drivers)

    The latest Creative SB Live drivers I posted about on the homepage, the ver number has escaped me... (Has not got Microsoft WHQL certification)

    And you guessed it right the first time: The problem still persists and is exactly the same as before...
  7. JAV

    JAV TS Rookie Posts: 210

    Man, Per. You definately have patience. It is a virtue. ;)

    Maybe this is hardware related. Have you tried a GF3 or GF4 to verify the DX thoughts? I have noticed that AMD XP, VIA chips, Win XP & ATi 8500's together on one system appears to be having problems on other boards too.

    I don't link to other boards from this board because this board usually has the answers. In this case tho':

    That is 'Driver Heaven'. They have a lot of the latest & leaked drivers. The posters aren't as 'polite' as they are here, but they do have some good tech info. They aren't rude, just a little less concerned w/the language then we here are. There are a few there that are creating drivers & such. Omega & Cyborg might have good info for you.

    Maybe a search of that board or a post in the ATi section will help.

    I'll continue looking (thought you had it resolved tho') for answers & will let you know.


  8. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    I have now started a similar thread over at Driver Heaven

    I will post all user suggestions and my findings thereof in this thread also though

    If you are insterested in the post over at driver heaven that's here.

    >Have you tried it all without any VIA drivers?

    A fresh test just run of the test mill:

    Win2K (no service pack)
    No VIA drivers
    DirectX v8.1 Swedish
    ATI 6071 WHQL drivers

    Problem still the same as before though...
  9. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    "Need For Speed: Porsche 2000/Unleashed:"

    I had a problem with NFS Porche Unleashed too. I do not exactly remember how I fixed it, but I think I either disabled/enabled the W-buffer or disabled/enabled 32-bit Z-buffer support. Do this in the ATI Direct X control panel located in Display Properties/Advanced/Direct X

    Also, I can't remember if it was NFS5 or not, but enabling/disabling "Alternate Pixel Center" worked on something.. Vague memories though since I haven't used Windows 2000 in nearly a year. Come to think about it, I think that may have fixed the text in Ghost Recon on XP... OH well.

    From my personal experience, Windows 2000 does have some problems running games... However, it does play most games fine. There's clearly a higher power at work - DirectX or some sort of operating system bug. I used to play Diablo II ALL THE TIME on Windows 2000, as well as NFS5.. Both worked fine although NFS5 needed a little tweaking. (ATI Radeon 64 DDR). They also worked with my old Voodoo3.

    I haven't read all of this thread since it's a lot of reading to catch up on. ;) But normally I would say upgrade to Service Pack 3, reinstall Direct X, try different driver versions... You know the routines I'm sure. This may be a strange quirk with your system and Windows 2000.

    I remember reading in an ATI tech support forum that setting your AGP aperture to 128mb fixes some persistent issues with with the Radeon.

    Considering what you've probably already tried, this is probably rooted much deeper than just drivers. The only thing that has reminaed constant is your system and a fresh copy of Windows 2000 which means that Windows 2000 does not run properly on your system or there's some sort of hardware configuration problem that only Windows 2000 has problems with.
  10. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    The problem is the same in both Win2K Pro and WinXP Pro, since I have the Swedish version of Win2K I can't install the service pack yet (it isn't available and I found out the hard way what happens when you try with the English version; There is a language check in the beginning of the installer...)

    The same goes true for the beta service pack for WinXP, it's only available in English...

    "Alternate Pixel centre" fixes the text in some games, it has nothing with stability to do, I shall check what the other settings you posted about does... (And yes, it fixes the text in NFS5)

    The thing to remember is that I have had my computer working perfectly on Win2K, as a matter of fact this all started when I was doing a Radeon driver comparison in Win2K, and I had tested lots of games without any problems at all...

    I have tried all different ATI driver revisions out there, including the DirectX9 beta plus 6118 ATI driver made especially for DX9...

    Games which aren't DX8 does indeed work, I posted the list of them above

    And since games which are not DX8 games works I can't try the ones that are with DX7, they won't start since they check which ver of DX you have installed...

    I have tried a few different BIOS settings which could case this but nothing has helped, the thing to remember again is that it has once worked with these settings...

    All in all this can't be hardware related since everything works completely perfectly in Win98SE...
  11. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    I've been comparing these two packages side by side..
    DirectX7.0a includes files dx7migr.inf, vjoyd.n98, vjoyd.w95 that aren't included in DX7.0. I haven't noticed any other differences in .inf files; CLSIDs and stuff are similar. I'll keep looking..
  12. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Rick: I tested all the different settings you said; didn't help...
    Thanks for the heads up mic!

    Though I can't find the files, perhaps they got removed in DX8?

    Keep looking, I think your onto something here...
  13. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    hmm.. minor changes seem to be known only in some cubicle in Redmond..
  14. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Thanks again Mic, guess I'll have to hunt down the DX dev team to find out then...

    I tried to install a new BIOS now to, before I had version 7004 dated 2001/11/07, now I have upgraded to version 7008 dated 2002/04/22

    I uninstalled the ATI driver before the install and flashed the BIOS then installed the driver again so that it would detect the card properly...

    The problem didn't get solved though...
  15. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    > Digital-Overload in the Driver Heaven forums suggested that I should disable ACPI, this was my response:

    It worked!

    I used the ver of Win2K where I don't have any VIA drivers etc installed, and when I was to change to "Standard PC" I also noticed something strange, instead of being listed as "ACPI Advanced Configuration and Power Interface) PC" like all my other recent mobo's has it was listed as "MPS Uniprocessor PC"

    Well anyway I manually changed it to "Standard PC" restarted and disabled ACPI in the BIOS then brought the comp back up and everything works like a charm!

    But it couldn't be the SB Live!'s fault since I removed that completely, so this has got to be a mobo which doesn't fully conform to the ACPI spec!

    Thanks a thousand Digital-Overload for the tip, I owe you one ;)

    Stay tuned for more info!

    [UPDATE] I tried changing from the default installed MPS Uniprocessor PC, to the one I would like it to be: "ACPI Advanced Configuration and Power Interface) PC" in WinXP, and it worked! (I also re-enabled ACPI in the BIOS)

    I then went on to try the same thing in my default Win2K installation (the "work" installation if you'd like to call it that, here everything is installed, VIA drivers SB Live LAN etc, and it worked here to!!!

    My MP3 and Movie issues are also gone now!

    I assume that Win98 installs the correct ACPI layer by default so that's why it has worked...

    I'll contact FIC about this issue, stay suned ;)
  16. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    ACPI & NT5.. :rolleyes:
    The reason why your motherboard is detected as multiprocessor one is that your motherboard has APIC chip, common in multiprocessor motherboards, and thus NT assumes the board is one.
  17. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Heh, now that you mention it, there actually even is a multiprocessor setting in the BIOS...
  18. JAV

    JAV TS Rookie Posts: 210

    Glad it worked! :grinthumb

    Maybe this will help too: Some ACPI, VIA 'bug' & XP tweak info related to this topic. ;)

    Wish I'd of found it sooner, ... :blush:
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...