Direct3D Problems in Win2K, not in Win98

By Per Hansson · 42 replies
Jun 19, 2002
  1. Okay, here is the deal, after that my computer has worked completley flawlessley in Win2K for several months it has now given up on me, I was writing a ATI Radeon driver comparsion but when I came to the last driver the comp said no, read on for a more technical explanation ;)

    As I said I was running benchmarks on my computer, both Direct3D and OpenGL testing ATI's drivers, but all of a sudden Direct3D refused to work!

    OpenGL works perfectly fine, but as soon as I try to start up a D3D game the program or computer either hangs or the game is totally unplayable, like Max Payne for example, the camera "locks of" from m.r Payne and just flies around as it likes...

    Ok, I thought, I'll just reformat then, said and done, I formatted and reinstalled Win2K, only installing in this order: Win2K (obviously), VIA 4in1438(2)v(a) DirectX 8.1, and the ATI display drivers (after a while tried out several different versions with complete reinstalls of Win2K inbetween)

    And the result was exactly the same as before, D3D didn't work but OpenGL did...

    Ok I thought, nice to have a change from the hardware problems between the ATI 8500 and Epox 8KHA+ mobo I had a few months ago atleast, because this clearly has to be a software bug...

    Then I tried WinXP, installed it just as Win2K with the same drivers, same story then...

    Then I thought that it might be my DirectX install file that is corrupt so I used another one from a PC Gamer cd, same story...

    Ok, then I thoguht have I done all this I might just as well try the worst pice of *** OS over created, so I installed Win98, the VIA drivers, DirectX 8.1a and the new(est) ATI display drivers (tried old ones to) and then the darn thing worked!

    It runs Direct3D without a problem for hours!

    And now I've run into another problem in Win2K, after a few hours of MP3 playing the sound hangs...

    This problem is not there in Win98SE...

    Well well, if anyone is able to help me solve this problem I'm gonna give you a wet kiss (no wait, that was almost a threat, well I'll owe you one;))

    My hardware configuartion is the following:

    FIC AN17 KT333 mainboard (which I should have done a review of had it not been for this darn bug...)

    256MB Twinmos PC2100 DDR-SDRAM (In the review of the Epox 8KHA+ mobo I brought this memory to 185mhz at fastest memory timings...)

    AMD Athlon XP 1700+ Palomino CPU (green cpu package; like it matters :D)

    Built by ATI, ATI Radeon 8500 RETAIL 275/275 core/mem clock speed

    SB Live! 5.1 soundcard connected to a DTT 3500 speaketr system via the digital output...

    Realtek RTL8139A LAN card

    Dual Maxtor D740X-FDB 20GB HDD's connected to the onboard Promise RAID controller in RAID-0 mode

    Pioneer 16X DVD player connected as lone master on the mainboards IDE connectors...

    1,44mb floppy

    Enermax 430w power-supply

    The CPU and GFX card are watercooled, the watercooling for the GFX card is made by me tm with the help of a CNC mill...

    All this is inside an ugly midi tower Aopen ATX case from 1463

    oh, almost forgot, the mouse is a $ Explorer Intellimouse (first one, not 3.0...) sitting ontop a RATPADZ mouse-pad ;)

    The keyboard has been bought at a supermarket about 50km from here called Ge-kås (just testing if you are reading this:D)

    Yea, that's right, I'm looking at something to, they say it's a Eizo Flexscan F57 17" monitor, yup, an old trusty CRT monitor ;)

    Yea right, there is also a flower standing quite colse to the computer, might that be the cause of my problems perhaps?
  2. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    At first I would've said to try the SP2 for Win2K which solved many D3D problems but I don't see why it wouldn't work with WinXP.
  3. JAV

    JAV TS Rookie Posts: 210


    Hmmm. Win 95 & then 2K are the worst OS's ever made. 98SE is a jewel in comparison. You proved it. he he ;)

    I *think* SE is detecting the right card & driver for it, but W2K is installing the 'defaults' for Win & that is your problem.

    Go into device manager & remove all the 'default' monitors you have there. Re-boot. If Win detects new hardware on re-boot & re-installs the 'default' monitors > disable them.

    'Start'> 'run'> 'dxdiag.exe' > test Direct 3D (DX) & it should work. If it doesn't: look at the vid card RAM #. Is it the same as the card has? If it isn't: it's reading a 'default' monitor on the default VGA (Win) driver & isn't using the ATI/VIA driver. Disabling the (virtual)monitor should allow the correct (real) monitor to work w/the correct DX/3D drivers you're installing.

    Hope this helps,
  4. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Didou: I have tried with SP2 also, just forgot to mention it...

    JAV: I wouldn't go as far as to call 98SE the best OS ever, anything not being named 2000 from MS in my humble opinion just sucks...

    Win95/a/b/c Win98/SE WinME, just the same piece of ***...

    Win NT4, a good beginning, Win2K=The perfect OS, WinXP, see the *cough* advancment above *cough* i.e. XP=The beginning to the end;)

    Well, back to the problem, As I said the card has worked perfectly flawless in Win2K for a long period before, so it can't really be a setting since I have used the same settings as I always do when I reinstall...

    Which I might add I have to do quite often when testing new drivers...

    It's only in Win98 the "default" monitor is listed (along with the actual one), in Win2K it's just my Eizo monitor that is listed...
    And after all OpenGL does indeed work, it's "just" D3D that doesn't...

    If I run the dxdiag D3D test in Win2K I get no errors reported and the tests run by perfectly...

    I didn't quite understand your last advice you posted, care to explain?

    Thanks for your taken time, much appreciated!
  5. JAV

    JAV TS Rookie Posts: 210


    It was meant as a suggestion. 'Advice' implies expertise & liability attaches to that. I'll have to watch my phrasing in the future. ;)

    I recently de-fragged in safe-mode. 98SE installed a 'default monitor' & the VGA driver to run the 640x480 16bit display. When I returned to 'reg mode' all looked the same (desktop @ 1024x768 & 32-bit) but I was still on the 'default monitor' & the VGA driver.

    The VGA driver ran OpenGL, but wouldn't run a DX game. That is when I found out I was on 'default'. Doing what I suggested, fixed the problem. Shaft (CPU bottlenecking?) also experienced it & disabling the 'defaults' helped him too.

    I searched the internet & found another board where people are experienceing the same thing. OpenGL works, but DX/D3d doesn't. No solutions: so I'm offering this to try. :D

    You seem to be experiencing the opposite: no default on the OS that doesn't work & a default on the OS that does: rather than many 'defaults' that don't have DX/D3d support. I'm thinking that your default DOES have support & the Eizo is w/o. That would explain the problem in W2K & not in 98SE.

    Have you checked in Device Manager> properties to see which drivers are installed for the 'graphics adapters' for the card under each OS? Maybe 'update driver' & point it in the direction of the files you want it to use? :cool:

  6. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Yup, I have also whitnessed 100% CPU usage for no appearent reason (in Win2k..)

    Your conclusion seems quite possible, I'll look further into this, thanks!

    The card is using the drivers I install for it... (I verify it by checking the version number of the ati2mtag.sys file listed there...)

    Again, thanks for your advice!
  7. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    First I tried to remove the Display driver (deactivate was unavalible)

    Didn't help, so I reinstalled the driver and changed it for Plug and Pray monitor, though with the same result as before:(
  8. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217


  9. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    If we attack this problem from another angle; How can OpenGL function when Direct3D does not?

    What kind of different ways etc do they use to render, in short:

    How the h** can OGL work but not D3D???

    Please impress me with your expertise now and help me solve this problem

    (Remember: In Win2K OpenGL does function flawlessly but D3D does not, though with the exact same hardware and software configuration both D3D and OGL work in Win98SE...)
  10. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Have you tried other DirectX versions?
    Sorry but I can't help much - I haven't been using D3D for ages and most likely I won't be, either.
  11. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    The installer for the ATI Radeon 8500 says that you should install DirectX 8.1 or later since the card itself is a DX 8.1 product...

    So, my answer is no, I have only tried with v8.1 of DirectX...
  12. MrGaribaldi

    MrGaribaldi TechSpot Ambassador Posts: 2,512

    Per, M$ just released DX 8.1b...
    I'd guess it won't make any difference, but still...
    You can pick it up here

  13. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Well *cough* yes Mr.G I saw that file before to, but when I took a look at the filesize (25mb) I thought I'd spare my old trusty 56k modem the trouble but well, alright, I'll download it :)
  14. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    If that would mean it wouldn't work without DirectX 8.1, it wouldn't work in DOS or Unixes either.. :rolleyes:
  15. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    My software configuration is now:

    VIA 4in1 4.40v(a)p3
    DirectX 8.1B

    Though the problem is the same as before ;)

    I'll fiddle around with the hadware now and see what I conclude on, watch for an update in a few hours.
  16. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    I just think I might have figured out what this problem is all about now:

    When the problem started I had done two things: One is install the waterblock on the GFX card which couldn't be the cause of my problem since everything worked in Win98...

    The other is set up my RAID setup and I didn't think that could be the cause of my problems either since that is purly a hardware thing to (the OS isn't even aware that it is saving files to two different harddrives, the controller chip takes care of that...)

    But then it struck me that it might be a bad driver for the RAID controller that is causing this, i.e. for Win98 the driver is mature enough but not for Win2K...

    I'm looking further into this right now as I write...

    I came to this conclusion when I started up the dxdiag test program went to the music test and in Win2K the music stopped after just a few seconds but in Win98 it just kept on playing...

    That led me to the conclusion that it can't be a hardware problem...

    _roger and out
  17. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    In order for me to be able to use a new(er) driver for my RAID controller it's BIOS must be updated to a more current version.

    Unfortunantley FIC hasn't released a single BIOS update since it's release, so to say the least "I'm on my own" here...

    I sent this mail to Paul at VIA Hardware but if anyone here thinks they can help me be sure to reply:

    Subject: Problems merging RAID bios with mobo BIOS

    Hi Paul, I'm an editor for, recently I
    was sent the AN17 mainboard from FIC, unfortunately
    the mobo uses a quite old BIOS for the built in RAID
    controller which I would like to update (FIC hasn't
    released a single updated BIOS for the AN17...)

    I used the following procedure:

    1. Copy the original BIOS from the flash chip to a

    2. Used CBROM to release the current RAID BIOS in that
    file (CBROM AN17.BIN /ncr release | Option "B": PCI
    RAID BIOS...)

    3. Copy the new RAID BIOS into the file (CBROM207.EXE
    AN17.BIN /PCI raid.bin) (original name of the RAID
    bios was ft100B24.bin)

    4. Flash the mobo with the new BIOS, just Flash810
    AN17.BIN, but then I got this error message: Unknown
    flash type"

    I was hoping you would know what this means and
    perhaps be able to help me solve this problem...

    The built in RAID controller is a Promise Fasttrak100
    "lite" controller, the BIOS I wish to use was
    downloaded from their site...

    Sincerely - Per Hansson, editor @
  18. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Hi Per,

    I never normally bother with the "release" step, just do "CBROM207.EXE
    AN17.BIN /PCI raid.bin". However, I can't think that this would cause
    problem. That said, I've never done this with the Promise controller,
    the Highpoint. The Highpoint only comes in one flavour - there is no
    version. Could your problem be due to using the wrong Promise BIOS?
    unknown flash type error can occur if you are using an old version of
    AWARD flash program too - try updating this (although if it works with
    non-modified BIOS, I doubt this is the cause).


    Subject: Re: Problems merging RAID bios with mobo BIOS

    > Hi again Paul and thanks for your very fast reply!
    > If I don't use the "release" step I get this error
    > message: AN17.BIN have not enough space for adding
    > ROM. (Over 925Bh bytes)
    > Where exactly do you find the most recent Award
    > software? I've looked around on the net for a while
    > and the newest I could find was 7.97D, though the one
    > included on the CD with my mobo says it's v8.10!
    > So, does Award have a site where you can download the
    > newest version of their program or do they only
    > release it to mainboard manufacturers?
    > I'm quite sure that I am using the correct RAID BIOS,
    > though as you say Promise really has a whole load of
    > different BIOS'es for their different cards.
    > Though there is a quite easy way to verify this, I
    > just don't know how to extract the RAID BIOS from the
    > mainboards BIOS, if you could explain how to do that I
    > could look up the same file on Promise site and do a
    > CRC check between them to see if they are the same.
    > Sincerely - Per Hansson, editor @


    To extract the BIOS use "cbrom207 biosname.bin /pci Extract"

    The space error is very odd - never seen that before. CBROM207 just
    overwrites the existing Highpoint BIOS when I use it. ABIT are
    shipping AWDFLASH 7.97 with their BIOS's too, so I guess this is the

    Good luck!



    Hi again Paul, it seems that the BIOS I was trying to
    flash infact was the wrong one.
    Atleast that is what it says on Promise site...
    (i.e. that the PCI cards use different BIOS files than
    the ones built into the mainboards...)

    Sincerely - Per Hansson, editor @


    I've sent mail's to both FIC and Promise asking them if they can supply me with the latest BIOS for the Promise RAID adapter, we will see how that goes...

    But I can also do this another way, here is a list of mainboards with the Promise PDC20265R RAID controller chip.

    If you happen to own one of those could you check when the PC boots which BIOS revision your RAID controller has?

    Because if it's newer than mine I can just as well use yours...

    * ASUSTek: A7V133, TUSL2, P4B-E, ¡K

    * Acorp: 6A815ED, 6A815EPD, 815EPI, ¡K

    * AOpen: AX37Plus, DX34R-U, AK77 Plus, AX3S Max, AX3S Plus, ¡K


    * DFI: AD70, NB72, NT70, NB75, WB72, ¡K

    * ECS: L4S5A, K7VTA3, P4VXAD,¡K¡K

    * EpoX: EP-D3VTA, M815B ¡K

    * Giga-Byte: 7ZXR, 7DXR, ¡K

    * JETWAY: I401-R, 866AS-R

    * LUCKYSTAR: P4A8455

    * MICRO-STAR: 845 Pro-2, K7T266 Pro, K7T Turbo, Pro266 Master, 815EPT Pro-R, 815EP Pro, 815ET Pro, K7T Turbo Limited Edition, 694D Pro2,¡K

    * Shuttle: AE25, AV40,..

    * SOYO: P41SR, K7V Dragon, K7V Dragon Plus

    * SOLTEK: 85SD+, 75DRV2+, 85DRV

    * Transcend: PS-ABD4
  19. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Installed Powerstrip and found this:
    Look under Manufacturer and then Options

    As you can see I'm reading this information from the registery and the manufacturer of the monitor is there listed as Micrsoft!

    Guess JAV was correct after all!

    Though when I downloaded a new monitor driver from Eizo's site and installed it everything looked correct in Powerstrip but Direct3D still didn't work...

    Dunno what to think, it seems quite probable that this is the cause of my problem but then again why didn't it help when I changed the driver?

    Post ideas, thoughts, comments and spam below;)
  20. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Just tried something new, removed the RAID array and put a lone harddrive on Primary Master on the mainboard’s IDE controller.

    Installed Win2K as I have described above and the problem was still there!

    So this puts my idea about that it should be the RAID controller causing the problems to an end to…

    Also I went into safe mode to change the monitor driver, though that was impossible …

    I did change it in Win2K though and Powerstrip reported the monitor as manufacturerd by Eizo but the problem was still the same though :(
  21. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Got this back from Promise Taiwan:

    Sorry we only release Smaraid bios to M/B manufacturer.
    v is newest version right now.
  22. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    This is just so wierd, I played MP3 in Win98 yesterday, 8 hours without problems!

    And in Win2K it hangs within an hour!

    I also played an OpenGL game in Win2K and the music hanged after a while then to...

    Though in Win98 I can play forever, and that is exactly what I'm going to do now; got myself a copy of Warcraft3...

    I've been tired long enough at this now so at the end of this month I'm changing my SB Live 5.1 for an Audigy, FIC AN17 mobo for a Epox 8K3A+ and my ATI 8500 for their "R300" / 9700 (if it's avalible then)
  23. JAV

    JAV TS Rookie Posts: 210


    Enjoy WarcraftIII on 98. You deserve a break. :D
  24. Per Hansson

    Per Hansson TS Server Guru Topic Starter Posts: 1,959   +217

    Heh, now on top of all the problems posted above I've also got crackly sound added to the list, it started this afternoon, after changing absolutely nothing with on the comp...

    (This is in Win2K, haven't tried Win98 yet...)
  25. JAV

    JAV TS Rookie Posts: 210

    PCI is prolly too high. Does that to me too when I go over 36.3mhz on it. ;)

    Check the divider for it in conjunction w/the FSB setting. 133FSB is 1/4 divided, 166 is 1/5 etc. for each 33mhz jump on the FSB.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...