Drive is not Recognized

By TimeTrek
Jan 12, 2009
  1. I have a problem with my 160G Seagate drive. I recently decided to buy a 500G drive and proceeded to ghost my 160G to the 500G. This works and my 500 is up and running fine. There was nothing wrong with the 160G except not enough space. I bought a SATA to USB enclosure and popped the drive in it and the system refuses to see it. It shows up in Device Manager as a the correct drive and it also shows up the correct Mass Storage Device under USB but nothing under Disk Mgmt and/or Explorer, etc. I can put it back into the laptop (single drive laptop) and boot off of it so I know the drive is good.

    I did boot off of it and did a clean install of XP on it and to test the enclosure I put the 500G in it and the system picked it up so I know the enclosure is good. I also have two other externals and I also used them in this enclosure and they were picked up correctly.

    I swapped the drives again putting the 500G in the laptop and the 160G in the enclosure. I can pick up everything except the 160G. I cannot even see the partition using any number of utilites (active partition, testdisk 6, etc, etc.). Well you get my drift.

    I tried it in other computers but it won't pick up the 160G. I retested the enclosure by trying out the other externals in this enclosure and they all work fine and I can use the other drives in this enclosure. I tried the 160G in the other enclosure for the other externals and same problem.

    Now the weird part is I can stick the 160G back in the laptop and pull out the 500G and it will boot up into Windows XP and when I run the utilities (active partition, testdisk, NDD, etc,etc) the drive is as healthy as can be. I have even run numerous diagnostics and the drive is healthy. When I proceed to make it an external, with the 500G as the laptop bootable drive, it does not show up..

    I have tried everything and searched the web for a solution but most of threads they have Disk management pick up the drive but not assign a drive, While my problem has it where device manager is the only one that picks it up and disk management and/or explorer does not.

    I hope this is not too lengthy and I apogize if it is. I just need a little help, maybe it could be a registry setting.

    I have a XPS 1710 w/4G ram. Everything works fine except this drive as an external.

    Thanks for anyone that helps me.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Try removing the 160Gig partition (ie not just format, but totally remove the partition)
    This may need to be done when you can see it obviously (ie either in a Desktop computer using an adapter or mounted back in the laptop)

    Of course you will lose all info (data and system files on the 160Gig)
    But it's worth a go ;)

    You would need to set it back up in Disk Management (whilst connected as USB, with no Partition) once all done

    Try that :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...