Dual Boot Laptop only loads GRUB cli.

By matulike ยท 8 replies
Aug 20, 2006
  1. Hi,

    I have just completely reinstalled my laptop after problems with dual booting before (using Norton Partition Magic). I reinstalled XP - after creating 4 partitions on my 40GB laptops drive:

    7GB NTFS Windows
    5GB EXT2 Linux
    500MB SWAP
    25GB FAT32 - shared data storage for both OS's

    I installed XP, all fine, then installed SuSe 10.1, also all fine.

    Booted to both (via the SuSe loader) (Windows is just another option). Updated both, and had bit of play around...didnt change anything thogugh, only really installed a few apps on the windows install.
    So, anyway, now when I start the laptop it just comes up with:

    GNU GRUB version 0.97 (636k lower / 1039174k upper memory)

    [Minimal BASH-like line editing is supported. For the forst word, TAB lists possible command completions. Anywhere else TAB lists the possible completions of a device/filename. ]


    And that's it.....now I really have no clue where to go from here>?! I know you can edit the grub config - maybe that;s why it['s not booting the OS....
    I didnt use any other boot loader as this did the job fine before...
    Any ideas? Even how to check the config?

    Thanks in advance.
  2. matulike

    matulike TS Rookie Topic Starter

    OK, I've looked into this a bit, and it seems there's some bad config in the grub.conf file.
    So, I tried to load the kernel:

    root (hd0,6)
    kernel (hd0,6)/boot/vmlinuz

    And it loads the kernel but it fails to mount the root.

    The actual error is:

    VFS: Cannot open root device "<NULL>" or unknown-block(8,6)
    Please appeand a correct "root=" boot option
    Kernel panic - not suncing: VFS: Unable to mount root fs on unkonwn-block (8,6)

    HELP!! :eek:(
  3. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You have to tell the kernel where the / filesystem is. Also, you may have to load some drivers before "boot". Try something like this:
    root (hd0,6)
    kernel /boot/vmlinuz root=/dev/hda5
    initrd /boot/initrd
  4. matulike

    matulike TS Rookie Topic Starter

    OK, will try that. Managed to boot SuSe using the installer DVD, and will try to fix GRUB with that too - I copied out the grub.conf and /boot/grub/ directory. I would like to know what is wrong with the config file - as I didnt change it and it booted fine the first few times to both OS's.

    If it's simply a case of misconfiguration then updating/replacing GRUB seems a bit like overkill - and also wont teach me to fix config problems myself...

    I dont have the files with me, but when I get home I could post the .conf file if anyone could explain what might bewrong with it+how to fix - that'd be great :eek:)
  5. matulike

    matulike TS Rookie Topic Starter

    I keep getting an error when I try to reinstall it! :eek:(

    Error 21: Selected disk does not exist
    grub> install --stage2=/boot/grub/stage2 /boot/grub/stage1 d (hd0,6) /boot/grub/stage2 0x8000 (hd0,6)/boot/grub/menu.lst

    Error 12: Invalid Device requested
    grub> install --stage2=/boot/grub/stage2 /boot/grub/stage1 d (/boot) /boot/grub/stage2 0x8000 (hd0,6)/boot/grub/menu.lst

    Please, please help!
  6. matulike

    matulike TS Rookie Topic Starter

    Here is how the config file looks:

    # Modified by YaST2. Last modification on Mon Aug 21 20:54:15 BST 2006

    color white/blue black/light-gray
    default 0
    timeout 10
    gfxmenu (hd0,6)/boot/message

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title SUSE Linux 10.1
    root (hd0,6)
    kernel .boot/vmlinuz root=/dev/hda7 resume=/dev/hda6 splash=silent showopts
    initrd /boot/initrd

    title Windows
    chainloader (hd0,0)+1

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- SUSE Linux 10.1
    root (hd0,6)
    kernel /boot/vmlinuz root=/dev/hda7 showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
    initrd /boot/initrd

    If anyone can tell me how this SHOULD look, or what might be wrong, I'd really appreciate it ;o)

    It worked, I didnt change anything, I rebooted and then it didnt work!
  7. matulike

    matulike TS Rookie Topic Starter

    Basically I just need to know where to put the boot loader (/dev/hda?) or on the Linux partition? And should I replace MBR with generic code and activate partition?

    For SUSE it has Image/Device: /boot/vmlinuz (/dev/hda7, root=/dev/hda7)

    Could a Windows update have screwed this up??? I saw that SP2 could mess it up on another forum...I cant see it myself, but gotta ask ;p
  8. matulike

    matulike TS Rookie Topic Starter

    Just so it's written down :p here';s the /etc/grub.conf too:

    root (hd0,6)
    install --stage2=/boot/grub/stage2 /boot/grub/stage1 (hd0,6) /boot/grub/stage2 0x8000 (hd0,6)/boot/grub/menu.lst
    install --stage2=/boot/grub/stage2 /boot/grub/stage1 (hd0) /boot/grub/stage2 0x8000 (hd0,6)/boot/grub/menu.lst

    And /boot/grub/device.map:

    (hd0) /dev/hda
  9. matulike

    matulike TS Rookie Topic Starter

    Reinstalled SuSe - fixed it!

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...