DVD Drive not working after re-restore

Apr 27, 2008
  1. Hi all,

    I am new to the forum, this is my first post, I hope you are all well.

    I have a Toshiba A55 Satellite, bought in 2004, runs XP Prof and so far have had no major problems. Yesterday I tried to resolve a minor issue by restoring my laptop to an earlier position, and I have unleashed chaos!
    I have managed to fix the majority (mozilla and IE I had to reinstall as the file location / path was lost) and programs I uninstalled before the "restore" are now kind of back but unfunctional, and I cant uninstall them. My main problem is that my DVD /CD ROM is not working anymore............

    It is a TEAC DV-W24E. In the device manager, a yellow circle with a ! in it appears. I have tried installing the driver, and I get the following message:

    Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

    Troubleshoot does not help!

    If anyone has any suggestions about how to fix this, I'd really appreciate it.

  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    You are missing a critical driver install... most likely the Chipset drivers... which you can find at the Toshiba Tech support site.
    Can you get online with the Toshiba.
    Your Device Manager will give you some clues (Start -> Control Panel -> System -> Hardware -> Device Manager)
    Look for yellow or red flags. They will delineate the problem. Then you can find eth appropriate drivers at www.Toshiba.com

    You will obviously have some difficulty getting it up and running... But if you are able to access your USB port, you can download the driver to a flash drive and install it that way.
  3. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    If your original "minor issue" can be resolved in a different manner, you could consider undoing the system restore. That should get you back to where you were before this trouble. If you tried this already, it wasn't clear to me.

    RUBANSKI TS Rookie Topic Starter

    Thanks folks. Tried both methods, the driver re install didn't work, so I restored it back to a previous date and sure enough, it worked. Cheers for your suggestions. All the best.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...