Tech Stocking Stuffers: 18 awesome gifts under $50

ECS x58-a2 motherboard with i7-920 processor

By skid ยท 5 replies
Jun 1, 2010
  1. I recently bought a ecs motherboard X58-A2 and installed a Intel i7- 920 processor with 6GB of Crucial DDR3 PC-8500 ram. Installed windows 7 and it booted up fine, but it apears to be extremely slow, my dell duo core far surpasses this thing. Now I have been trying to update the BIOS and when I restart to install the update, it takes a good 15-20 minutes to install windows, and then it goes to a black screen with the mouse curser as the only thing on the screen. What is going on..... is this a bad processor, memory, HHD, or MOBO.Can some one please help.
  2. slh28

    slh28 TechSpot Paladin Posts: 1,706   +172

    First of all double check that everything is installed correctly, e.g. the heatsink in on properly, RAM modules are pressed in firmly, all the cables are plugged in and have a browse through the motherboard's manual because tbh I've never really heard of ECS.

    You could also try booting with another hard drive if you have one, if that's from your old computer then maybe it's dying.

    Out of interest did you fresh install a copy of Windows 7 and how did you go about updating the BIOS?
  3. skid

    skid TS Rookie Topic Starter

    Everything is new HHD mobo and processor, memory and clean install of windows. thing is I can't update bios because, when I install the bios I get message that states the update is not for that OS. So No I am using another OS disk to see if that will fix the problem. I have use the OS disk to install Windows 7 on three other computers, so I am not sure if that is the problem. But this is the first time I have tried to do a X64 install with it. It is supposed to be a x86 or X64 Windows 7 ultimate.
  4. Ritwik7

    Ritwik7 TechSpot Chancellor Posts: 1,672   +9

    When you say slow, could it be some energy saving feature kicking in? I know AMD has "Cool And Quiet". Not sure about Intel though. But if there is one, disable through BIOS.
  5. dividebyzero

    dividebyzero trainee n00b Posts: 4,891   +1,262

    The boards BIOS can (and should) be updated outside of the OS enviroment.

    If your BIOS isn't 10/02/08 then I'd download from it from ECS here
    If your BIOS is not this revision then...
    Click the "download" tab and select the BIOS radio button.

    They mention something called eJiffy -which sounds like either an in-OS BIOS flashing tool of a relative of the ShamWow. I don't think I'd recommend either.

    Download this pdf from ECS on how to flash your BIOS using a USB flash drive - unless you have a floppy drive that you're keen to run it from.

    The procedure is fairly straightforward (in theory). Post back if you have any questions regarding the flash, if the flash doesn't fix the problem, or if it does for that matter as you could be helping someone else who views the thread and has an ECS motherboard.

    My first impression is that the BIOS probably needs updating. Also update the other drivers (Download -> Drivers radio button -> Chipset Driver, LAN Driver, Realtek sound driver).
  6. skid

    skid TS Rookie Topic Starter

    problem solved

    it was the bios after all. it just took me forever to find a way to format a usb drive for boot. and then i kept typing the wrong instructions once i got to the afudos. thanks to all for your help.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...