Emachine T5088 motherboard problem!

By Kinetron ยท 8 replies
Apr 15, 2010
  1. I have an Emachine T5088 that screen went black! Swaped monitor, no signal! Replaced PSU with 500W, battery, HDD, and battery! Monitor lit and saw Emachine splash , but nothing else happened! Turned off and back on after 30 seconds while listening to HDD! It spun up but no attempt to boot! Not even the splash the second power up! Gues its the MBO...any suggestions on buying a replacement? Someone said a genuine exact replacement will circumvent buying a new OS!
    Any Help will be greatly appreciated!
    Jim G
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    The motherboard is fried. Buying the exact motherboard will be expensive, and doing this, may or may not require you to buy a new OS install disc

    This looks like a good deal:
    eMachines Motherboard replacement
  3. Kinetron

    Kinetron TS Rookie Topic Starter

    I checked it out....its a great replacement since I have all the other hardware!
    Thanks again for your help!
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Okay Jim,
    yes, I was surprised at this deal too. I'm going to keep the link for my repair work
  5. Kinetron

    Kinetron TS Rookie Topic Starter

    Hello everyone! I am back with the rest of the story! I installed an exact replacement MBO and CPU! Now the only "old part" is the cd player! The unit fired up and booted in safe mode! I was happy since the OS was intact and operational! Then screen went black! Figured HDD was bad so got a new one and installed! Fired up and stopped at the screen asking to choose boot options or bios options! Then screen went black, Monitor indicated no signal! After that, never got a signal to monitor! I am baffled! DidI fry the MBO or CPU? Any suggestions? I am having the exact same problem as when I started! Black screen! It doesnt make sense....does it to anyone out there?
  6. Kinetron

    Kinetron TS Rookie Topic Starter

    Installed the new supposedly exact MBO....same issue!

    I purchased a new MBO and CPU combo, purportedly the exact replacement! Since I already have the new HDD, PSup, memory etc, Using the orig HDD, I fired it up! It booted in safe mode to the desktop! Then it stopped! Only message on the way up was it recognized that I had replaced the CMOS battery. It paused briefly and continued to a clean boot, or so i thought! I shut it down, tried to reboot, nothing....no splash, no monitor signal! This is the same action as the broken MBO/CPU that was replaced! There is no other old parts except DVD, which I disconnected and bootetd to no avail! Is it possible the MBO fried too? So far I have new MBO, CPU, Memory, Psup, power cable, USB mouse and Keyboard, which worked on first boot! I am baffled! Any suggestions other than buying a new PC?
  7. Kinetron

    Kinetron TS Rookie Topic Starter


    I also installed new Sata drive, and tried to boot from CD! Nada!
    Thanks again
  8. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    If you can get back into the BIOS, you need to adjust the settings to duplicate what the old motherboard's BIOS was set to. If you have SATA drives, for example, the original mode for the SATA controllers might have been set to AHCI/SATA or maybe IDE. Whatever it is set to now, set it the other way and see if Windows will start. If you are having trouble getting into the BIOS due to no start/blank screen, try removing the CMOS battery for a minute or so and replacing it.
  9. seanc

    seanc TS Rookie Posts: 88

    Umm, have you eliminated the monitor as being a problem?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...