Epson wireless printer cannot be found by my PC

Im not super tach savvy so need help - please guy. Upstairs laptop cvan detect and print to my WF2750 printer. Desktop PC which is literally next to the printer cannot detect it. Epson online help after one hour said it must be my ISP and so was not their problem. Ping test from PC to router and PC to printer shows a general failure. PC has fibre connection. PC and printer are connected to same router. I have tried both usb and wifi connection from Printer>PC and still the PC cannot find the printer. Any ideas ?
 

Gabriel Pike

Posts: 240   +62
If you can't ping it then there is your problem. There must be network connectivity to be able to communicate. Perhaps the fiber network is not the same as your network that the printer is on?
 

bazz2004

Posts: 1,736   +290
We've had similar issues with wireless printers. They can work great for months and then they cannot connect. I used to reinstall the software but have since bought a usb cable for our Epson XP-55. It works fine and we can print with it from other computers.

Sorry, I just read that the usb connection isn't working either. Try uninstalling everything connected with the Epson printer software and start again to set it up for usb. If that doesn't work there may be an issue with the printer.
 
Last edited:

Kshipper

Posts: 523   +116
TechSpot Elite
I do IT and this can be a pain. More then once I have 'almost' told the customer: "You need a new printer". Deleting any and all Epson software on the desktop is a good start. When you reboot and retry installing the Epson software pay particular attention to the setting where it asks if you want to install WIFI or USB. Choose WIFI. It may ask you to connect the printer to the desktop via USB so that it can tell it what network the desktop is on. If the USB part of the printer is broken, there might be a way to enter the WIFI settings on the printer directly via a panel on the printer?.
 

bazz2004

Posts: 1,736   +290
The printer is right next to the PC so I’d recommend usb rather than wireless. It’s far more dependable too. There are occasional revisions of Epson printer software so it’s worth going to their site for a download. On occasions it can be a challenge to remove the Epson software completely.
 
Guys - thank you for all of your responses. I have tried all the things you suggested and none of them work. I have instead used my laptop , which accesses the printer by WIFI and also can print directly to it, to re-register the printer to Epson online, and re establish cloud access by e-mail and cloud scanning from the printer. The email works from the Desktop but I cannot print to it directly from the desktop, even now. I've tried USB, WIFI , re installing all software. Powering down all devices...you name it. Totally illogical as this desktop used to print to it directly and now cannot even see it. I don't fully understand what a ping test is, but I do understand that this seems to be where the failure is occurring, even though both printer and desktop are connected to the same WIFI router with the same log in passwords.What really spooks me is that direct access by USB connection to back of desktop does not even show us as a device connected. I have tried 2 diferent ports (both work with other devices) and swapped the fire wire lead . Im afraid to say it has totally beaten me :)
 

bazz2004

Posts: 1,736   +290
Apart from trying to install it via Windows 10 Settings rather than the Epson software I'm out of ideas. If you find out what's wrong please post about it.