Error: "Invalid IP address"

By Bealsebub
Jul 6, 2008
  1. Hello,

    I need a little help. Short story: I spilt some soda on my laptop last week and now, not only do I have non-functioning keys, but for some reason, it won't log onto the internet. The connection status tells me that it's aquiring network address but there's no activity. Under the Support tab, it says Invalid IP address.

    Under START > RUN, I typed in ipconfig /all and this is what it brought up:

    Microsoft Windows XP [Version 5.1.2600]
    <C> Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\Mr. B\ipconfig /all

    Windows IP Configuration

    Host Name: DAN
    Primary Dns Suffix:
    Node Type: Mixed
    IP Routing Enabled: No
    WINS Proxy Enabled: No

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix:
    Description: Realtek RTL8139/810x Family Fast Ethernet NIC
    Physical Address: 00-E0-B8-70-AE-D4
    Dhcp Enabled: Yes
    Autoconfiguration Enabled: Yes
    IP Address:
    Subnet Mask:
    Default Gateway:
    DHCP Server:
    DNS Servers:

    Ethernet adapter Wireless Network Connection:

    Media State: Media disconnected
    Description: Intel<R> PRO/Wireless LAN 2100 3B Mini PCI Adapter
    Physical Address: 00-0C-F1-0F-36-21

    C:\Documents and Settings\Mr. B>

    Yes, I had to physically retype all of that. Good times.

    Any help is appreciated. I definitely ant to get my internet back up and working before I deal with the non-functioning keys.

    I am using a router and I have alreayd tried connecting right to the source cable from the modem. Still no dice.

  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Fix the hardware (keyboard) then fix the software.

    You could try this:

    Open Notepad and cut and paste the following and save as Flush.bat then run it;

    ipconfig /release

    ipconfig /flushdns

    ipconfig /registerdns

    ipconfig /renew

    netsh winsock reset catalog

    netsh int ip reset reset.log

    netsh winsock reset
  3. Bealsebub

    Bealsebub TS Rookie Topic Starter

    Hey, I'm back.

    I tried the flush.bat, but no go. Still no IP address.

    Any other thoughts?
    This is a very weird side affect from a beverage spill. Isn't it?
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Replace the network cable, or clean the actual network connection in the laptop (probably the fault I'd say)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...