1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

"Error Loading Operating System"

By JoshuaGenubath ยท 15 replies
Jun 16, 2009
  1. Ah, yes a classic problem,
    one goes to boot up his computer and upon trying to load windows, is confronted with a message : "Error Loading Operating System"

    I was fairly consternated when this happened to me.

    Having this problem for some time I have been able to do a bit of research on the topic.
    This problem most often will occur when one is trying to install a new OS, the message will appear during the reboot portion of setup.
    I, however, had been running this system two years with no prior problems.
    When this was the case, for other people, the HD was often corrupted, damaged, old. After running several scans on my HD, I ruled out this possibility after failing to find the slightest error.
    Going on the possibility that the Windows installation may be corrupted (Note: I can boot Windows off a floppy disk, made to boot Windows XP) i tried the FixBoot and FixMBR functions on my install disk. No luck.
    I installed a working version of BartPE on my HD, and I got the same result when I tried to load that instead of Windows, this makes me think that the problem is not with the Windows installation.
    Just to be on the safe side though, i did a repair installation of Windows, no luck, upon restart I was confronted with the same message.

    Well, I figured, the problem must be with the BIOS. So I flashed it (the equivalent, in this case, of replacing the current BIOS with an updated version). Well, the new version came with a nice menu for booting options, but it didn't solve my problem, I still received the same error message.

    I was out of ideas until a ran across a solution. In other cases I found, the BIOS would be reading the HD with the wrong geometry. So if the HD on the BIOS was set to CHC, and the HD should be read as LBA, it would not work. I thought this must be it. I went into BIOS setup and discovered that there were two options: AUTO and LARGE. Currently it was set to AUTO. So I changed to LARGE. And.......
    it didn't work. I changed it back to AUTO, to no avail. So I removed the HD from the BIOS setup (changed IDE1 to "none")
    unable to get BIOS to register the HD again, I flashed the BIOS, again with the same version.
    It was able to recognize the HD drive like before, but still could not read off of it. I am now out of ideas, and so I am posting my problem here.

    I do not think the problem is with the installation of Windows, since BartPE will also not start. I could try reinstalling windows, but since this problem typically occurs during the restart portion of setup, and the repair install did not work, I do not think that reinstalling windows is the answer.

    I can boot off of a floppy disk that is made to boot up Windows. I did try replacing the OS files on the HD with the corresponding ones on the floppy disk, did not work.

    To be clear:

    1. I turn on the computer
    2. BIOS comes up with it's list of options (i.e press DEL for Setup, press F9 for Boot options.. etc...)
    3. The screen changes to display the system stats (IE. temp, fan RPM, etc...)
    4. Below, it starts to boot of HD, "Verifying DMI Pool Data..."
    5. It displays an error message "Error Loading Operating System"

    I am running on a Biostar GeForce 6100 M-9 Motherboard
    using a SATA2/RAID 250GB HD.
    With a Windows XP Home Edition SP2 Installation.
    BIOS Id: C51MCP51-6A61HB09C-00

    I was not sure where to post this, sorry if I mis-posted in wrong section
  2. alphnumeric

    alphnumeric TS Rookie Posts: 173

    I had that error after removing Windows 7 and trying to re-install XP Pro. I also tried the FixBoot and FixMBR functions on my disk with no luck. I deleted all the partitions and started over also with no luck. In the end I downloaded the Western Digital Tools for my drive and wrote all 0's to the drive. After that I was able to install XP again.
  3. ender

    ender TS Rookie Posts: 92


    Just trying to clear up what I understood from your post:
    - your PC will not boot directly from the hard drive
    - your PC is perfectly able to boot from anything but the HDD and will be happy to use (aka. read and write) the information stored on the HDD
    - the MBR and BIOS settings have been debugged into oblivion as far as you can tell and it's not an OS related issue

    So far so good and it'd seem that your approach is rather exhaustive and well though out. In my opinion, the most likely causes for your issue are:
    - an HDD that has issues and is about to fail
    - a faulty or improperly connected SATA cable
    - a faulty SATA controller on the motherboard

    You should be able to check the cable rather easily (simply grab a new one from a store, they are rather cheap and having a spare will definitely not do any harm).

    I'm also assuming (or rather hoping) that there is more than one SATA controller on your motherboard in which case you should be able to simply plug the HDD in a different one and see what comes of it.

    Another simple step that I'm not sure you've already taken is to download and burn a CD containing the diagnostic tools provided by your HDD's manufacturer and run their diagnostics. From the description you made it's not clear if you checked the drive using anything beyond the tools that tend to come with an OS (Windows' chkdsk or similar) or partition manager. I'm not entirely sure that all HDD manufacturers provide such tools but in case you have a Seagate drive here's a link to theirs: http://www.seagate.com/www/en-us/support/downloads/seatools. The DOS (aka. bootable CD image) is the version you want. You'll need to provide a valid e-mail address before they let you download, I think.

    If all this fails to come up with a reason for you issue zeroing out the HDD and trying to reinstall is a valid option that might work if the drive is only slightly ailing. However, I'd suggest checking out if the warranty has expired and having it sent back to the manufacturer for a diagnostic if it's still covered.
  4. alphnumeric

    alphnumeric TS Rookie Posts: 173

    In my case I ran memtest to check my RAM and it showed no errors. I also ran the full diagnostics on my hard drive and it passed. I assumed Windows 7 had done something to the boot sector that XP didn't like. The first part of the install went fine but on the first reboot (from the hard drive) I got that error. As a last resort I zeroed out my drive and was able to install XP. Just some food for thought. ;)
  5. JoshuaGenubath

    JoshuaGenubath TS Rookie Topic Starter


    In the end, I was able to resolve the problem by writing zeros to the entire drive.
    I tried replacing the sata cable, and trying it in both the sata ports in my computer.
    Additionally, I ran an extensive test provided by Western Digital (the manufacturer of my HD) which turned up no errors. As far as I can guess, somehow the formatting outside the bootsector was altered so that windows could not read the boot sector, even after being rewritten by FixBoot.
  6. ender

    ender TS Rookie Posts: 92

    Fishy behavior and I hope it doesn't happen again. I'm happy to know it's 'fixed'. :)
  7. osc2146

    osc2146 TS Rookie

    Hello everyone,

    I still have "error loading operating system" and I can't do any of the above solutions for the simple reason - I am using MacBook (a 13-inch one). I've installed XP using bootCamp and it worked neatly along with Leopard.
    However, yesterday I got some serious infection on my XP and had to do a system restore. After it had done that, none of Macbook drivers were installed. I therefore used disk utility - one that comes originally with windows - to make my Mac partition active (very stupid of me).
    After i restarted i got this damn error and I've been trying to fix it for the whole day.

    My issue is: i have no idea how to get to a bios in a Mac, before i get this error there is just a white screen.
    I cant boot with XP cd, shows press any key to boot from a cd.... error loading operating system
    When i start holding an option key it only shows the windows partition

    I know this is hopeless, but I really dont want to buy a new HDD. I would appreciate any help.

    Thanks in advance
  8. alphnumeric

    alphnumeric TS Rookie Posts: 173

    I don't know any thing about Macs but why would you have to buy a new hard drive? Buying a new hard drive isn't going to help you if you can't sort out how to boot from the CD-Rom drive. Sounds like you were dual booting and changed the active partition. Now your PC can't find the boot loader. try using that utility to change the active partition back to what it was. That or start over with a clean install, deleting all the partitions and creating new ones should fix it.
  9. JohnTheElder

    JohnTheElder TS Rookie

    Joshua wasn't the only one. I'm experiencing the same problem, and have tried the same fixes, except for zeroing the harddrive. I also replaced the existing Seagate with a new larger Seagate SATA, to no avail. Also tried replacing the Nvidia 430/410 Controller drivers, but couldn't find an appropriate driver in the Nvidia driver download (Also tried repartitioning the new drive and installing WinXP Pro instead of the old OEM WinXP Home...as a last resort, I tried installing an old RedHat-7 Linux OS.
    During the Linux install, the hard disk was deemed to be "absent", and a request for third-party dyivers ensued.
    Finally, during yet another repartition, reinstall of XP Home from the set of recovery disks made when I first had the HP Laptop in question, I inadvertently left the Recovery CD (#1 of 18) in the CD drive. Choices were "Repair", "Format & Reinstall" or "QUIT"
    I selected "QUIT", and mirable dictu, the boot proceeded, and the HD (and OS) miraculously reappeared. I then tried the WinXP Pro installdisk, and ignored "press any key to boot from CD"...the maching booted again!
    SO, I have no idea what's happening, but apparently the work-around is to boot with an install or restore disk in the CD player, and NOT boot from the CD.
  10. 8088

    8088 TS Rookie

    Like many others, this problem has been incredibly aggravating! After reading the many posts about this problem, I was able to fix it...by writing 0's to the hard drive using the manufacturer's utilities. In this case, Western Digital. A bit more Googleing also turned up information having to do with VIA chipsets and how they interact with hard drives and W2000 and XP. My motherboard does have a VIA chipset and I was attempting to originally install W2000. Even XP gave the same error message on a restart! Thanks to all of you for pointing me in the right direction and fixing my issue. I'm an A+ certified technician and have been involved with computers for over 20 years! This was one of the most vexing problems I've come across when attempting a clean install! I was ready to toss the motherboard, thinking it was defective! If it happens again, I'll know what to do!
  11. PeterKabai

    PeterKabai TS Rookie

    Fixed fixed fixed

    The Problem is that windows 7 and XP have different boot loaders.
    1 Boot from windows 7 boot DVD
    2 Select recover your computer
    3 Open command prompt
    4 Type "Bootrec.exe /FixMbr" withought the quotes
    5 Restart computer normally.

    Boot loader is repaired and no data is lost!
    Worked perfect for me!
  12. PM99

    PM99 TS Rookie

    YEEEEES! It worked!

    Thanks for posting this. 8.am in the morning .... now im off to bed. God damn that was a long night.
  13. walkeraudio

    walkeraudio TS Rookie

    Hi. I just joined this forum and i don't even know if this thread is still active. I just encountered this problem having given up on windows 7 for the time being and decided to go back to XP. After a complete reformat of the drive the XP installation comes up with this error after first reboot. I tried writing zeros to the drive with the world digital tools and no luck. Windows 7 seems to have left a ghost on the hard drive to prevent us going back to XP which can't be removed by a normal reformat. Microsoft just get sneakier every day.
  14. walkeraudio

    walkeraudio TS Rookie

    I think i sussed it if anyone's still interested. I was formatting my SATA drive from an older HD with windows 7 on it, i replaced this with another old Hd with XP installed, booted up to XP and formatted the sata drive from XP. I then removed the older drive leaving only the sata drive and ran the widows XP installation disk as before, this time it worked. Windows 7 must have been formatting the drive for windows 7 and i suspect i've been a bit thick and should have thought of this sooner. ;)
  15. jobeard

    jobeard TS Ambassador Posts: 12,899   +1,530

  16. akapal

    akapal TS Rookie

    perfect and acurate solution worked for me also thank you very much!!!!!!!!!!
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...