1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Error Message: Setup did not find any hard disk drives installed in your system

By trigger753 ยท 204 replies
Dec 22, 2004
Post New Reply
  1. tyleryoungblood

    tyleryoungblood TS Rookie

    Grats! I'm glad my post was helpful to you and to everyone else who have replied. I've been out of the country for months and therefore I have been unable to reply to anyone's posts. I hope everyone's dell is still working splendidly!

    To Answer your question about being unable to change your dell back to the original factory settings as reccommended, I'd say if you can reboot and use your computer without any issue than don't worry about changing your settings back to their original state like Dell reccommends. Hope that helps.

    - Tyler
  2. tyleryoungblood

    tyleryoungblood TS Rookie

    Since this was posted back in Dec 2005 I would imagine that you've already found an answer to this question (or you've tossed your dell out the window). But in case you haven't or in case others have the same concern, here's the answer. You shouln't lose any data by changing to "combination". Changing this setting to combination only changes the way in which your computer looks for / recognizes your factory SATA drive. Hope this helps, again sorry for taking months to reply - Europe called and i had no laptop.
    - Tyler
  3. tyleryoungblood

    tyleryoungblood TS Rookie

    :haha: No problem. I'm glad my post was helpful to you. You won't be sorry that you registered for this forum. Techspot has helped countless people. Enjoy!

    - Tyler
  4. tyleryoungblood

    tyleryoungblood TS Rookie

    :confused: A few questions:
    What make/model/year is your dell. is it newer?
    Are you sure that your dell came with a factory SATA drive?
    - If it did not come with a SATA drive this might explain why you don't have the ability to configure SATA devices in you Setup screen. Other than that I'm not sure if I have enough information to help you out. Sorry bud.

    - Tyler
  5. GQmancini

    GQmancini TS Rookie

    Hey tyler, i've seen a lot of the help you've given and i'm confident (cross fingers) that you can help me too!

    This is the closest forum i've found to my problem. As with the last guy, my Dell is too old to have those setup options everyone else seems to have. I have a Dimension desktop 4300, circa 2002. 1.6 Ghz, 256DDR, 40gig hard drive that I wiped clean and set active partition...

    Well my problem is, like everyone else, when i boot (even before winxp cd begins xp setup) the screen reads "Primary Hard Drive 0 Not Found... Press F1 to continue press F2 to enter setup" etc...

    When i continue windowsXP Setup begins. If i allow it to load drivers, when we arrive at the screen that reads "Press Enter to set up a new Windows XP, Press R to start recovery" no matter which I choose the next screen is always the same. It reads "Setup did not find any hard disks on your computer and can not continue.

    This is what found me to this forum. I tried the various drivers people posted in here to install during the F6 portion of XP Setup, but none prevailed!

    In the setup menu of my dimension 4300, relating to hard disks the only options i have are

    HARD DRIVE 0 - Auto (or OFF), and
    HARD DRIVE 1 - Auto (or OFF)

    Unfortunately, nothing about SATA or AHCI or whatever. I might be able to post a picture of it if that would help?

    Any help would be more appreciated than you could know! I will eagerly await :cool:
  6. tyleryoungblood

    tyleryoungblood TS Rookie

    Hi GQmancini -

    There are a few things that you might try, but it's really hard to know what the problem is without being there to fiddle with the computer. Some of the things I want you to try are obvious and you've probably already thought of them, and some are not.

    First off, you didn't specifically say that the drive you are dealing with is a SATA drive (although it probably is a factory SATA if you're getting a "drive 0/drive 1" mesage rather than "master/slave" message). However, if your drive happens to be an IDE drive, try step 1 below, if the drive is indeed a SATA drive, skip to step 2.

    Step 1: IDE Drive -
    There is a chance your computer shipped with an IDE drive for your C: drive. Just because your computer has the ability to support SATA doesn't necessarily mean it shippped with a SATA for your C: drive. (If the drive is a SATA drive skip this step since jumper settings don't matter for SATA). If this drive is an IDE and you pulled the drive out and popped it into another computer to format, than you probably changed the jumper setting to "slave" (because the computer that you used to format would likely have the C: set to "master"). Failure to set the jumper back to "master" when you put the newly formatted drive back into your computer may be the problem. Also, some older computers not only require the jumper setting to be set to master, they also require the drive to be plugged into the IDE cable in a specific order (but they often say "master" and "slave" on the IDE cable if this is nessary, especially if it's a Dell). Also, if your drive is and IDE and your boot sequence is set to boot from SATA drive 0, you may need to change your boot sequence to boot from "Primary Master" - your IDE drive. (Remember tho, if you change your boot sequence make sure that you boot from Floppy, then CD, then HD, that way you can always boot from a floppy or CD if necessary and bypass your HD boot sequence).

    Step 2: SATA Drive -
    Now that I've said all that above, chances are your drive is most likely a SATA drive if it is factory and you're getting "Primary Drive 0 Not Found". So the first thing I'd check is that your SATA data cable is plugged into the "Drive 0" slot on the motherboard (and also into the drive of course). Next, make sure that you are using the SATA Power cable OR the IDE power cable - NOT BOTH. I know that seems silly, but it happens and people burn up there drives that way.

    Step 3: RAID Config -
    It doesn't sound like you had this computer set up in a RAID configuration (IE RAID 0 or Striped with another drive). But you may want to check to make sure that there isn't a RAID configuration setting. I'm not sure how Dell handled RAID back then and I'm also not sure that you would have an on-board RAID controller, but there's a chance. If so, turn off RAID so the computer will recognize the drive as a non-RAID drive setup. As far as the Drive 0 / Drive 1 thing goes, your primary drive is Drive 0 and you would want to set Drive 0 to Auto or On. Drive 1 would be any secondary drive that you had installed. In other words, if you had 3 drives in your computer (C:, D:, and E: ) they would be numbered 0 (C), 1 (D), and 2 (E). So set Drive 0 to on or auto and make sure the drive is plugged into the Drive 0 slot on the motherboard.

    Step 4: If none of these steps work, can you confirm that the drive is still functional? You may need to plug the drive into another case to make sure that it spins up and can be written to. It's unlikely that after formatting your drive suddenly decided to die, but there's always a chance. Can you hear the drive spin or power up when you try to boot?

    Note: Since I've never had exactly the same problem you're having I'm kind of shooting from the cuff with some different things I would try. In other words, I'm not sure if I've helped you at all, but I hope so. As with most things, it's pretty difficult to diagnose and fix without being there (for instance, when was the last time a mechanic fixed a car w/o being there to listen and try things). The steps above are the first few steps I would take if I was sitting in front of your computer. I hope one of them helps, but as I said earlier, you may have already tried all of them. If so, please feel free to reply and we'll keep trying other steps to try to figure it out. As a last resort, you could always take the computer in to a professional. Most professionals could have the computer booting in 15 minutes. At $60/hour you could probably get the computer fixed for $15-30 bucks. But if you're anything like me you'd rather search forums for weeks and rack your brain trying to figure it out on your own. And that's ok too. :)

    No matter what happens, please post what steps you took to get it fixed so others with your same error message will know what to try.

    Good luck and let me know if anything I suggested helped. If not we'll keep trying other things. Who knows, I may wake up at 3 am with the answer and it will probably be the most obvious of all that I missed - if so I'll post it. Or maybe someone else will read this and the answer will jump out at them, if so hopefully they will post it.

    In any case, sorry for the long post and good luck to you.

    - Tyler
  7. GQmancini

    GQmancini TS Rookie

    thanks :)

    I will try all the steps at home (i'm at work right now)

    I think i tried something close to a few ideas that you had, but probably not the exact step correctly. It's always that one little thing you forget to do, so thanks very much for the quick response!

    As a side note, i asked my company's IT tech guy today if he could help me with my Dell problem (we all have dells, he works on 1000's of Dells a month) and before I could even finish my explanation of the problem he said "buy a new one." Bum.

    so needless to say, you are much more helpful thus far.

    I will post back with results, thanks again!
  8. tyleryoungblood

    tyleryoungblood TS Rookie

    Hi GQmancini -

    I had to laugh when I read your reply. There is something to be said about buying a new dell versus spending the time, effort, money, and energy to fix your old one. Computers really only have a 2-4 year lifespan anyway. After that timeframe they are either so outdated that they aren't worth keeping or they are starting to have problems on both the hardware and software end. A few ways to postpone these two certanties is to buy the best computer available at the time (thus streching the useable lifespan to maybe 5 years) and to keep your computer impecably clean (compressed air works best for this, but do it outside and unplug fans prior to spinning them with the compressed air - they can create voltage by being spun by the air - kind of like a wind powered generator. You don't want to create voltage by spinning a fan and fry something on your motherboard). An even better option is to hold the fan stationary while blowing it off, that way it doesn't spin too fast for its bearings and it doesn't create any voltage. Also, use a can of compressed air rather than an air compressor. Compressors can have condensation in the air which can detremental to electronic components (obviously), and compressors can also be too forceful for the delicate parts inside the machine. The can of compressed air is ideal because it is moisture free and comes with a tiny straw to help direct the air into all the little crevices. But these are things to keep in mind when you purchase your next Dell. And for less than $500 you can have a brand new machine from Dell that's faster than your current machine. But again, I must remember that I myself still have an X86 and a 386 from over 10 years ago, as well as a first generation Data East laptop from the 80's with a monochrome screen (weighs over 15 pounds). So I understand how hard it can be to part with your old system for a "newer/better" one. Lets just hope that one of the steps I previously suggested helps. Good luck.

    - Tyler
  9. amoorthy

    amoorthy TS Rookie

    Hard Drive crashed?

    Hi all,
    Like others I too have the problem of "Primary Hard Disk Drive 0 not found". However, I think my drive may actually be cooked. Please let me know if you think I have options...

    1. I have a Dell Inspiron 600m laptop, with the factory installed hard drive... 30GB Seagate... IDE I presume.
    2. One day when I shut down and restarted I got a blue screen with "unmountable boot volume". After a few restarts and the problem persisting the error message changed to Primary Hard Disk Drive 0 not found". There is a faint clicking sound coming from the drive for a while then it stops.
    3. I tried booting from the WinXP CD to enter recovery console but got the error "cannot find any hard disk drives installed".
    4. I bought a USB Hard Disk Enclosure and plugged my busted HD into this device. But when I plugged in the USB cable into a functioning computer Windows Explorer doesn't see any USB device. The clicking sound continues to come from my drive. (there is also a faint burning smell... I don't know if I'm imagining things but if this is true then for sure this drive is cooked).

    I presume this news thread does not apply to me as much since I don't have a SATA drive but I wanted to check anyway in the hopes that someone can help. far too much data is on this computer to be lost so I pray I'm not screwed. thanks.

    arjun (amoorthy@gsb.stanford.edu).
  10. Rinat

    Rinat TS Rookie

    NTLDR is missing

    Dear All,
    Thank you for the valuable information on installing xp on my Dell dimension 9150. It was very helpful. After installing xp, when I try to change the SATA operation to RAID Autodetect/ACHI or to RAID Auto detect/ATA I get an error message saying missing NTLDR. Otherwise the computer seems to be functioning fine on the combination option. The hard disk I got is: DataSafe 160GB

    Since my computer did not come with a floppy drive I did not include any special drivers.

    What is NTLDR? Is it connected to the missing driver? Is it possible to include this driver after the installation? Can I keep using the computer as it is with the combination option in the BIOS? Will there be a problem in performance? Do you recommend getting a floppy and re-installing everything again?

    Thank you,
  11. es84

    es84 TS Rookie Posts: 47

    uniqueclone-- sata drives are not primaary or secoindary , there are Sata 0 and 1 depening on how many drive u have on the system . one SATA conroller can control 2 hdd . there are 2 cables for the hard drive . so for one controller there are 2 drives . new intel mobos have mostly 2 controller . there is no primary and slave, the system will boot from the hard drive which is set to SATA 0 or SATA 1 depending on the Bios
  12. thrash_head

    thrash_head TS Rookie

    I have the same problem that everyone else is getting, only my problem is with a custom built computer. I wanted to try what he posted above, but my bios does not have anything like he stated. I can not find anything about setting a floppy to internal. Nor can i find anything about a "sata combination setting" the only thing i find about sata, is changing the IRQ#.... PLEASE HELP!!

    I have the Asus PS800D-X Motherboard, Pentium 4 3.0ghz, 2gb of ram, DVD-rw, Floppy, and a 430w PSU. I can not find a way around this problem!!!
  13. zzipp

    zzipp TS Rookie


    I also have the same problem as many of you, my BIOS does not recognize the hard drive during set up. The problem for me is that i do not found the BIOS options you have given, i see "Primary Hard Dirve: None" buit i can not modify it anyway, no options related to hard drive settings, i think.

    I have a Dell Latitude D600 (Pentium M, 1.4GHz, Win 2000), and several days of work in this HD, so i am quite worry about it. I would thank any help

  14. tyleryoungblood

    tyleryoungblood TS Rookie

    Hi Amoorthy,

    It does sound as though your HD is having some problems. Does the HD spin-up? You'll know if it is spinning because it will hum or vibrate and usually the spin-up makes a distinct whirring noise. The clicking is usually made by the arms inside the HD that actually read the data on the disk. You'll have several arms similar to the arm on a record player that reads the sectors off your HD. They move back and fourth across the surface (w/o touching) of the HD to access the data. Usually a "clicking" without the "whirring" of the spin-up of the drive means that the drive isn't working properly. A professional may be able to salvage your data using special equipment, but that will only be possible if you or the professional can get the HD to spin-up. The good news is you can always replace the HD. The bad news is it's typically more difficult to crack open a laptop and reinstall an OS, but not a lot more difficult. Hope that helps.

    - Tyler
  15. tyleryoungblood

    tyleryoungblood TS Rookie

    Hi Rinat, here's the steps for reinstalling the NTLDR files:
    1. Insert the Windows XP bootable CD into the computer.
    2. When prompted to press any key to boot from the CD, press any key.
    3. Once in the Windows XP setup menu press the "R" key to repair Windows.
    4. Log into your Windows installation by pressing the "1" key and pressing enter.
    5. You will then be prompted for your administrator password, enter that password.
    6. Copy the below two files to the root directory of the primary hard disk. In the below example we are copying these files from the CD-ROM drive letter "E". This letter may be different on your computer.

    copy e:\i386\ntldr c:\
    copy e:\i386\ntdetect.com c:\

    7. Once both of these files have been successfully copied, remove the CD from the computer and reboot.

    more information on this can be seen by going to:

    Hope that helps. Oh, and NTLDR is short for NT loader, NTLDR is a program loaded from the hard drive boot sector that displays the Microsoft Windows NT startup menu and helps Microsoft Windows NT load.

    - Tyler
  16. Bardaf

    Bardaf TS Rookie

    Setup did not find ... on a HP Nc6320


    Same problem using the Windows 2000 CD on a brand new laptop HP Nc6320 : "setup did not find any hard disk drives installed ..." Our usual "no-brand" Ghost CD does work but the computer crashes when starting Windows 2000 mini-setup.

    Solution : reboot pressing F10.

    In the BIOS, goto "System Configuration", "Device Configurations", and set SATA native mode to disabled. Now you can install, add the SATA-AHCI drivers, and here we go.

    Bardaf, Brussels

    Note : if you want to come back to "SATA native mode enabled" after this installation, I succeeded to do it so (doesn't mean that it will work with another system and OS):

    - after the successful installation, switch off.
    - insert a floppy with the SATA drivers
    - insert the Windows 2000 CD
    - boot from CD and select install Windows 2000
    - when the system checks the disk and says like "found a Windows 2000 installation, do you want to repair it ?", press R to accept
    - wait until this repair is finished. Now you boot in native SATA mode.
    - (if you had IE6 installed, you need to reinstall it, because the Windows 2000 repair reverts to IE5)
  17. young-gun13

    young-gun13 TS Rookie

    Awesome! Got one problem though. When I go and change it back to RAID AUTODETECT / AHCI, I save and reboot, then this message comes up (it's not an error message it comes up all the time back when my PC was normal) and it just stays there. So I changed it back to combination and the computer itself works fine, but the sound card, video card, dvd-drives, ethernet cable, and a host of other things don't work anymore.
    Help would be AWESOMELY aprecciated.

  18. heardsg

    heardsg TS Rookie

    Configuration: Precision 380 - have taken the factory SATA, and put in a StorCase frame and carrier the system cannot boot the drive. In the factory configuration and set up the SATA disk works fine. It's when I install the SATA drive into frame and carrier and use the cabling from the frame to SATA-0 is when I cannot boot the drive.. I have left the factory installed jumpers alone on the frame; it's still a Master Drive. I have taken your advise in the System Set up screen (F2) - Diskette Drive is properly set to Internal and I have made sure that Drive 0: SATA-0 is set to "ON" ( I have turned off the SATA-2-3 & -4). Gone to SATA Operations: Changed the SATA setting to "COMBINATION"which now the system sees or identifies the SATA drive for that Thanks! " (In modified config system does not see the drive in the Auto DETECT/AHCI) ; I have ensured that the boot sequence was set to CD rom before HD and made sure the CD XP reinstall is ready. I hit enter and I am thinking I am reinstalling XP; I see the licensing agreement, but that is as far as I get. The option to delete a partition or perform a full reinstall it will not let me do. I know I have added several variables that it could be, but maybe someone has come accross this situation i.e. maybe the frame pinout, carrier or the associated cabling.
  19. tyleryoungblood

    tyleryoungblood TS Rookie

    Hi Young-gun13,

    Don't worry about changing the computer back to RAID Autodetect, that was something Dell recommended, but they couldn't give a reason as to why it was a good idea. If your computer works without changing it back I wouldn't fool with it. If you've re-installed your OS you will most likely have to reinstall the drivers for your soundcard, video card, etc. That's pretty normal. If you still have your factory disks you can use those, or you can go to driverguide.com and get nearly any driver you need (you'll have to register but it's free and they don't bombard you with annoying spam emails).

    Hope that helps.

    Tyler -
  20. tyleryoungblood

    tyleryoungblood TS Rookie

    Sorry my friend. I'm not familiar enough with the Precision 380 or the StoreCase frame. Hopefully someone else can help you on this one.

    Good Luck!

    Tyler -
  21. heardsg

    heardsg TS Rookie

    Finally somehow I got the BIOS to read the SATA disk. But, upon reboot I am getting a "Read Disk Error" I am thinking I have a timing problem either with the motherboard or the StorCase frame. I need to figure out if I can adjust the timing speed on the motherboard or in the StorCase.
  22. young-gun13

    young-gun13 TS Rookie

    Awesome! I went on Dell and got the drivers I needed and my computer works great now! Thanks, Tyler, you rock!

    I'm still gonna get a mac though... :stickout:
  23. heardsg

    heardsg TS Rookie


    Once I switched to "Combination" the bios found the Removable HD (factory drive inserted into a StorCase"frame and carrier). But when I tried to boot the system it would come back with a read error. I took the HD out of the Storcase frame/carrier and hooked it back almost to factory and it worked like a champ. So, I called Dell and there was no joy. So, I called StorCase and found that my Line Speed of my HD of 3.0Gbps (my HD is a Western digital) was to fast for my StorCase frame to interpret and would create data errors/Read error. They had a fix for the read error by jumpering pins 5&6 would reduce operation down to 1.5GPS on my drive. I installed the jumper and put the drive back into the carrier & frame and vola, I had success. I am still in "Combination" currently; I am going to see what happens if I go back to Radi Autodetect AHCI. Press On!
  24. Boomaroo

    Boomaroo TS Rookie

    So simple, and yet...

    ...pure genius. Gentlemen, a million thanks. I've been going bloody nuts trying to dual install English and Japanese copies of XP on my wifes new Dell and this problem has been blocking me for hours. I searched high and low all over the Net, searched all through the Dell and MS sites and got nothing but stress. You guys were spot on, first time.

    Cheers and thanks again!

    Rob in Tokyo
  25. tyleryoungblood

    tyleryoungblood TS Rookie

    Awesome Rob! Glad we could help. Have fun in Tokyo. I wish I was there!

    - Tyler

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...