Error Message: Setup did not find any hard disk drives installed in your system

mwkbrown

TS Rookie
Another thanks to Tyleryoungblood and LunaNM re: the [apparently very common] issue of reinstalling windows on a Dell Dimension 8400 w/ a SATA drive that Windows cannot find ... I followed your advice [after many hours of spinning my wheels], changed the BIOS setting to "combination" and get things working immediately.
 

michael78779

TS Rookie
Thank You!!!

I spend three hours trying to figure this out, and wehn I felt it was time to throw the computer, I went to GOOGLE, and this was the first result, and I ended up spending three minutes for what I couldn't to in three hours.
 

putoffbypc

TS Rookie
Hello All,

Very informative thread. Thanks to Tyleryoungblood and all others.

But those steps did not help me. PLEASE HELP! I have already spent two days trying to solve this problem.

Problem: I am trying to install Windows 2003 Server on WD 250GB SATA drive mounted and connected properly inside the PC. I boot from DVD/CD Rom drive. Windows 2003 Setup screen shows up. Windows setup goes through loading various files. It shows Welcome to Windows Setup screen. Gives three options 1) To install Windows press Enter 2) to repair windows press R 3) to quit setup F3. As soon as I press enter to install windows I get 'Setup did not find any hard disk drives installed in your system.....etc.' message.

I tried changing various BIOS settings as below. I am pretty sure I tried most of the combinations:

BIOS recognizes the drive. It shows this drive on Disk Configuration option.
My BIOS does not have the options posted in this thread. I see following options under Drive Configuration menu of BIOS:

1) Use Automatic Mode <Enable/Disable>
2) Use Serial ATA <Enable/Disable> -- This option shows only when #1 is Disable
3) ATA/IDE Mode <Native/Legacy> - Native is default
4) Configure SATA as <IDE/RAID/AHCI> - RAID is default
5) S.M.A.R.T. <Enable/Disable> - Enable is default - Don't know what this means.
6) Primary Channel - <Enable/Disable> - This option is shown only if #1 (Use Automatic Mode) is disabled.

It also shows SATA Port 0 - through 3. Only Port 0 shows my drive WDC WD2500KS-00M - 250 GB ( This means BIOS recognizes this drive )

I do not have floppy drive. Is there any way to install drivers using USB flash or USB external HD? I have only one CD/DVD drive (which is used to install Windows 2003)

According to the posts on this thread, I am not clear if I need to have floopy drive just to get Windows 2003 installation going or I need to do that only if I need to change RAID configuration.

Also, I am not sure if this drive can support Windows 2003 server?It lists Windows XP/2000/98/Me. Don't know which drivers to use if needed.

This is a new drive.

My Hardware Configuration is:
I have Gateway 5404 - With Intel Pentium D 2.8 GHz. With Western Digital 250GB SATA-300 WD2500KSRTL drive. Intel Motherboard D945GCL.

Don't know about BIOS manufacturer. BIOS Version: CF94510J.15A.0028.2006.1213.1629.

PLEASE HELP! I have already spent two days trying to solve this problem.

Thank you!
 

rafaeliii

TS Rookie
As I can see, you can´t install Windows 2003 in your Gateway PC ´cause you get this message STOP: 0x0000006B (0x0000003A, 0x00000002, 0x00000000, 0x00000000), or some like that, if this is so, then this may help you...

I tryed to install WinXP in my Gateway PC that has your same motherboard, but when started from my install cd it just stopped and it showed me the message I already told you. My PC came up with Win Vista preinstalled so the problem i thought it was the Bios that didn´t identify my hard disk. well, I tried so many ways to make the bios recognize my hard disk, including all you did, but i was wasting my time, the key was the program that was making a backup of the system from WinVista, and I found out when I saw this link from Microsoft: http://support.microsoft.com/kb/330134/es it comes in spanish but also you may find it in the english version. The thing is to uninstall that program from WinVista, I can´t remmember what´s the name but its pretty easy to identify it, You´ll know which one it is. So after that turn off the computer to complete the uninstall process and turn it back on to enter the Bios to configure this parameters in this way:

1) Use Automatic Mode <Disable>
2) Use Serial ATA <Enable>
3) ATA/IDE Mode <Native>
4) Configure SATA as <IDE>
5) S.M.A.R.T. <Disable> -
6) Primary Channel - <Enable>

After all this you may install any OS in your PC, because for security the program that backs up the WinVista protects the system with a hidden partition and if you uninstall that program it stops that protection.

To end just you need to enter back again to the Bios to set the options I mentioned to default, to get stable your system.

I hope it really worked to you, so long!!!

Edited by Moderator: Removed quote. There`s no need to quote the post directly above your own, unless you`re only replying to a specific section, in which case you would only quote that section. ;)
 

t1m

TS Rookie
Stryfe said:
"That's nice. Now how the hell do I get my system working again?"
If you want to continue using the "RAID Autodetect / AHCI" setting in the BIOS of your shiny Dimension 8400, you *must* have a floppy drive. Without a floppy drive, you will not be able to load the driver that will allow Windows XP to communicate with your SATA controller and by extension, your SATA hard drives.

There should be a method to do this without a floppy drive, but as of right now it's only a theory in my mind and I don't know if it would actually work.



--Stryfe
This topic is definitely my problem. The only thing is I don't have a floppy drive. That's why I quoted stryfe, my question is if there is any solution for this? Otherwise i don't know how to solve this problem.

Thanks tim
 

IcedZ

TS Rookie
tyleryoungblood said:
Reboot your system and hit F2 as soon as you see the Dell startup screen (the options are F2 for setup, F12 for boot sequence).

In the System Setup screen, do these steps.

Select Drives:
Make sure your Diskette Drive (3.5 floppy) is set properly (Usually set to Internal)
Make sure that "Drive 0: SATA-0" drive is set to "ON"

Go to "SATA Operation":

Your system proabaly came set to "RAID Autodetect / AHCI" - THIS SETTING CAUSES YOUR SYSTEM TO GO INTO AN IDE LOOP AND DOESN'T ALLOW IT TO FIND YOUR FACTORY INSTALLED SATA DRIVE.

CHANGE THE SATA OPERATION SETTING TO "COMBINATION"
Tyler.. I LOVE YOU! I don't know you, but I love you. Big help. THANKS! I also just registered to give you my thanks. I think many of us appreciate it.
 

Sever9

TS Rookie
PBR 2...failed on a Dell Inspiron 6000

tyleryoungblood said:
I completely feel your pain. I have the same system and just fixed the same problem. Here's what I did. And by the way, 2 hours of tech support with Dell did nothing for me other than give me practice understanding Pakistan accents. I eventually stumbled on the solution myself w/o dell's help.

Reboot your system and hit F2 as soon as you see the Dell startup screen (the options are F2 for setup, F12 for boot sequence).

In the System Setup screen, do these steps.

Select Drives:
Make sure your Diskette Drive (3.5 floppy) is set properly (Usually set to Internal)
Make sure that "Drive 0: SATA-0" drive is set to "ON"

Go to "SATA Operation":

Your system proabaly came set to "RAID Autodetect / AHCI" - THIS SETTING CAUSES YOUR SYSTEM TO GO INTO AN IDE LOOP AND DOESN'T ALLOW IT TO FIND YOUR FACTORY INSTALLED SATA DRIVE.

CHANGE THE SATA OPERATION SETTING TO "COMBINATION"

Reboot - make sure that the boot sequence is set to CD rom before HD and make sure that the reinstall CD is in the drive. Setup will load, hit enter to reinstall XP. Your HD should now be detected and you should see the licensing agreement.

If you have your files backed up I reccommend deleting the partition and reformatting prior to installing XP, it will give you that option after the license agreement.

Once you have successfully reinstalled the OS, Dell reccommends that you change the SATA Operation setting back to RAID AUTODETECT / AHCI (or back to whatever your factory setting was) to avoid any problems with other IDE devices installed on your system.

Hope that helps!

Good luck!

tyleryoungblood I'm calling for your help. I've read through most of the posts here, but I need some assistance on a Dell laptop. Last night my girlfriend was listening to music and she said a blue screen appeared with an error message. I didn't see the message, but I told her to restart. Now, every time the laptop is booting, on the www.dell.com header screen it says PBR 2.... failed .

Now, my question to you is how can I correct this matter without losing any data? There is a good amount of information needed for work and I need to get to it before I use the Dell provided ghost image and start from scratch.

I come to you because I see you have a really good track record on correcting this matter. If anyone else may provide some assistance on this matter, I'd greatly appreciate it too.

Thank you all,

Jon AKA Sever9
 

MattHaff

TS Rookie
Same Troubles

Hello,

I just finished building my own computer. I'm having the same problems. The boot priority is set correctly. The cables are connected good. The SATA is enabled, I even installed the Maxtor driver properly. I go to install Windows XP Professional and it says "setup did not find any hard disk drives installed in your system."

Any help would be great.
 

jyothee

TS Rookie
Setup didnot find any harddisk, Make sure any hard disk

Hi Friends,

This is my first post in techspot. I need your help badly. I am also facing similar problem with a slight change.

My laptop is HP laptop. I am trying to install Win 2000 server edition. But it is not allowing me to proceed further setup after clicking the Enter for proceed.
I am getting the following error.
SETUP DIDNOT FIND ANY HARDDISK DRIVE IN YOUR COMPUTER. MAKE SURE ANY HARD DISK DRIVES ARE POWERED ON AND PROPERLY CONNECTED TO YOUR COMPUTER, AND THAT ANY DISK-RELATED HARDWARE CONFIGURATION IS CORRECT.
THIS MAY INVOLVE RUNNING A MANUFACTURAL SUPPLIED DIAGNOSTIC OR SETUP PROGRAM.

Please help me out in this issue. I didnt have any floppy drive.

I would thankful to you if you solve out this issue.

Thanks in Advance.

JS
 

Ab0udi

TS Rookie
I Think I have Solution For You jyothee :grinthumb
First Thing Go to this Link And Download this Program HWiNFO32
Thin Installed In your Computer To Find Out what Is the Model Of Your Chipsit
Then Go To This Link Of Intel And Download The Driver For The Floppy Disk After That But The Windows In The Cd And Win The Installation Start Pres F6 And Insert The Floppy Disk
 

Stbean

TS Rookie
I had the same problem recently

Only if I read this thread earliear it would have saved me a week of frustration. I tried everything and eventually found combination mode worked!

Now my question is will Changing the setup to auto detect RAID have any effect on the software I installed in combination mode? I dont want to go through the headache of reinstalling all my software and drivers.
 

Quantum Leap

TS Rookie
Hi, I have the same problem that the computer dont recognized the Hard Drive is a DELL Dimesion 8400 but when I do the set up with windows she tell me that the setup cannot access this disk, she dont allow me to istall or Delete or Create a partition. It could be the hard drive or the IDE Cable this is the first time that my computer crash with that, but since a I bought it in Nov 04 and crash for first time a year later and the for 16 times more....but not with this error or horror!!..please help me........Do I have to buy a new Hard Drive?
 

Stbean

TS Rookie
As for the hard drive, Make sure all cables are securely fastened. Also , with caution you may try to feel vibration from the hard drive to make sure its powered up and spinning.

If your talking about same problem weve all been having just read the reply from first post of this thread, tyleryoungblood and follow his/her instruction.
 

stellaxxbella

TS Rookie
i have the same problem too
and i suck at computer, so i don't know how to check the drives or whatever it is

and i read tyleryoungblood's post
for the set up part
i can't find the first part
i don't get it
???
--->
Make sure your Diskette Drive (3.5 floppy) is set properly (Usually set to Internal)
Make sure that "Drive 0: SATA-0" drive is set to "ON"

Go to "SATA Operation":
 

thulasitk

TS Rookie
How do we do it for a Laptop??

tyleryoungblood said:
I completely feel your pain. I have the same system and just fixed the same problem. Here's what I did. And by the way, 2 hours of tech support with Dell did nothing for me other than give me practice understanding Pakistan accents. I eventually stumbled on the solution myself w/o dell's help.

Reboot your system and hit F2 as soon as you see the Dell startup screen (the options are F2 for setup, F12 for boot sequence).

In the System Setup screen, do these steps.

Select Drives:
Make sure your Diskette Drive (3.5 floppy) is set properly (Usually set to Internal)
Make sure that "Drive 0: SATA-0" drive is set to "ON"

Go to "SATA Operation":

Your system proabaly came set to "RAID Autodetect / AHCI" - THIS SETTING CAUSES YOUR SYSTEM TO GO INTO AN IDE LOOP AND DOESN'T ALLOW IT TO FIND YOUR FACTORY INSTALLED SATA DRIVE.

CHANGE THE SATA OPERATION SETTING TO "COMBINATION"

Reboot - make sure that the boot sequence is set to CD rom before HD and make sure that the reinstall CD is in the drive. Setup will load, hit enter to reinstall XP. Your HD should now be detected and you should see the licensing agreement.

If you have your files backed up I reccommend deleting the partition and reformatting prior to installing XP, it will give you that option after the license agreement.

Once you have successfully reinstalled the OS, Dell reccommends that you change the SATA Operation setting back to RAID AUTODETECT / AHCI (or back to whatever your factory setting was) to avoid any problems with other IDE devices installed on your system.

Hope that helps!

Good luck!
How do we do it for a Laptop. I recently bought a SONY VGN-FZ140E/B with Vista Home Premium Preloaded. I tried to install XP Pro by formatting the HDD. I got the same Hard Disk Drive not found Error.
Laptop doesnt have internal Floppy drive. Can it be done with external floppy drive or any other approach?

Capacity: 200GB9
Speed-3: 4200rpm
Interface: Serial ATA

Thanks,
Krishna.
 

thulasitk

TS Rookie
jyothee said:
Hi Friends,

This is my first post in techspot. I need your help badly. I am also facing similar problem with a slight change.

My laptop is HP laptop. I am trying to install Win 2000 server edition. But it is not allowing me to proceed further setup after clicking the Enter for proceed.
I am getting the following error.
SETUP DIDNOT FIND ANY HARDDISK DRIVE IN YOUR COMPUTER. MAKE SURE ANY HARD DISK DRIVES ARE POWERED ON AND PROPERLY CONNECTED TO YOUR COMPUTER, AND THAT ANY DISK-RELATED HARDWARE CONFIGURATION IS CORRECT.
THIS MAY INVOLVE RUNNING A MANUFACTURAL SUPPLIED DIAGNOSTIC OR SETUP PROGRAM.

Please help me out in this issue. I didnt have any floppy drive.

I would thankful to you if you solve out this issue.

Thanks in Advance.

JS
any luck???

Thanks,
krishna.
 

thulasitk

TS Rookie
Help !!!

Hello Friends,
I am in need of your help.
As mentioned earlier I bought the SONY VGN-FZ140E/B and while trying to install XP Pro, had the Hard disk drive not found error.

I am not sure if I can use an external (USB powered) floppy disk and supply the drivers you mentioned.
Please help me in solving this issue.

Help greatly appreciated!!!

Thanks,
Thulasi
 
Give it a try. You may be able to boot from a USB powered floppy depending on your system configuration. See if your bios allows you to turn that option (booting from usb devices) on/off. If you can, make sure booting from USB is turned on and see if it will boot from a USB floppy then. I know some servers can boot from a USB device, but I've never tried to do it from a desktop. Make sure that the USB boot sequence is set high in the que (i.e. set it so the computer tries to boot from USB devices before it tries to boot from CD, Floppy, or HD, if it allows you to change this setting). Other than that I'm not sure if I can be of any help to you since I'm not all that familiar with Sony's setup.

Good Luck!
Tyler Youngblood


thulasitk said:
Hello Friends,
I am in need of your help.
As mentioned earlier I bought the SONY VGN-FZ140E/B and while trying to install XP Pro, had the Hard disk drive not found error.

I am not sure if I can use an external (USB powered) floppy disk and supply the drivers you mentioned.
Please help me in solving this issue.

Help greatly appreciated!!!

Thanks,
Thulasi
 
stellaxxbella said:
i have the same problem too
and i suck at computer, so i don't know how to check the drives or whatever it is

and i read tyleryoungblood's post
for the set up part
i can't find the first part
i don't get it
???
--->
Make sure your Diskette Drive (3.5 floppy) is set properly (Usually set to Internal)
Make sure that "Drive 0: SATA-0" drive is set to "ON"

Go to "SATA Operation":
These steps are referring to the system setup/bios settings in your computer. If you've never entered your setup screen before (and feel lucky if you never have or have never needed to) than these steps are no doubt foreign to you. Refer to your computers manual or other web resources on how to properly modify your system settings. For my system I had to press F2 while booting to get the setup screen to load. Other systems may be different. Hope that helps.

Tyler
 
Stbean said:
Only if I read this thread earliear it would have saved me a week of frustration. I tried everything and eventually found combination mode worked!

Now my question is will Changing the setup to auto detect RAID have any effect on the software I installed in combination mode? I dont want to go through the headache of reinstalling all my software and drivers.
I'm not exactly sure what you mean, but if you're asking if you will lose your data if you change raid settings (from Raid 0 to Raid 1 for example), the answer is yes. You will need to reformat your drives if you choose to change Raid settings. Wikipedia explains Raid setup differences pretty well here:

http://en.wikipedia.org/wiki/Standard_RAID_levels#RAID_0

If your asking if you will lose data by switching from combination mode back to your previous mode, I think you will be safe - however, PC's have 1 truism, anything can go wrong at anytime :)

Hope that helps.

Tyler
 

The Oracle

TS Rookie
XPS XP SP1 Issue

I am having the same issue, I needed to upgrade from
SP1 to SP2 to upgrade Windows Media Player 10 to 11. I attempted this, it was not successful, only upon logging off the OS and into another account did I see that there were issues.

Blue screen of death Unable to locate component C0000135. I have gotten pretty far w/ Google and this web site, thank you for everyone who has documented these instances, and yes I am very fluent in DELL foreign language as well. I have changed my BIOS as below or at least tried to. The problem that I have is that I so not have the option for SATA Operation, my option is;

Drive Configuration
SATA Raid
Options or On or Off only, not combination

the solution below is not applying to my situation
I do not have a floppy drive

Solution applied is below, does anyone have any ideas?

Thanks

In the System Setup screen, do these steps.

Select Drives:
Make sure your Diskette Drive (3.5 floppy) is set properly (Usually set to Internal)
Make sure that "Drive 0: SATA-0" drive is set to "ON"

Go to "SATA Operation":

Your system proabaly came set to "RAID Autodetect / AHCI" - THIS SETTING CAUSES YOUR SYSTEM TO GO INTO AN IDE LOOP AND DOESN'T ALLOW IT TO FIND YOUR FACTORY INSTALLED SATA DRIVE.

CHANGE THE SATA OPERATION SETTING TO "COMBINATION"

Reboot - make sure that the boot sequence is set to CD rom before HD and make sure that the reinstall CD is in the drive. Setup will load, hit enter to reinstall XP. Your HD should now be detected and you should see the licensing agreement.

If you have your files backed up I reccommend deleting the partition and reformatting prior to installing XP, it will give you that option after the license agreement.

Once you have successfully reinstalled the OS, Dell reccommends that you change the SATA Operation setting back to RAID AUTODETECT / AHCI (or back to whatever your factory setting was) to avoid any problems with other IDE devices installed on your system.
 

joelfcruz

TS Rookie
thulasitk said:
Hello Friends,
I am in need of your help.
As mentioned earlier I bought the SONY VGN-FZ140E/B and while trying to install XP Pro, had the Hard disk drive not found error.

I am not sure if I can use an external (USB powered) floppy disk and supply the drivers you mentioned.
Please help me in solving this issue.

Help greatly appreciated!!!

Thanks,
Thulasi
Hello Thulasi,

I also have a sony vaio vgn-fz140e preinstalled with vista premium. I also got the same "hard disk not recognized " error message when trying to install xp. Have you solved this problem?

Joel
 

captaincranky

TechSpot Addict
Ouch......

SATA will not run in XP without a raid driver. Intel configures it's boards with a software layer that presents the HDD to XP as an IDE drive. "AHCI" the native mode for a single SATA drive can only be accomplished by Vista, (thus speaks Intel). I configured my Intel G965 to SATA mode "run as IDE" it picks them up the first time every time. The software abstraction layers provided by Maxtor's "Max Blast" and the like, probably accomplish the same thing.
 

raspiw

TS Rookie
SATA drive issue on Dell

Tyler you're a life saver!! I've been scatching my head over this one for longer than I care to admit. Your solution got me reinstalling Windows on this Dell and I REALLY appreciate it!!
 

D_LAN

TS Rookie
Okay...this SONY VGN-FZ140E/B is really getting to me. I'm trying to install XP/VISTA dual boot for a friend and Im getting the same old error everyone keeps getting "HD not found". I've had this problem before with my girlfriends HP DV6000 something...but I could fix this in the bios in seconds. Sony bios are so lame...the only thing you can do is check to see what time it is!

I dont have a USB floppy, but it does show you can boot just about ANY usb device you have available. How do I get this to work (lets say with a USB thumb drive) and where can I get these drivers for RAID?