Error message WINDOWS/SYSTEM32/CONFIG/SYSTEM on Windows startup

By White Knight123 · 54 replies
Jul 8, 2006
  1. fatballs

    fatballs TS Rookie

    I can not rebuild... The hard drives are fine so no need in replacing them. I just need to get into it and repair it. I know their has ot be a utility tool to be able to do it or someone much smarter than I that knows the trick.

    I want to get it all backed up then cut the RAID/STRIPE out. I am sick of this crap to be honest.

    Computer for sale here :)

    duel 8800gtx overclocked 768 mb ram on them :) asus 4x4 board duel fx74 processors and 4 gig of ram DOMINATOR corsair in a super swell case lol... dont let me forget the 500 dollar friggin processor to run all this crap...

    oh ya and windows xp64 bit to boot friggin thing is making me wanna toss it out the window...
  2. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    my understanding is you will need a commercial data recover company and ask
    for your data to be recovered (eg My Documents\). It may be expensive.

    see this for Raid Issues

    A striped configuration is the most difficult for recovery without a full backup in place.
  3. fatballs

    fatballs TS Rookie

    I messed with it for three months last time and finally it worked out. I can not remember what i did to get it working is the worst part...

    md tmp
    copy c:\windows\system32\config\system c:\windows\tmp\system.bak
    copy c:\windows\system32\config\software c:\windows\tmp\software.bak
    copy c:\windows\system32\config\sam c:\windows\tmp\sam.bak
    copy c:\windows\system32\config\security c:\windows\tmp\security.bak
    copy c:\windows\system32\config\default c:\windows\tmp\default.bak

    delete c:\windows\system32\config\system
    delete c:\windows\system32\config\software
    delete c:\windows\system32\config\sam
    delete c:\windows\system32\config\security
    delete c:\windows\system32\config\default

    copy c:\windows\repair\system c:\windows\system32\config\system
    copy c:\windows\repair\software c:\windows\system32\config\software
    copy c:\windows\repair\sam c:\windows\system32\config\sam
    copy c:\windows\repair\security c:\windows\system32\config\security
    copy c:\windows\repair\default c:\windows\system32\config\default
  4. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    YES! that's step ONE of Three documented by Microsoft.
    The system will be bootable again and then you can get the
    C:\WINDOWS\system32\Restore\rstrui.exe to bring your registry current.

    Best wishes :)
  5. bluedame

    bluedame TS Rookie Posts: 27


    try checking BIOS first if SATA Operation is set to AHCI / ATA / RAID.
    default setting should be AHCI.
    try changing it to ATA first then boot to CD again to do the repair
  6. fatballs

    fatballs TS Rookie

    none of it worked i cant get in to do it. I was copying to a notepad in case I could get the machine up and posted here on accident.
  7. Informer

    Informer TS Rookie

    If your registry hive becomes badly corrupted,you will probably be faced with error messages such as:

    * Windows could not start because the following file is missing or corrupt: \WINDOWS\SYSTEM32\CONFIG\SYSTEM

    * NTLDR is missing

    * Windows could not start because the following file is missing or corrupt:<Windows root>\system32\hal.dll

    when you boot your computer and Windows will fail to boot.

    If you are in a situation where you cannot boot from the Windows CD,which means you won't be able to access the Recovery Console,and also hitting F8 and choosing Last Known Good Configuration fails to fix the problem,then you will need to repair it manually.

    This will require that you have READ/WRITE access to the NTFS partition of the hard drive from within MS-DOS.You will need a program called NTFSDOS Professional.

    Download: NTFSDOS Professional 5.0 www dot flyupload dot com/?fid=6794034 (This is very old software - Abandonware)

    To create a boot disk,run BootDisk.exe.It will then require that you enter some licence details.You can find those details in the licence.txt file.Copy and paste them into the space provided.It will then ask you to specify the directory from which it will copy the required Windows files.For this,use your Windows CD which would be D:\I386 .Next you will need to choose where you want to save the boot disk to.Save it onto some floppy disks on drive A:\ .You will need 3 blank floppy disks.

    Boot up the computer using the floppy boot disks you made.It will take you into a MS-DOS screen.From there,run the file NTFSPRO.EXE and you will now have access to the files on your hard drive.

    Next you will need to type in the following lines as per the instructions from the Microsoft website:
    Remove the floppy disk from the drive and reboot the computer.Your Windows should now boot up and you will be able to carry out the remaining steps given on the Microsoft website,which are:
    ** Information in quotes is supplied from support dot microsoft dot com/kb/307545
  8. fatballs

    fatballs TS Rookie

    Looks like something I will try if it goes down again.
    I am up and running atm. I only see half the ram that is installed.

    I thought about doing the safe mode stuff now without going the the first steps or is their something I can do now with my xp64 bit to get in back on track ?
  9. Kelborn

    Kelborn TS Rookie

    I am experiencing a similar problem myself.

    In the Windows XP Recovery Console I press 1 for C:\WINDOWS

    The Mircosoft support site says I will be prompted for my admin password, but the only account on the computer (and the network) is my own, and I have no password. So I get no prompt and it just sits there with a 1 on the screen.

    In class atm and can't get back to my comp for a while. Should I just wait until it does something so I can use the the command prompts, or... I don't know. I'm not very familiar with command interface.

    I see that there are several different methods to remedy this situation that have been posted. Which one works the best? I really don't want to have to lose all my files, as I have many iTunes purchases that aren't backed up.
  10. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Just in case you missed this it's Press 1 then Press Enter, then Press Enter (if no Admin password)
  11. fatballs

    fatballs TS Rookie

    I tried a few of them and none worked on my x84 bit xp. I amtrying to find a way to get everything running properly without having to take it a shop for them to tell me it is fixed me pay them and still have the same issues...
  12. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Well after 3 months trying, you might start to think it's beyond you ;)
  13. Kelborn

    Kelborn TS Rookie

    Ok so I've been trying a few of the things here... and whenever I get to a command line that has the c:\windows\system32\config\system in it, it tells me that it cannot find the file specified.

    It would seem that my registy is not corrupt, but just not there.

    Any ideas as to where I go from here?
  14. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Microsoft's Windows XP Professional Repair Install step by step

    Microsoft's Windows XP Home Repair Install step by step

    And if that doesn't work
    Try to backup (you may need to physically mount the drive into another working computer, as a secondary (or slave) drive)

    Microsoft's Windows XP Professional Repair Install step by step (* Including Delete Partition)

    Microsoft's Windows XP Home Repair Install step by step (* Including Delete Partition)

    * Warning deleting the Partition will remove all User data and Windows system files
  15. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    MAKE SURE your view settings include View Extensions and Hidden files!
  16. mrlucky

    mrlucky TS Rookie

    I had this problem a few times now. The first time I had to reinstall. My operating system came preinstalled on my computer so I didn't have a reinstall disk to to the repair functions. I borrowed a disk and even call Microsoft tech support. They had me boot from the disk and hit r from the screen that you would perform an install or repair. I then got just a C: and not C:/windows so they said they couldnt perform the manual reinstall. I went to bed last night thinking I had to reinstall but I found this on the net and it worked. It looks like it worked for a bunch of other people also. I would spread this link so others won't have to go through this major process. this was pretty simple and no repair disk needed. Hopes this helps a few people. If this wokrs for you I would spread it to other forums. Mr lucky

    PS I cant post a link becuase I didnt have enough post so if someopne needs the link contact me at mrlucky200abc at yahoo dot com
  17. xyzxyzabcd

    xyzxyzabcd TS Rookie


    i have the same problem of
    however, after I hit 'r' there is only a blinking underscore left and I can't seem to type or do anything. I've got he windows cd... what is the problem?
    btw im using a macbook pro.
    Please help me asap. Thanks a million.
  18. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    huh? If you have the hardware,
    then your running OS X and that requires a VM like Vmware or Parallel's Desktop to
    run Windows.

    Please create your own topic for follow-up
  19. manifest305

    manifest305 TS Rookie

    Hello i have the same problem such as fellow members. but the only problem i face is when i put in my rev cd to repair the corrupted file the cd loads up and then it tells me that a file is corrupted and to press any key to restart the computer. as it seems it is probably the cd right? if so should i purchase a new one? Please help i hav a inspiron 1501 using the xp home edition rev cd
  20. singlemom06

    singlemom06 TS Rookie


    after not haveing my puter for almost a week due to this.. it was accually a barrowed one from a friend... there was one very important thing that i did not see in any online forums that i read... when the computer is starting up you have to press F12 to get into the boot menu... this helps alot....esp. in my case when the puter origanally came with xp but vista had been installed to it over a year ago...

    so start your puter when it first starts it should say press F12 to get to boot menu.. click on from CD and insert what ever you have for a recovery disk or in my case the vista disk and it was fixed in less than a min.... i was soooooooooooooo very glad to tell my friend i fixed it cause i cant afford to take it to a shop....
  21. onasis16

    onasis16 TS Rookie

    i have the same issue but mine wont let me run any cd it wont recognize the cd rom so i cannot access the boot menue or the recovery console,or comand prompt it just wont let me allowe to access the hard drive any ideas what i can do here? i tried to boot fronm a boot cd nothing ,tried to restore with original xp cd or format the set up screen will not come up instead the message comes up
    system32 error config system file corrupt or missing ,i dont know what to do anymore thanks for any help
  22. JoshuaLangit

    JoshuaLangit TS Rookie

    Please help!

    I have a problem about the file C:\windows\system32\config\system

    I tried copying the file from the repair folder using recovery console...

    after restarting... I can startup and use the computer...

    but when I turn off the computer and turn it on again... the said thing comes back...

    and I'll have to do it all over againg... and this event just happens all over again...

    I don't wanna do that .... is there a way to fix it without formatting or erasing personal

    files in the system??? PLEASE HELP!!!

    "Information About the file system32\config\system"

    system is a process which shows up on the tasks on mainly
    Windows XP, Windows 2003 server and later version of Windows.
    This is a default system counter and cannot be removed.
    You must not modify this file or else your system will be damaged.

    Author: Microsoft Corp.
    Part of: Microsoft Windows Operating System
    Location: %winroot%\system32\config\
  23. WinXPert

    WinXPert TS Guru Posts: 445

    I've addressed this problem before. Please read this thread

    What we tackled on that thread is a system folder not a file named system. I've see one (system folder containing virus) once on a PC infected with virut.
  24. NightmareSnake

    NightmareSnake TS Rookie


    I am also having this exact same problem since this morning, but when I put the Windows XP disc in and began setup, it tells me something like "Setup could not be done because there are no hard disk drives." Now that same computer was working perfectly fine yesterday, and all I did was install a few updates before turning it off. How do I fix it?
  25. groogruxking40

    groogruxking40 TS Rookie

    now I can't boot!

    I followed this step by step and the good news is that it got to the windows XP screen, but nothing happened after that.. just black... help please!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...