External hard drive dock no longer being recognized as USB 2.0

By mavrick3020
Feb 9, 2012
Post New Reply
  1. Alright, I've had this problem for the last few weeks. I have a Alura-tek USB2.0 SATA hard drive dock that I use with a 2TB WD Caviar Green. After using this dock on a different computer a few weeks ago, I came home to find that win7 was requiring me to install drivers for a new USB controller. It installed as a Generic USB controller and the hard drive dock was tied to it. I then get the message "This device can perform faster" and "click here for a list of ports..." It shows 6 ports, for the 6 ports I have on my computer under the two existing usb controllers I have. I've tried uninstalling the new controller, deleting the infcache.1 file and tried using the device on a different pc. It works find on other pc's, but not on my main desktop. I can't seem to find the problem. Also, the computer I used it with before it stopped working was running DeepFreeze, if that means anything.
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1) I'm guessing it says it's a Generic USB Hub ( not a Generic controller). (Check Device Manager)

    2) If you look at the USB controllers in Device Manager, at least one controller name should include word Enhanced and/or include the number 2? (Those are the 2.0 controllers)

    3) Do you have the power adapter connected on your drive dock station before you connect the USB cable to the computer?
  3. mavrick3020

    mavrick3020 TS Rookie Topic Starter

    yes, sorry. It says hub. It also says I have 2 Enhanced USB controllers with 6 ports each(I'm running on an ASUS P5QC). I've plugged it in properly and have tried different cables and power adapters.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...